Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#14424 closed defect (fixed)

libsdl_mixer cannot load libvorbisfile.dylib even though it is installed

Reported by: dbruce@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port:

Description

My new port (tuxmath) uses libsdl_mixer and libvorbis to play title music while the menus are visible. It fails to play the music - the tuxmath source for the port just says the ogg file is not found, although it is present. After modifying the tuxmath source slightly to generate more helpful output (namely by calling libsdl_mixer's Mix_GetError()) I get the following:

janis-lehtinens-imac:tuxmath_w_fonts-1.6.1 dbruce$ tuxmath 2008-02-21 12:02:15.474 tuxmath[55393:10b] Warning once: This application, or a library it uses, is using NSQuickDrawView, which has been deprecated. Apps should cease use of QuickDraw and move to Quartz. LoadMusic(): /usr/local/share/tuxmath/sounds/tuxi.ogg not loaded successfully Error was: Mix_LoadMUS(fn): Failed loading libvorbisfile.dylib: dlopen(libvorbisfile.dylib, 2): image not found

Looking in /opt/local/lib I find that libvorbisfile.dylib does in fact exist (as a symlink to libvorbisfile.3.2.0.dylib):

janis-lehtinens-imac:lib dbruce$ ls -l total 60952 (...) -rwxr-xr-x 2 root admin 82732 Feb 9 20:55 libvorbisfile.3.2.0.dylib lrwxr-xr-x 1 root admin 25 Feb 9 20:55 libvorbisfile.3.dylib -> libvorbisfile.3.2.0.dylib -rw-r--r-- 2 root admin 175064 Feb 9 20:55 libvorbisfile.a lrwxr-xr-x 1 root admin 25 Feb 18 13:00 libvorbisfile.dylib -> libvorbisfile.3.2.0.dylib -rwxr-xr-x 2 root admin 936 Feb 9 20:55 libvorbisfile.la (...) janis-lehtinens-imac:lib dbruce$

if I cd to /opt/local/lib and run tuxmath from there, it finds the lib and plays the music properly.

This is on an Intel iMac with Leopard 10.5.2

(this is my first bug ticket - sorry if I haven't completed it quite properly)

David Bruce dbruce@…

Attachments (1)

patch_Portfile.patch (577 bytes) - added by jmroot (Joshua Root) 13 years ago.
the fix from #14589

Download all attachments as: .zip

Change History (9)

comment:1 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: nox removed
Owner: changed from macports-tickets@… to nox@…

Assigning to maintainer of libsdl_mixer.

Why does it say "/usr/local/share/tuxmath/sounds/tuxi.ogg not loaded" -- specifically why is the prefix /usr/local? Your MacPorts appears to be in /opt/local, and hopefully your tuxmath port installed everything under the MacPorts prefix as well.

comment:2 in reply to:  1 Changed 13 years ago by dbruce@…

Replying to ryandesign@macports.org:

Assigning to maintainer of libsdl_mixer.

Why does it say "/usr/local/share/tuxmath/sounds/tuxi.ogg not loaded" -- specifically why is the prefix /usr/local? Your MacPorts appears to be in /opt/local, and hopefully your tuxmath port installed everything under the MacPorts prefix as well.

Hi Ryan - thanks for replying. The "/usr/local" prefix is simply because the build of tuxmath for the port itself did not have very informative error output. I edited a local copy of tuxmath's source to add the Mix_GetError(), did a "./configure; make; sudo make install" and found that the problem was that libvorbisfile.dylib seemingly could not be located. The /usr/local build of tuxmath still uses MacPort's libs.

Here's the output from the MacPorts-installed build of tuxmath:

janis-lehtinens-imac:Tuxmath.app dbruce$ tuxmath 2008-02-22 09:17:59.260 tuxmath[72745:10b] Warning once: This application, or a library it uses, is using NSQuickDrawView, which has been deprecated. Apps should cease use of QuickDraw and move to Quartz. LoadMusic(): /opt/local/share/tuxmath/sounds/tuxi.ogg not found

The program behaves exactly the same (and yes, /opt/local/share/tuxmath/sounds/tuxi.ogg exists), but without the call to SDL's Mix_GetError() it doesn't provide much useful info.

I don't think there is a previous trac ticket on this, but I found a mailing list item that appears to be about the same issue:

http://lists.macosforge.org/pipermail/macports-users/2007-November/007111.html

Thanks, David Bruce

comment:3 Changed 13 years ago by neric27@…

I had the same problem with frozen-bubble.

See http://trac.macosforge.org/projects/macports/ticket/14589 for a workaround. Hope this helps,

comment:4 in reply to:  3 Changed 13 years ago by dbruce@…

Replying to neric27@wanadoo.fr:

See http://trac.macosforge.org/projects/macports/ticket/14589 for a workaround.

Thanks - so are we just waiting for the patch to be committed?

(I'm still pretty new to MacPorts - can I assume the problem is in the process of being eliminated?)

David Bruce

Changed 13 years ago by jmroot (Joshua Root)

Attachment: patch_Portfile.patch added

the fix from #14589

comment:5 Changed 13 years ago by nox@…

Owner: changed from nox@… to macports-tickets@…

comment:6 Changed 12 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned

comment:7 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

Fixed in r39478.

comment:8 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.