Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#14492 closed defect (fixed)

ffmpeg staging error: usage: install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]

Reported by: fharbec@… Owned by: acho@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: kuraaku.deibiddo@…, brbttyl@…, max0913@…, stephen.ng@…, vermeulen.mp@…, khaksari@…
Port:

Description

When trying to install the ffmpeg port I get the following:

Error: Target org.macports.destroot returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_ffmpeg/work/trunk" && make install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_ffmpeg/work/destroot " returned error 2 Command output: make -C libavutil install-libs install -d "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_ffmpeg/work/destroot/opt/local/lib" install -m 755 "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_ffmpeg/work/destroot/opt/local/lib/libavutil.49.6.0.dylib" usage: install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]

[-o owner] file1 file2

install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]

[-o owner] file1 ... fileN directory

install -d [-v] [-g group] [-m mode] [-o owner] directory ...

make[1]: * [install-lib-shared] Error 64 make: * [install-libs] Error 2

Error: Status 1 encountered during processing.

Change History (10)

comment:1 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: kuraaku.deibiddo@… added
Owner: changed from macports-tickets@… to acho@…

Assigning to maintainer.

This problem was also reported on macports-users.

comment:2 Changed 12 years ago by richard@…

I just tried installing ffmpeg using sudo port -dv install ffmpeg +lame+faac+faad+x264+xvid (I enabled debugging and verbose messages). The installation was on a PowerMac G5 using Mac OS X 10.4.11 and MacPorts 1.6.0. I made sure that there was no previously installed version of ffmpeg before beginning the install. I got the following error message during staging into destroot:

DEBUG: Executing org.macports.destroot (ffmpeg)
DEBUG: Environment: 
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_ffmpeg/work/trunk" && make install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_ffmpeg/work/destroot'
make -C libavutil   install-libs
install -d "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_ffmpeg/work/destroot/opt/local/lib"
install -m 755  "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_ffmpeg/work/destroot/opt/local/lib/libavutil.49.6.0.dylib"
usage: install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]
               [-o owner] file1 file2
       install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]
               [-o owner] file1 ... fileN directory
       install -d [-v] [-g group] [-m mode] [-o owner] directory ...
make[1]: *** [install-lib-shared] Error 64
make: *** [install-libs] Error 2
Error: Target org.macports.destroot returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_ffmpeg/work/trunk" && make install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_ffmpeg/work/destroot " returned error 2
Command output: make -C libavutil   install-libs
install -d "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_ffmpeg/work/destroot/opt/local/lib"
install -m 755  "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_ffmpeg/work/destroot/opt/local/lib/libavutil.49.6.0.dylib"
usage: install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]
               [-o owner] file1 file2
       install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]
               [-o owner] file1 ... fileN directory
       install -d [-v] [-g group] [-m mode] [-o owner] directory ...
make[1]: *** [install-lib-shared] Error 64
make: *** [install-libs] Error 2

Warning: the following items did not execute (for ffmpeg): org.macports.activate org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

comment:3 Changed 12 years ago by aciddeath@…

The problem is that the ffmpeg svn repository pulls in the trunk of libswscale, even when we checkout an older revision of the ffmpeg svn. Later revisions of the ffmpeg repository have an updated configure script to handle the new version numbering that we are seeing from libswscale.

The symptoms we are seeing is because the version numbers from libswscale are evaluating to \ and causing the SLIBNAME variable to never get defined, this causes the install to break because it doesn't have 2 files specified on the command line.

comment:4 Changed 12 years ago by aciddeath@…

Replying to myself. I just successfully installed ffmpeg by changing my Portfile to use the latest revision from trunk (12275 when I built).

comment:5 Changed 12 years ago by richard@…

Bumping the svn.tag (in my case to 12276) in /opt/local/var/macports/sources/rsync.macports.org/release/ports/multimedia/ffmpeg/Portfile also fixed the problem for me (sudo port install ffmpeg +lame+faac+faad+x264+xvid on PowerMac G5 / Mac OS X 10.4.11 / MacPorts 1.6.0).

comment:6 Changed 12 years ago by ryandesign (Ryan Schmidt)

Summary: ffmpeg fails to installffmpeg staging error: usage: install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]

comment:7 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: brbttyl@… max0913@… stephen.ng@… added

Has duplicates #14539 and #14571. The issue was also reported again on macports-users by Stephen Ng.

comment:8 Changed 12 years ago by jmroot (Joshua Root)

Cc: vermeulen.mp@… khaksari@… added

Cc reporters of duplicates #14551 and #14633.

comment:9 Changed 12 years ago by reiffert@…

Resolution: fixed
Status: newclosed

Committed in r35073 and r35074.

comment:10 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.