Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#14542 closed defect (duplicate)

py25-hashlib doesn't compile: "unable to execute -DNDEBUG"

Reported by: mjs@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: python python25 Cc:
Port:

Description

There's some problem with py25-hashlib, a dependency of python25 (and py25-django-devel):

$ sudo port install py25-django-devel
Password:
--->  Fetching python25
--->  Attempting to fetch Python-2.5.2.tar.bz2 from http://www.python.org//ftp/python/2.5.2/
--->  Verifying checksum(s) for python25
--->  Extracting python25
--->  Applying patches to python25
--->  Configuring python25
--->  Building python25 with target all
--->  Staging python25 into destroot
Warning: violation by /Users
Warning: python25 violates the layout of the ports-filesystems!
Warning: Please fix or indicate this misbehavior (if it is intended), it will be an error in future releases!
--->  Installing python25 2.5.2_0+darwin_9
--->  Activating python25 2.5.2_0+darwin_9
--->  Cleaning python25
--->  Fetching py25-hashlib
--->  Verifying checksum(s) for py25-hashlib
--->  Extracting py25-hashlib
--->  Configuring py25-hashlib
--->  Building py25-hashlib with target build
Error: Target org.macports.build returned: shell command " cd "/Ports/var/macports/build/_Ports_var_macports_sources_rsync.macports.org_release_ports_python_py25-hashlib/work/Python-2.5.2/Modules" && /Ports/bin/python2.5 setup.py build " returned error 1
Command output: Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
running build
running build_ext
building '_hashlib' extension
creating build
creating build/temp.macosx-10.3-i386-2.5
-DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I/Ports/include -I/Ports/include/python2.5 -c _hashopenssl.c -o build/temp.macosx-10.3-i386-2.5/_hashopenssl.o
unable to execute -DNDEBUG: No such file or directory
error: command '-DNDEBUG' failed with exit status 1

Running "port install py25-hashlib" after receiving this error does seem to solve the problem, and install py25-hashlib successfully.

Change History (3)

comment:1 Changed 13 years ago by jmroot (Joshua Root)

Milestone: Port Bugs
Owner: changed from macports-tickets@… to mww@…

This seems to be a common problem with python-based ports. They somehow lose the value of $CC, but only sometimes. Clean py25-hashlib and try installing again.

comment:2 Changed 13 years ago by raimue (Rainer Müller)

Resolution: duplicate
Status: newclosed

Duplicate of #13930.

comment:3 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.