Opened 16 years ago

Closed 16 years ago

Last modified 14 years ago

#14552 closed defect (fixed)

aspell-0.60.5 failing to install at Staging aspell into destroot

Reported by: nightflame@… Owned by: jochen@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: aspell destroot install-info Cc: stefmit@…, lists@…


aspell is a dependency for kdebase3 and is failing to install. The failure message is below:

--->  Staging aspell into destroot
Error: Target org.macports.destroot returned: shell command "install-info /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_aspell/work/destroot/opt/local/share/info/ /opt/local/share/info/dir" returned error 1
Command output: install-info: No such file or directory for /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_aspell/work/destroot/opt/local/share/info/

Error: The following dependencies failed to build: kdelibs3 aspell bzip2
Error: Status 1 encountered during processing.

I have attempted to run 'port clean --all aspell' and re-run 'port install aspell' and it returns to the same error. Looking at the directory structure it is erroring out on, the directories all exist, but there appears to be no files in those directories.

This is on a Leapord Mac, 10.5.2.

Attachments (1)

debug.txt (107.3 KB) - added by lists@… 16 years ago.
Debug output of aspell compilation.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 16 years ago by nightflame@…

I was able to work-around this problem by doing a system search for the file required and putting it into the correct directory. The final solution was to put and into the directory listed in the failure, run 'port uninstall aspell' then 'port install -f aspell'

The installer will complain about files already existing during the Activation phase, but it will complete and register as installed. It also appears to function properly.

comment:2 Changed 16 years ago by jochen@…

Owner: changed from macports-tickets@… to jochen@…

What install-info is this?

which install-info

Does the latest version of aspell, which directly depends on texinfo and uses its install-info work?

comment:3 Changed 16 years ago by lists@…

jay@Singularity~$ which install-info /opt/local/bin/install-info jay@Singularity~$

Even symlinking the other install-info in place of that one didn't appear to work; same error.

comment:4 Changed 16 years ago by jochen@…

Does this file exist on your machine?


Please do an port clean and then attach the output of

sudo port -dv install aspell

to the ticket.

Changed 16 years ago by lists@…

Attachment: debug.txt added

Debug output of aspell compilation.

comment:5 Changed 16 years ago by lists@…

It does not exist. Debug output attached.

comment:6 Changed 16 years ago by jochen@…

Resolution: fixed
Status: newclosed

Thanks, I could reproduce that scenario, should be fixed in r34821

comment:7 Changed 16 years ago by jochen@…

Cc: stefmit@… lists@… added

comment:8 Changed 14 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.