Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#14756 closed defect (worksforme)

ice-cpp: No platform variant for Leopard (darwin 9) causes build to fail (environment variables CC, CXX, CPP don't get set)

Reported by: aronnax@… Owned by: blair (Blair Zajac)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port:

Description

On Leopard (darwin 9), build fails because the environment variables CC, CXX, and CPP don't get set correctly. There needs to be a "platform darwin 9" section. Attached portfile contains corrections.

Attachments (1)

Portfile (3.3 KB) - added by aronnax@… 13 years ago.
corrected portfile

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by aronnax@…

Attachment: Portfile added

corrected portfile

comment:1 Changed 13 years ago by jmroot (Joshua Root)

Cc: blair@… removed
Owner: changed from macports-tickets@… to blair@…

comment:2 Changed 13 years ago by blair (Blair Zajac)

Instead of adding a new variant, can you try taking out all the variants. I believe MacPorts 1.6.0 does not require setting the compiler environmental flags any more.

Let me know if that works for you.

Blair

comment:3 Changed 13 years ago by blair (Blair Zajac)

Resolution: worksforme
Status: newclosed

I can't reproduce this problem on Mac OS X 10.5.

Next time please send in a log from the compile showing the failure.

Also, see r35837 and r35839.

Regards, Blair

comment:4 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.