Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#14830 closed defect (invalid)

texlive doesn't download package

Reported by: psarge@… Owned by: milosh@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: jmroot (Joshua Root)
Port: texlive

Description

The texlive port is unable to find a package to download and compile.

Mudskipper:~ pauls$ sudo port install texlive
--->  Fetching texlive_texmf-minimal
--->  Attempting to fetch texlive_texmf-minimal-2007.tar.gz from http://students.dec.bournemouth.ac.uk/ebarrett/texlive/distfiles/
--->  Attempting to fetch texlive_texmf-minimal-2007.tar.gz from http://svn.macports.org/repository/macports/distfiles/texlive_texmf-minimal
--->  Attempting to fetch texlive_texmf-minimal-2007.tar.gz from http://svn.macports.org/repository/macports/distfiles/general/
--->  Attempting to fetch texlive_texmf-minimal-2007.tar.gz from http://svn.macports.org/repository/macports/downloads/texlive_texmf-minimal
Error: Target org.macports.fetch returned: fetch failed
Error: The following dependencies failed to build: texlive_base texlive_texmf-minimal texlive_texmf-full
Error: Status 1 encountered during processing.


Attachments (1)

texlive-master_sites.diff (2.7 KB) - added by jmroot (Joshua Root) 12 years ago.
fix

Download all attachments as: .zip

Change History (18)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Milestone: Port Bugs
Owner: changed from macports-tickets@… to milosh@…

Assigning to maintainer.

Changed 12 years ago by jmroot (Joshua Root)

Attachment: texlive-master_sites.diff added

fix

comment:2 Changed 12 years ago by jmroot (Joshua Root)

The files have been moved into a new subdirectory. They're also on the OpenBSD mirrors now, so we might as well try them first.

comment:3 Changed 12 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

Since this problem renders the port unusable and the fix is quite simple, I went ahead and committed it in r35506.

comment:4 Changed 12 years ago by erickt@…

Resolution: fixed
Status: closedreopened

This isn't working for me. Does it work for anyone else?

comment:5 Changed 12 years ago by jmroot (Joshua Root)

The old directory is back and the new one has been removed. Go figure.

Also, some but not all of the files seem to have a new version number, 2007g0. There is no 2007 version available on the OpenBSD mirrors for those files.

comment:6 Changed 12 years ago by jmroot (Joshua Root)

Cc: jmr@… added

I updated the bournemouth URL again in r35602. I'll leave it to milosh to figure out what if anything to do about the g0 versions.

comment:7 Changed 12 years ago by psarge@…

I've just re-tried the install.

As expected by the above comments it falls through to the bournemouth URL, with all the other mirrors failing. It does build and install now though.

comment:8 Changed 12 years ago by milosh@…

The g0 distfiles correspond to this line in the openbsd cvs repository:

  • maintainer made new distfiles with fixed updmap.cfg files

I'm going to try and build the new version and update the port.

comment:9 Changed 12 years ago by milosh@…

Resolution: fixed
Status: reopenedclosed

Updated to g0 distfiles in r35960.

comment:10 Changed 12 years ago by aronnax@…

I'd like to have this ticket reopened. I am having the same problem on a brand new installation of Leopard on a Mac Mini.

comment:11 Changed 12 years ago by jmroot (Joshua Root)

Port: texlive added

If you're really seeing the same thing as in the original report, your ports tree is way out of date and you need to sync.

comment:12 Changed 12 years ago by wsiegrist@…

Resolution: fixed
Status: closedreopened

comment:13 Changed 12 years ago by blb@…

http://students.dec.bournemouth.ac.uk/ebarrett/texlive/distfiles/ appears to have both 2007 and 2007g0 distfiles, so if this is an issue for anyone, you either have a firewall causing issues or the server may have been unavailable at the time.

comment:14 in reply to:  10 Changed 12 years ago by milosh@…

Replying to aronnax@…:

I'd like to have this ticket reopened. I am having the same problem on a brand new installation of Leopard on a Mac Mini.

Do you still have this problem? Have you tried the '-d' option to get information? Is ypur macports dport tree up to date? If it is, it should not try to download texlive_texmf-minimal-2007.tar.gz as in the bug report but texlive_texmf-minimal-2007g0.tar.gz...

comment:15 Changed 12 years ago by milosh@…

Now that macports 1.7 is out, and as the distfiles for texlive_* are on macports distfiles mirror, this issue should be solved, no?

comment:16 Changed 12 years ago by milosh@…

Resolution: invalid
Status: reopenedclosed

The reopen requester does not reply. The bug is unconfirmed. Closing.

comment:17 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.