Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#14841 closed defect (fixed)

openexr-1.4.0 fails to build

Reported by: gargasm@… Owned by: waqar@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: kde openexr build fail Cc:
Port:

Description

i tried to install the kde-3.5.8 bundle with the command:

sudo port install kde

here's my uname -a output:

Darwin tiPop.local 8.11.0 Darwin Kernel Version 8.11.0: Wed Oct 10 18:26:00 PDT 2007; root:xnu-792.24.17~1/RELEASE_PPC Power Macintosh powerpc

only minor hitches (having to symlink a few files) up until the OpenEXR package's turn. here is the error output:

[asl@tiPop:~/src]$ sudo port install kde
--->  Fetching openexr
--->  Verifying checksum(s) for openexr
--->  Extracting openexr
--->  Configuring openexr
--->  Building openexr with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_OpenEXR/work/openexr-1.4.0" && make all " returned error 2
Command output: Fl_Widget::Fl_Widget(int, int, int, int, char const*)
Fl_Window::show(int, char**)
Fl_Window::Fl_Window(int, int, char const*)
vtable for Fl_Box
Fl_Gl_Window::draw_overlay()
Fl_Gl_Window::hide()
Fl_Gl_Window::init()
Fl_Gl_Window::show()
Fl_Gl_Window::flush()
Fl_Gl_Window::resize(int, int, int, int)
Fl_Gl_Window::~Fl_Gl_Window()
Fl::e_x
Fl::e_y
Fl_Widget::label(char const*)
Fl_Widget::redraw()
Fl_Window::handle(int)
Fl_Window::Fl_Window(int, int, int, int, char const*)
Fl_Window::~Fl_Window()
typeinfo for Fl_Gl_Window
vtable for Fl_Gl_Window
_glClear
_glClearColor
_glDrawPixels
_glLoadIdentity
_glOrtho
_glRasterPos2i
_glViewport
collect2: ld returned 1 exit status
make[1]: *** [exrdisplay] Error 1
make: *** [all-recursive] Error 1

Error: The following dependencies failed to build: kdebase3 kdelibs3 openexr pcre qt3 unsermake py25-zlib libusb kdenetwork3 openslp kdepim3 gpgme gnupg pth kdeaccessibility3 opensync py25-gobject py25-numeric swig bison kdeutils3 gmp
Error: Status 1 encountered during processing.

when the port install process fails because it can't find a particular file, i can usually solve that with a quick symlink, but this output is rather incomprehensible to me.

hack solution i've tried and failed with:

:download and compile from the OpenEXR site's version (1.4.0 from there as well. strangely, the compile went fine)

:symlink that install from /usr/local/ to /opt/local/

:manually simulate the port structure in /opt/local/var/macports/... with everything mostly symlinked, and a dummy empty file for a reciept

:port clean openexr, kde, kdebase3, multiple times and retry

:attempt to install other kde-3.5.8 dependencies first (all that i tried seem to need openexr as well)

a note: i was compiling things for ipodlinux before, which requires gcc-3.4.3 instead of the default tiger gcc-4.0, and i forgot to change it back for the install up to the failure of OpenEXR. would that be an issue? if so, would

sudo port upgrade active

fix that, or should i re-install all my active ports (all have been compiled with gcc-3.4.3)? i can't find anything that sheds light on this problem in this ticket universe, so any help would be greatly appreciated!

thanks

Change History (6)

comment:1 Changed 13 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to waqar@…
Summary: kde-3.5.8 and openexr-1.4.0 : openexr fails to build, stalls kde package installationopenexr-1.4.0 fails to build

Assigning to maintainer.

Please report your "minor glitches" BTW, unless there are tickets open for them already. You shouldn't have to symlink anything for ports to build.

comment:2 Changed 13 years ago by gargasm@…

hi.

re: minor glitches.

i think i was a bit over-zealous in my plurality. most of the symlinking was done to get another non-macports piece of software to complie using macports-installed libraries and showing it where they were. there was only one true glitch in my kde-3.5.8 install before the current ticket, but it was addressed in the following tickets (sort of):

#11139: BUG: automake fails to build

#7556: BUG: popt (1.10.4_1) upgrade fails with perl5.8 @ 5.8.8_0+darwin_8

i was also hanging on a perl crash when building automake. however, the tip in ticket #7556 suggested downgrading perl and reinstalling the port, but that ticket implied downgrading the macports install of perl to 5.8.7, which seems to no longer be available. i was able to workaround this by replacing the hard link /opt/local/bin/perl, which points to /opt/local/bin/perl5.8.8 (is this the case?), with a symlink to /usr/bin/perl5.8.6, which comes with 10.4.x. this was the only symlink i really had to make to get a macports port to install. long hours staring at a terminal can make memory a bit fuzzy, but i guess that's what logs are for.

comment:3 Changed 13 years ago by waqar@…

Resolution: fixed
Status: newclosed

Fix checked in. Added ilmbase port required by the latest release.

comment:4 Changed 13 years ago by gargasm@…

thanks much for the fix. just one small further point. the portfile for the ilmbase dependency has an error:

http://trac.macports.org/projects/macports/browser/trunk/dports/graphics/ilmbase/Portfile#L15

the line reads:

master_sites    http://savannah.nongnuopenexr

but should read:

master_sites    http://savannah.nongnu.org/download/openexr

everything went smoothly after that change! thanks again!

comment:5 Changed 13 years ago by waqar@…

Fix checked in. --Thanks

comment:6 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.