Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#14946 closed defect (duplicate)

Installing gimp fails with multiple errors

Reported by: woodenwastebasket@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: gimp install py25-libxml2 Cc:
Port:

Description

I was attempting to install gimp with the command "sudo port install -f gimp" under mac OS 10.5.2 I get the following errors:

--->  Fetching py25-libxml2
--->  Attempting to fetch libxml2-python-2.6.21.tar.gz from ftp://xmlsoft.org/libxml2/python/
--->  Verifying checksum(s) for py25-libxml2
--->  Extracting py25-libxml2
--->  Applying patches to py25-libxml2
--->  Configuring py25-libxml2
--->  Building py25-libxml2 with target build
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py25-libxml2/work/libxml2-python-2.6.21" && /opt/local/bin/python2.5 setup.py build " returned error 1
Command output: /opt/local/lib/python2.5/xmllib.py:9: DeprecationWarning: The xmllib module is obsolete.  Use xml.sax instead.
  warnings.warn("The xmllib module is obsolete.  Use xml.sax instead.", DeprecationWarning)
/opt/local/lib/python2.5/distutils/dist.py:247: UserWarning: 'licence' distribution option is deprecated; use 'license'
  warnings.warn(msg)
Found 1579 functions in libxml2-api.xml
Found 53 functions in libxml2-python-api.xml
Generated 873 wrapper functions, 547 failed, 212 skipped

Missing type converters: 
xmlRelaxNGValidityErrorFunc *:2  xmlXPathObjectPtr:22  const htmlEntityDesc *:2  xmlOutputMatchCallback:1  xmlElementContentPtr *:1  xmlStructuredErrorFunc:3  xmlSchematronValidCtxtPtr:2  xmlParserInputBufferCreateFilenameFunc:2  xmlSchemaValType:2  size_t:1  xmlEnumerationPtr:5  xmlSchemaWildcardPtr:1  xmlXIncludeCtxtPtr:4  xmlRelaxNGValidityErrorFunc:2  xmlSAXHandler *:4  ...:1  xmlShellReadlineFunc:1  xmlDict *:1  xmlAutomataPtr:19  xmlParserInputPtr:17  xmlCatalogAllow:2  xmlExpNodePtr:3  xmlElementContent *:1  xmlCharEncodingOutputFunc:1  xmlDictPtr:10  xmlTextWriterPtr:77  const htmlElemDesc *:1  xmlIDPtr:1  xmlSchemaValPtr:13  xmlInputMatchCallback:1  xmlElementTablePtr:2  xmlChar **:15  xmlXPathCompExprPtr:5  xmlTextReaderErrorFunc:1  xmlExternalEntityLoader:2  xmlNotationTablePtr:2  xmlXPathVariableLookupFunc:1  xmlParserNodeInfoPtr:1  xmlExpCtxtPtr:14  xmlPatternPtr:8  xmlC14NIsVisibleCallback:1  xmlDeregisterNodeFunc:2  va_list:1  xmlSchemaTypePtr:9  htmlStatus:1  xmlRegisterNodeFunc:2  xmlAttributeType:2  xmlRefPtr:1  xmlCharEncodingHandler *:4  xmlNotationPtr:3  xmlSaveCtxtPtr:8  xmlRegExecCallbacks:1  xmlNsPtr *:1  xmlLocationSetPtr:6  xmlSchemaSAXPlugPtr:1  xmlModulePtr:4  xmlEnumerationPtr *:2  xmlShellCtxtPtr:10  xlinkNodeDetectFunc:2  xmlRefTablePtr:1  xmlStreamCtxtPtr:4  xmlSchemaValidityErrorFunc *:2  xmlChRangeGroupPtr:1  xmlAttributeTablePtr:2  xmlSchematronParserCtxtPtr:5  xmlCatalogPrefer:1  xmlParserNodeInfoSeqPtr:3  xmlSchematronPtr:2  xmlNodePtr *:2  xmlInputReadCallback:7  char **:5  xmlCharEncoding:13  xmlRegExecCtxtPtr:5  xmlElementContentType:2  void *:85  xmlTextReaderErrorFunc *:1  xmlSAXHandlerPtr *:1  xmlEntityReferenceFunc:1  xmlDocPtr *:1  xmlBufferAllocationScheme:3  xmlSchemaValidityErrorFunc:2  xmlDOMWrapCtxtPtr:5  xmlOutputWriteCallback:2  xmlSchemaFacetPtr:7  xlinkHandlerPtr:2  xmlXPathFuncLookupFunc:1  htmlElemDesc *:3  xmlCharEncodingHandlerPtr:7  xmlCharEncodingInputFunc:1  xmlFeature:1  const xmlParserNodeInfo *:1  xmlNodeSetPtr:32  xmlEntitiesTablePtr:3  xmlIDTablePtr:1  xmlXPathFunction:4  xmlOutputBufferCreateFilenameFunc:2  xmlElementContentPtr:8  xmlElementTypeVal:1  xlinkType:1  xmlGenericErrorFunc *:1 
running build
running build_py
creating build
creating build/lib.macosx-10.3-i386-2.5
copying libxml2.py -> build/lib.macosx-10.3-i386-2.5
copying drv_libxml2.py -> build/lib.macosx-10.3-i386-2.5
running build_ext
building 'libxml2mod' extension
creating build/temp.macosx-10.3-i386-2.5
-DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -D_REENTRANT=1 -I/opt/local/include/libxml2 -I/opt/local/include -I/opt/local/include/python2.5 -c libxml2-py.c -o build/temp.macosx-10.3-i386-2.5/libxml2-py.o
unable to execute -DNDEBUG: No such file or directory
error: command '-DNDEBUG' failed with exit status 1

Error: The following dependencies failed to build: gimp-app gimp2 libgnomeui gnome-keyring gtk2 gtk-doc gnome-doc-utils py25-libxml2 py25-numeric rarian jpeg pango Xft2 xorg-xproto xorg-util-macros shared-mime-info tiff libgcrypt libgpg-error libtasn1 libbonoboui dbus xmlto dbus-glib gconf orbit2 libidl gnome-vfs desktop-file-utils gnome-mime-data libbonobo libglade2 libgnome esound audiofile libgnomecanvas gail libgtkhtml libmng autoconf help2man p5-locale-gettext libtool m4 automake lcms librsvg libcroco libgsf libwmf poppler poppler-data py25-gtk py25-cairo py25-numpy fftw-3 g95 gimp-jp2 openjpeg cmake gimp-lqr-plugin gtk-nodoka-engine coreutils gutenprint icns-gimp macclipboard-gimp macfile-gimp ufraw exiv2 xsane sane-backends libusb
Error: Status 1 encountered during processing.

Did a clean --all on py25-libxml2 and installed py25-libxml2 by itself and reattempted the gimp install. This resulted in another error dealing with gnome-keyring listed at ticket #14945.

Change History (2)

comment:1 Changed 13 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #13930.

comment:2 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.