Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#14985 closed defect (worksforme)

[py25-matplotlib] Unneeded dependency on odcctools

Reported by: matthias.woehrle@… Owned by: skymoo (Adam Mercer)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: matplotlib, dependendy Cc: mcalhoun
Port:

Description

When trying to install py25-matplotlib on 10.5.2 (MacBook Intel), the installation fails with odcctools. (Issue is known, see Ticket #13148)

However, if you install the ports py25-matplotlib is dependent on by hand except odcctools, everything works fine. The dependency on odcctools appears to be wrong.

Change History (8)

comment:1 Changed 13 years ago by jmroot (Joshua Root)

Milestone: Port Bugs
Owner: changed from macports-tickets@… to ram@…

Assigning to maintainer.

It doesn't look like py25-matplotlib actually declares a dependency on odcctools. In fact, I just installed it this week, and at no point did any of its dependencies try to install odcctools.

comment:2 Changed 13 years ago by skymoo (Adam Mercer)

matplotlib doesn't require odcctools, the dependency is not coming from matplotlib.

Have you recently upgraded your system from Tiger without doing a clear reinstall of MacPorts?

comment:3 Changed 13 years ago by skymoo (Adam Mercer)

Status: newassigned

comment:4 Changed 13 years ago by matthias.woehrle@…

Not sure if I did a reinstall... The dependency was there however (If found some of the output):

Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_odcctools/work/odcctools/odcctools" && make default " returned error 2 Command output: cd libstuff && make

[more odcctools error information]

../include/libkern/machine/OSByteOrder.h:63: error: redefinition of '_OSSwapInt64' /usr/include/libkern/i386/_OSByteOrder.h:69: error: previous definition of '_OSSwapInt64' was here

make[1]: * [allocate.o] Error 1

make: * [libstuff] Error 2

Error: The following dependencies failed to build: py25-numpy g95 odcctools py25-hashlib py25-tkinter tcl tk Error: Status 1 encountered during processing.

So if it works for you, it's probably my setup...

comment:5 Changed 13 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: mcalhoun added

The reason it matters if there was a reinstall of MacPorts after the OS upgrade is because:
py25-matplotlib depends on py25-numpy
py25-numpy depends on g95
on 10.4, g95 depends on odcctools
on 10.5, g95 does NOT depend on odcctools.

If you upgraded the OS without reinstalling Macports, then MacPorts might still think that it's running on 10.4
(hence trying to install odcctools).

If you type in "port info g95" on a 10.5 machine and you see odcctool as a library dependency, then MacPorts is
confused as to which type of machine it is running on,
A reinstall of MacPorts should fix this.

comment:6 Changed 13 years ago by matthias.woehrle@…

port info g95 returns no dependencies at all, as you can see

Macintosh-6:home m$ port info g95 g95 0.90, Revision 6, lang/g95 (Variants: darwin_9) http://g95.org/

G95 is a stable, production Fortran 95 compiler available for multiple cpu architectures and operating systems. Innovations and optimizations continue to be worked on. Parts of the F2003 standard have been implemented in g95.

Platforms: darwin Maintainers: takeshi@…

I tried to dig into each package to see where else the dependency may come from, but couldn't find anything.

The matplotlib dependencies are:

python25, freetype, libpng, py25-dateutil, py25-tz, py25-numpy, py25-tkinter

I could not reproduce the behavior by uninstalling (matplotlib, g95, ...) and reinstalling. I guess something is wrong with my setup.

comment:7 Changed 13 years ago by skymoo (Adam Mercer)

Resolution: worksforme
Status: assignedclosed

Sounds like something is wrong with your ports installation as only g95 on Tiger depends on odcctools. I recommend you removing MacPorts entirely and reinstalling, its a pain but it looks like your base thinks its running on Tiger.

I'll close this ticket, but if after reinstalling you encounter the same problem reopen.

comment:8 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.