Opened 13 years ago

Closed 2 years ago

#15095 closed defect (fixed)

BLT doesn't work properly

Reported by: mn@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: kurthindenburg (Kurt Hindenburg), chrstphrchvz (Christopher Chavez), gustafn
Port: blt

Description

I installed BLT library via macports: port install blt, and when I am trying to run it on included samples, it doesn't work, and tells me that there are some version conflicts. The only other version I have is originally suplied Leopard TCL - version 8.4, so the conflict is according to me somewhere in macports installation.

there is a log when I tried to run a sample, it always ends up like this:

mn@hrusticka /opt/local/lib/blt2.4/demos $ bltwish barchart1.tcl 
Application initialization failed: version conflict for package "Tcl": have 8.5.2, need exactly 8.5
Error in startup script: dlsym(0x5882a0, Blt_Unload): symbol not founddlsym(0x5882a0, Blt_SafeUnload): symbol not foundversion conflict for package "Tcl": have 8.5.2, need exactly 8.5
    while executing
"load $library BLT"
    (procedure "LoadBLT" line 30)
    invoked from within
"LoadBLT 2.4 /opt/local/lib/blt2.4"
    ("package ifneeded BLT 2.4" script)
    invoked from within
"package require BLT"
    (file "barchart1.tcl" line 3)
dyld: unloaded: /opt/local/lib/libBLT.2.dylib

Attachments (2)

blt2.4z-patch-64 (903 bytes) - added by howarth@… 12 years ago.
patch from Fedora 12 blt that provides 64-bit compatibility
blt2.4z-noexactversion.patch (477 bytes) - added by howarth@… 12 years ago.
patch from Fedora 12 that eliminates check on exact tcl/tk version

Download all attachments as: .zip

Change History (20)

comment:1 Changed 13 years ago by jmroot (Joshua Root)

Milestone: Port Bugs
Owner: changed from macports-tickets@… to markd@…

Assigning to maintainer.

comment:2 Changed 13 years ago by markd@…

BLT source needs some work to get it working with Tcl/Tk 8.5. I hope this is done soon.

http://coding.derkeiler.com/Archive/Tcl/comp.lang.tcl/2008-04/

comment:3 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Changed 12 years ago by howarth@…

Attachment: blt2.4z-patch-64 added

patch from Fedora 12 blt that provides 64-bit compatibility

Changed 12 years ago by howarth@…

patch from Fedora 12 that eliminates check on exact tcl/tk version

comment:4 Changed 12 years ago by howarth@…

An alternative fix for this from gentoo (which is what fedora)
finally used is available here.
http://bugs.gentoo.org/attachment.cgi?id=154647

comment:5 Changed 12 years ago by mf2k (Frank Schima)

Cc: macsforever2000@… added

Cc Me!

comment:6 Changed 12 years ago by jmroot (Joshua Root)

Port: blt added

comment:7 Changed 11 years ago by jmroot (Joshua Root)

Does this work now that the fix for #22536 has been checked in?

comment:8 Changed 11 years ago by mf2k (Frank Schima)

This still does not work for me:

$ bltwish barchart1.tcl 
Error in startup script: unknown namespace in import pattern "blt::tile::*"
    while executing
"namespace import -force blt::tile::*"
    invoked from within
"if { $tcl_version >= 8.0 } {
    namespace import blt::*
    namespace import -force blt::tile::*
}"
    (file "barchart1.tcl" line 24)

comment:9 Changed 7 years ago by jmroot (Joshua Root)

Cc: mf2k@… added; macsforever2000@… removed

comment:10 Changed 7 years ago by mf2k (Frank Schima)

Cc: mf2k@… removed

comment:11 Changed 7 years ago by mf2k (Frank Schima)

Owner: changed from markd@… to macports-tickets@…

markd has retired. See #44782.

comment:12 Changed 6 years ago by kurthindenburg (Kurt Hindenburg)

Cc: khindenburg@… added

Cc Me!

comment:13 Changed 6 years ago by kurthindenburg (Kurt Hindenburg)

It looks to me that BLT should be obsoleted.

http://wiki.tcl.tk/199 http://blt.sourceforge.net/

The last BLT release is for tcl <= 8.4

comment:14 Changed 2 years ago by chrstphrchvz (Christopher Chavez)

I would consider #51180 to effectively be a duplicate of this.

There are/have been BLT alternatives that are compatible with Tcl/Tk 8.6. BLT 4.0 has also been under development recently, and is compatible with Tcl/Tk 8.6, but it currently exists only in the project's git repository on Sourceforge. However, are any of these worth adding to MacPorts, given how long this issue has existed and that any efforts toward resolving this have stalled (see #34826, #40203)?

comment:15 Changed 2 years ago by chrstphrchvz (Christopher Chavez)

Cc: chrstphrchvz added

comment:16 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: gustafn added
Owner: changed from macports-tickets@… to MarcusCalhoun-Lopez
Status: newaccepted

Adding reporter of #34826 since hopefully the issue will be resolved here.

comment:17 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Using Repology, I have done a little research on how other package managers handle this problem.

Gentoo patches version 2.4z to get it to work.

FreeBSDand Debian start with a fork of blt that purports to be at version 2.5.3.
Even still, a significant number of patches have to be applied.

The upstream development version of blt is at version 3.0a and claims to be compatibly with Tcl 8.6.

I tried to steal all of the Debian patches, but it did not quite work.
Debian Tk installs a couple of header files that MacPorts tk does not.
I have to do a little more research before I start modifying the MacPorts Tk.

comment:18 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: acceptedclosed

In 99a69e509ed7c5eab314fc77e5a37d1ce19f6367/macports-ports (master):

blt: update version 2.4z->2.5.3

For an explanation of this versioning scheme, see
#15095#comment:17.

Fixes #15095
Fixes #40203

Note: See TracTickets for help on using tickets.