Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#15136 closed defect (invalid)

gnome-control-center fails to build: unmet dependency on metacity

Reported by: paulbeard@… Owned by: macports-tickets@…
Priority: High Milestone:
Component: ports Version: 1.6.0
Keywords: metacity gnome gnome-control-center Cc: rhwood@…
Port:

Description

Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-control-center/work/gnome-control-center-2.22.1" && ./configure --prefix=/opt/local --mandir=/opt/local/share/man --disable-hal --enable-gstreamer --disable-scrollkeeper --disable-update-mimedb --disable-update-desktopdb --disable-schemas-install " returned error 1
Command output: checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for XScreenSaverQueryInfo... no
checking for XScreenSaverQueryInfo in -lXss... yes
checking X11/Xlib.h usability... yes
checking X11/Xlib.h presence... yes
checking for X11/Xlib.h... yes
checking for XF86MiscQueryExtension in -lXxf86misc... no
checking X11/extensions/XKB.h usability... yes
checking X11/extensions/XKB.h presence... yes
checking for X11/extensions/XKB.h... yes
checking for LIBSLAB... yes
checking for CAPPLET... yes
checking for GNOMECC... yes
checking for GNOME... yes
checking for DBUS... yes
checking for VFS_CAPPLET... yes
checking for GNOME_DESKTOP... yes
checking for DEFAULT_APPLICATIONS_CAPPLET... yes
checking for METACITY... configure: error: Package requirements (libmetacity-private >= 2.21.21) were not met:

Requested 'libmetacity-private >= 2.21.21' but version of libmetacity-private is 2.20.0

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables METACITY_CFLAGS
and METACITY_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Change History (6)

comment:1 Changed 13 years ago by jmroot (Joshua Root)

Cc: rhwood@… added; rhwood@… removed

The error message makes it clear that your version of metacity is too old, which is to be expected given that you've reported having trouble building metacity 2.22.0 in #14905.

comment:2 Changed 13 years ago by rhwood@…

Resolution: invalid
Status: newclosed

The problem here is a build failure in metacity, not a dependency failure in gnome-control-center.

comment:3 in reply to:  1 Changed 13 years ago by paulbeard@…

Resolution: invalid
Status: closedreopened

Replying to jmr@macports.org:

The error message makes it clear that your version of metacity is too old, which is to be expected given that you've reported having trouble building metacity 2.22.0 in #14905.

I realize that, but as I have noted in the metacity ticket comments, perhaps some other window manager could be swapped in as a dependency if metacity's build problems prove to be intractable.

comment:4 Changed 12 years ago by paulbeard@…

Since I am having to drop to older versions to get this all working again, I am finding this issue with building gnome-control-center. Metacity 2.21.2 built and installed w/o issue, but this dependency on it is hosing things up.

--->  Staging gnome-control-center into destroot
Error: Target org.macports.destroot returned: shell command "cd /opt/local/var/macports/build/_opt_mports_trunk_dports_gnome_gnome-control-center/work/destroot/opt/local/lib/window-manager-settings/ 
&&  ln -s libmetacity.so libmetacity.dylib" returned error 1
Command output: ln: libmetacity.dylib: File exists

Error: Unable to upgrade port: 1

I have tried moving the libmetacity.dylib file aside and it get re-made each time: not sure how that works.

comment:5 Changed 12 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: reopenedclosed

comment:6 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.