Opened 13 years ago

Closed 11 years ago

#15152 closed defect (fixed)

BUG: simh: Unexpected *.dSYM

Reported by: raimue (Rainer Müller) Owned by: gwright@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: simh dsym Cc:
Port: simh

Description

gcc on Leopard uses *.dSYM directories for debug symbols when using -g. The Portfile for simh can't handle that.

Error: Target org.macports.destroot returned: shell command "install -c -m 755 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_emulators_simh/work/./BIN/altair.dSYM /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_emulators_simh/work/destroot/opt/local/bin/simh-altair.dSYM" returned error 71
Command output: install: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_emulators_simh/work/./BIN/altair.dSYM: Inappropriate file type or format

Error: Status 1 encountered during processing.

Why is this port build with -g anyway?

Proposed patch attached, but I think it would be better to remove -g from CFLAGS as it is usually not needed in a release version.

Attachments (1)

patch-simh-dSYM.diff (656 bytes) - added by raimue (Rainer Müller) 13 years ago.

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by raimue (Rainer Müller)

Attachment: patch-simh-dSYM.diff added

comment:1 Changed 12 years ago by raimue (Rainer Müller)

Port: simh added

comment:2 Changed 12 years ago by blb@…

I'm guessing r37841 fixed this (I can't reproduce here)?

comment:3 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:4 in reply to:  2 Changed 11 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: newclosed

Seems to be fixed.

Note: See TracTickets for help on using tickets.