Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#15176 closed enhancement (fixed)

upgrade gramps to 3.0.0 [2.2.8 doesn't run anyway]

Reported by: paulbeard@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: gramps python gnome Cc: rjt-gramps@…
Port:

Description

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for pkg-config... /opt/local/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... none
checking for perl... /opt/local/bin/perl
checking for XML::Parser... ok
Using directory $(prefix)/share/mime for installation of mime type definitions
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking build system type... powerpc-apple-darwin8.11.0
checking host system type... powerpc-apple-darwin8.11.0
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for LC_MESSAGES... yes
checking libintl.h usability... no
checking libintl.h presence... no
checking for libintl.h... no
checking for a Python interpreter with version >= 2.5... python
checking for python... /opt/local/bin/python
checking for python version... 2.5
checking for python platform... darwin
checking for python script directory... ${prefix}/lib/python2.5/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.5/site-packages
checking for sh... /bin/sh
checking Python bindings for gtk2.10 (pygtk2>=2.10.0)... 2.14.1
checking Python bindings for gnome... configure: error:
**** The python bindings for gnome2 (gnome2-python) could not be found.

How do I get configure to see the bindings? I'm optimistic it will compile and run as soon as that's sorted out.

2.2.8 doesn't seem to do anything: it prints out on console that it doesn't have the spell checker but never displays a window or anything.

Attachments (2)

Portfile (1.7 KB) - added by rjt-gramps@… 12 years ago.
Portfile for gramps 3.0.1
patch-configure (749 bytes) - added by rjt-gramps@… 12 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Cc: rjt-gramps@… added

Cc maintainer.

comment:2 Changed 12 years ago by rjt-gramps@…

We are working on a new port file. I will upload it here in a few days for you to try.

comment:3 Changed 12 years ago by rjt-gramps@…

I have attached a Portfile and patch for gramps 3.0.0. If I get some feedback that it works I will ask for it to be committed. Gamps 3.0.1 is about to come out, so if that works I will probably just jump straight to that.

Richard

comment:4 Changed 12 years ago by paulbeard@…

Excellent. I'll see if it builds and runs. I agree on waiting til 3.0.1: makes sense.

Thanks for getting to this.

comment:5 Changed 12 years ago by paulbeard@…

Works fine, looks good. One gotcha (not related to the port so much as to the source): importing old data works in their portable XML format, but not as a direct import of an old database. If that is reproducible, the upstream folks should be advised and anyone who uses the port will want to know.

comment:6 Changed 12 years ago by rjt-gramps@…

It is a known limitation of the database engine that is used in Gramps or at least it is a feature of the changes that have been made to the database model between version 2 and version 3. The user must export their data into the Gramps XML format before upgrading to 3.0.0.

I am not sure what the best way of informing people is? I can send an email to the Mac ports mailing list, but I doubt that many gramps users are on that list.

Any suggestions.

comment:7 Changed 12 years ago by paulbeard@…

So it's a feature, not a bug?

I think your obligations are discharged if you put it in the info of the Portfile (maybe in 1.7, there could be a pre-flight option that allows a user to abort based on some question?) and remind the folks upstream that not everyone knows that the 2.0 database is not directly importable (the import module didn't work for me: I had to go to another system with 2.x installed and export a gpkg file).

Cheers. I'm glad you got 3.x up and going.

comment:8 Changed 12 years ago by rjt-gramps@…

This port has now been tested by a few people.

It is ready to go, but I do not have commit access so I can not get it added.

Can an admin please commit the port?

Thanks

Changed 12 years ago by rjt-gramps@…

Attachment: Portfile added

Portfile for gramps 3.0.1

Changed 12 years ago by rjt-gramps@…

Attachment: patch-configure added

comment:9 Changed 12 years ago by rjt-gramps@…

I have updated portfile and patch for gramps 3.0.1.

comment:10 Changed 12 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: newclosed

Committed revision r38806. I made some minor fixes. Thanks and sorry for the delay!

comment:11 Changed 11 years ago by (none)

Milestone: Port Enhancements

Milestone Port Enhancements deleted

Note: See TracTickets for help on using tickets.