Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#15254 closed defect (duplicate)

rb-rubygems 1.1.1_0 fails on Staging phase

Reported by: lsproc@… Owned by: pguyot (Paul Guyot)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: rb-rubygems Cc: mr_bond@…, tim.harding@…
Port:

Description

The port file for rb-rubygems fails to install on my system (Leopard, Xcode Tools from Leopard DVD). This is the error encountered:

./lib/rubygems/custom_require.rb:27:in `gem_original_require': no such file to load -- socket (LoadError)
	from ./lib/rubygems/custom_require.rb:27:in `require'
	from /opt/local/lib/ruby/1.8/net/protocol.rb:21
	from ./lib/rubygems/custom_require.rb:27:in `gem_original_require'
	from ./lib/rubygems/custom_require.rb:27:in `require'
	from /opt/local/lib/ruby/1.8/net/http.rb:28
	from ./lib/rubygems/custom_require.rb:27:in `gem_original_require'
	from ./lib/rubygems/custom_require.rb:27:in `require'
	from ./lib/rubygems/remote_fetcher.rb:1
	from ./lib/rubygems/custom_require.rb:27:in `gem_original_require'
	from ./lib/rubygems/custom_require.rb:27:in `require'
	from ./lib/rubygems/source_info_cache_entry.rb:3
	from ./lib/rubygems/custom_require.rb:27:in `gem_original_require'
	from ./lib/rubygems/custom_require.rb:27:in `require'
	from ./lib/rubygems/source_info_cache.rb:4
	from ./lib/rubygems/custom_require.rb:27:in `gem_original_require'
	from ./lib/rubygems/custom_require.rb:27:in `require'
	from setup.rb:206

Change History (9)

comment:1 Changed 12 years ago by lsproc@…

Cc: lsproc@… added

Cc Me!

comment:2 Changed 12 years ago by jmroot (Joshua Root)

Cc: mr_bond@… added; lsproc@… removed
Milestone: Port Bugs
Owner: changed from macports-tickets@… to pguyot@…

Assigning to Paul since there seem to be issues with ruby's socket lib being built. See this ML post.

comment:3 Changed 12 years ago by nipponese@…

In the meantime, is there a way to install a previous patch, and easily upgrade later?

comment:4 Changed 12 years ago by andrew-macports@…

Same problem encountered with Tiger on a Macbook Pro 2.2GHz, latest MacPorts.

comment:5 Changed 12 years ago by popeast@…

I got this problem also. I checkout previous Portfile for ruby 1.8.6-p111 and it still meets the same problem, and there's no many difference between p111 and p114's Portfile. I find another ticket #15177 that "When autoconf 2.62 is used, ruby doesn't build all the appropriate standard libraries. such as socket" . I uninstall autoconf and install ruby with system's autoconf, both 1.8.6-p111 and 1.8.6-p114 works fine. So it's autoconf's problem not ruby's. Hope this can help others.

comment:6 Changed 12 years ago by tim.harding@…

Cc: tim.harding@… added

Cc Me!

comment:7 Changed 12 years ago by ian.w.white@…

deactivating autoconf cleaned up the problems for me (OS X 10.5.2), so this is probably a dupe of #15177

comment:8 Changed 12 years ago by pguyot (Paul Guyot)

Resolution: duplicate
Status: newclosed

Definitely a dup of #15177.

comment:9 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.