Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#15279 closed defect (wontfix)

p5-svn-simple Configure error

Reported by: jeremy.g.ross@… Owned by: danielluke (Daniel J. Luke)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: p5-svn-simple git-core Cc: orestis@…
Port:

Description

I got this error doing: port -v install git-core +svn +doc +bash_completion.

I'm running OS X 10.5.2 and MacPorts 1.6.

--->  Configuring p5-svn-simple
dyld: lazy symbol binding failed: Symbol not found: _Perl_Gthr_key_ptr
  Referenced from: /usr/local/lib/libsvn_swig_perl-1.0.dylib
  Expected in: flat namespace

dyld: Symbol not found: _Perl_Gthr_key_ptr
  Referenced from: /usr/local/lib/libsvn_swig_perl-1.0.dylib
  Expected in: flat namespace

sh: line 1: 25775 Trace/BPT trap          /opt/local/bin/perl Makefile.PL INSTALLDIRS=vendor
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-svn-simple/work/SVN-Simple-0.27" && /opt/local/bin/perl Makefile.PL INSTALLDIRS=vendor " returned error 133
Command output: dyld: lazy symbol binding failed: Symbol not found: _Perl_Gthr_key_ptr
  Referenced from: /usr/local/lib/libsvn_swig_perl-1.0.dylib
  Expected in: flat namespace

dyld: Symbol not found: _Perl_Gthr_key_ptr
  Referenced from: /usr/local/lib/libsvn_swig_perl-1.0.dylib
  Expected in: flat namespace

sh: line 1: 25775 Trace/BPT trap          /opt/local/bin/perl Makefile.PL INSTALLDIRS=vendor

Warning: the following items did not execute (for p5-svn-simple): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

Change History (11)

comment:1 Changed 11 years ago by jeremy.g.ross@…

Cc: jeremy.g.ross@… added

Cc Me!

comment:2 Changed 11 years ago by jmroot (Joshua Root)

Cc: jeremy.g.ross@… removed
Owner: changed from macports-tickets@… to dluke@…

Assigning to maintainer. Looks like you have libs installed in /usr/local that are being picked up instead of the ones installed by MP.

comment:3 Changed 11 years ago by danielluke (Daniel J. Luke)

Resolution: wontfix
Status: newclosed

Yep, it looks like /usr/local/lib/libsvn_swig_perl-1.0.dylib is the problem here.

Likely, you have other svn libraries installed in /usr/local.

You'll want to remove those (or move them aside) clean your build (sudo port clean --all p5-svn-simple) and and try again.

comment:4 Changed 11 years ago by jeremy.g.ross@…

Must be the svn that comes with OS X.

I moved anything /usr/svn* into a ./backup sub-directory. I also confirmed that the /opt directories come before the /usr directories in PATH.

Now I get the following:

--->  Configuring p5-svn-simple
===> Warning: SVN::Core missing or outdated.
Please manually install SVN::Core by compiling Subversion
(version 0.31.0 or above) with SWIG/Perl bindings,
and try this installation process again.
Writing Makefile for SVN::Simple::Edit
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-svn-simple/work/SVN-Simple-0.27" && /opt/local/bin/perl Makefile.PL INSTALLDIRS=vendor " returned error 2
Command output: ===> Warning: SVN::Core missing or outdated.
Please manually install SVN::Core by compiling Subversion
(version 0.31.0 or above) with SWIG/Perl bindings,
and try this installation process again.
Writing Makefile for SVN::Simple::Edit

Warning: the following items did not execute (for p5-svn-simple): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

comment:5 Changed 11 years ago by jeremy.g.ross@…

I was able to get all this fixed by uninstalling and installing subversion-perlbindings.

comment:6 Changed 11 years ago by orestis@…

OK, after struggling with this myself:

As mentioned move your libsvn_swig_perl* out of /usr/local/lib AND out of /usr/lib into temporary folders.

Uninstall and reinstall subversion-perlbindings

Install p5-svn-simple (and git-core +svn which is what lead me here)

Move the libsvn_swig_perl files back in /usr/lib and /usr/local/lib (or else git svn won't work).

I would like to repoen this bug because this should be really straightforward and touching the /usr/lib directory feels very un-Macports like. It blocks installing git-svn which is an important dev tool.

comment:7 Changed 11 years ago by orestis@…

Cc: orestis@… added

Cc Me!

comment:8 Changed 11 years ago by danielluke (Daniel J. Luke)

This bug was unrelated to anything in /usr, but was related to things in /usr/local

Things in /usr/local can conflict with MacPorts and so care must be exercised when installing things into /usr/local.

You shouldn't have to move aside anything in /usr/lib for this port to install.

comment:9 Changed 11 years ago by orestis@…

OK - I'm not really sure how these things work.

Forgive me for my ignorance, but couldn't the portfile specify an explicit link to the /opt/local version of libraries, so that there would be no conflicts?

comment:10 in reply to:  9 Changed 11 years ago by danielluke (Daniel J. Luke)

Replying to orestis@…:

Forgive me for my ignorance, but couldn't the portfile specify an explicit link to the /opt/local version of libraries, so that there would be no conflicts?

The compiler and linker search /usr/local specially (similar to a standard system directory), so it can cause problems. Sometimes individual ports can be patched to handle this, but often it's not possible (or not easy).

comment:11 Changed 10 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.