Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#15341 closed defect (fixed)

ImageMagick checksum mismatches

Reported by: shirose@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: ryanfelton@…, brendan_billingb@…, dershow, jmroot (Joshua Root)
Port:

Description

---> Fetching ImageMagick
---> Attempting to fetch ImageMagick-6.4.1-2.tar.bz2 from http://image_magick.veidrodis.com/image_magick/[[BR]] ---> Verifying checksum(s) for ImageMagick
Error: Checksum (md5) mismatch for ImageMagick-6.4.1-2.tar.bz2
Error: Checksum (sha1) mismatch for ImageMagick-6.4.1-2.tar.bz2
Error: Checksum (rmd160) mismatch for ImageMagick-6.4.1-2.tar.bz2
Error: Target org.macports.checksum returned: Unable to verify file checksums
Error: Unable to upgrade port: 1

Change History (18)

comment:1 Changed 12 years ago by ryanfelton@…

I too am having the same issue on a clean install even after preforming an sudo port clean --all imagemagick and sudo port sync

sudo port install ImageMagick
--->  Fetching ImageMagick
--->  Attempting to fetch ImageMagick-6.4.1-2.tar.bz2 from http://image_magick.veidrodis.com/image_magick/
--->  Verifying checksum(s) for ImageMagick
Error: Checksum (md5) mismatch for ImageMagick-6.4.1-2.tar.bz2
Error: Checksum (sha1) mismatch for ImageMagick-6.4.1-2.tar.bz2
Error: Checksum (rmd160) mismatch for ImageMagick-6.4.1-2.tar.bz2
Error: Target org.macports.checksum returned: Unable to verify file checksums
Error: Status 1 encountered during processing.

comment:2 Changed 12 years ago by ryanfelton@…

Cc: ryanfelton@… added

Cc Me!

comment:3 Changed 12 years ago by raimue (Rainer Müller)

Owner: changed from macports-tickets@… to ryandesign@…

comment:4 Changed 12 years ago by brendan_billingb@…

Cc: brendan_billingb@… added

Cc Me!

comment:5 Changed 12 years ago by jmroot (Joshua Root)

Sourceforge has a version of the file whose checksum matches that in the portfile. The one on veidrodis.com is 5021 bytes longer.

comment:6 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed
Summary: ImageMagick: Checksum ErrorImageMagick: 6.4.1-2 Checksum Error

Hopefully 6.4.1-3 is consistent on all servers because I updated to it in r36935.

comment:7 Changed 12 years ago by dershow

Resolution: fixed
Status: closedreopened

Nope, something is still not right. Even when I do a sync it says that the current version is 6.4.1-2_0. But if I view the port file it says that the version is 6.4.1-3_0 as it should since you have updated it and I have done a sync.

sudo port clean --all ImageMagick
Password:
--->  Cleaning ImageMagick
Macintosh-2:~ dersh$ sudo port sync;port outdated
The following installed ports are outdated:
ImageMagick                    6.4.1-1_0 < 6.4.1-2_0     
Macintosh-2:~ dersh$ sudo port upgrade outdated
Password:
--->  Fetching ImageMagick
--->  Attempting to fetch ImageMagick-6.4.1-3.tar.bz2 from http://image_magick.veidrodis.com/image_magick/
--->  Verifying checksum(s) for ImageMagick
Error: Checksum (md5) mismatch for ImageMagick-6.4.1-3.tar.bz2
Error: Checksum (sha1) mismatch for ImageMagick-6.4.1-3.tar.bz2
Error: Checksum (rmd160) mismatch for ImageMagick-6.4.1-3.tar.bz2
Error: Target org.macports.checksum returned: Unable to verify file checksums
Error: Unable to upgrade port: 1

So something is not in sync. It seems to "think" that 6.4.1-2 is the current one, but the current port file is for 6.4.1-3, and then there is a checksum error with that one.

comment:8 Changed 12 years ago by dershow

Cc: dersh@… added

Cc Me!

comment:9 Changed 12 years ago by blb@…

Looks like the tarball from veidrodis.com is definitely different; doing a diff between the 6.4.1-3 versions from veidrodis.com and from imagemagick.org makes it appear that the veidrodis.com version is one day earlier...weird. Maybe remove that mirror?

Also, 6.4.1-3 doesn't appear to be on the sourceforge download page at all, just 6.4.1-2.

dersh@, note that 'port outdated' will appear to be confused for a bit until the PortIndex file is updated, which happens only twice a day. But as you see, when trying to install, it'll try for the current version.

comment:10 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

The PortIndex only regenerates every 12 hours. Please wait 12 hours from the time I committed the fix before selfupdating and trying again.

comment:11 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: closedreopened

Ah, sorry, I see you're having a checksum error with 6.4.1-3 too.

comment:12 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

If they had different versions of the 6.4.1-3 distfile before, they've resolved it now. I downloaded the distfile from all mirrors listed in the portfile, and the distfile is identical on all of them, and matches the checksums I recorded in the portfile. (Except SourceForge, which doesn't carry 6.4.1-3 yet; this may be intentional; the download page says SourceForge hosts legacy releases.)

If you are experiencing a checksum verification error, please remove the download and try again, e.g.:

sudo port clean --all ImageMagick

comment:13 Changed 12 years ago by jmroot (Joshua Root)

Cc: jmr@… added
Resolution: fixed
Status: closedreopened
Summary: ImageMagick: 6.4.1-2 Checksum ErrorImageMagick checksum mismatches

This has popped up again with 6.4.1-5. The distfile from SourceForge has different checksums than those in the portfile, while the one from ftp.imagemagick.net matches. (I didn't check the other mirrors.)

comment:14 Changed 12 years ago by ryandesign (Ryan Schmidt)

Chris Janton also reported this on macports-users.

comment:15 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

I checked the distfiles on all mirrors listed in the portfile. SourceForge is the only mirror with files of a different checksum. I reported this to the magick-bugs mailing list, and disabled the SourceForge download location in the port in r37445 until they fix it. For those experiencing the issue, please wait 30 minutes, selfupdate, clean, and try again.

sudo port selfupdate
sudo port clean --all ImageMagick

comment:16 in reply to:  description ; Changed 12 years ago by jdelsman@…

Resolution: fixed
Status: closedreopened

Problem is still occurring with a new version:

$ sudo port install ImageMagick +no_x11 ---> Fetching ImageMagick ---> Attempting to fetch ImageMagick-6.4.2-1.tar.bz2 from http://image_magick.veidrodis.com/image_magick/ ---> Verifying checksum(s) for ImageMagick Error: Checksum (md5) mismatch for ImageMagick-6.4.2-1.tar.bz2 Error: Checksum (sha1) mismatch for ImageMagick-6.4.2-1.tar.bz2 Error: Checksum (rmd160) mismatch for ImageMagick-6.4.2-1.tar.bz2 Error: Target org.macports.checksum returned: Unable to verify file checksums Error: Status 1 encountered during processing.

comment:17 in reply to:  16 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

Replying to jdelsman@voxxit.com:

Problem is still occurring with a new version:

Actually, the problem is occurring again, not still. I can confirm that the mirrors ftp.surfnet.nl and ftp.nluug.nl have the wrong file. MacPorts picked one of those mirrors for me when I downloaded and updated the port, so the checksums in the port are wrong. Mac OS Forge also picked up the wrong file for the distfiles mirror.

In r37942 I removed the mirrors with the wrong file, upped the revision, changed the dist_subdir so a new file is downloaded by users and the distfiles mirror.

I also wrote another email to the magick-bugs mailing list about the problem. (Nobody replied to my first email.)

P.S: Please remember WikiFormatting.

comment:18 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.