Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#15356 closed defect (fixed)

building jpeg fails

Reported by: lord@… Owned by: waqar@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: jpeg Cc: ryandesign (Ryan Schmidt), MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: jpeg

Description (last modified by ryandesign (Ryan Schmidt))

mbenzi /Users/lord> sudo port install jpeg
--->  Fetching jpeg
--->  Verifying checksum(s) for jpeg
--->  Extracting jpeg
--->  Applying patches to jpeg
--->  Configuring jpeg
--->  Building jpeg with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_jpeg/work/jpeg-6b" && make all " returned error 2
Command output:       _parse_switches in cjpeg.o
  "_jpeg_set_defaults", referenced from:
      _main in cjpeg.o
  "_jpeg_set_colorspace", referenced from:
      _parse_switches in cjpeg.o
  "_jpeg_stdio_dest", referenced from:
      _main in cjpeg.o
  "_jpeg_add_quant_table", referenced from:
      _read_quant_tables in rdswitch.o
  "_jpeg_simple_progression", referenced from:
      _parse_switches in cjpeg.o
  "_jpeg_default_colorspace", referenced from:
      _main in cjpeg.o
  "_jpeg_finish_compress", referenced from:
      _main in cjpeg.o
  "_jpeg_std_error", referenced from:
      _main in cjpeg.o
  "_jpeg_start_compress", referenced from:
      _main in cjpeg.o
  "_jpeg_write_scanlines", referenced from:
      _main in cjpeg.o
  "_jpeg_set_quality", referenced from:
      _parse_switches in cjpeg.o
  "_jpeg_destroy_compress", referenced from:
      _main in cjpeg.o
  "_jpeg_CreateCompress", referenced from:
      _main in cjpeg.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make: *** [cjpeg] Error 1

Error: Status 1 encountered during processing.
mbenzi /Users/lord> 

Attachments (1)

jpeg.txt (29.0 KB) - added by lord@… 12 years ago.
"sudo port -d install jpeg" output

Download all attachments as: .zip

Change History (15)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Milestone: Port Bugs
Owner: changed from macports-tickets@… to waqar@…

Assigning to maintainer.

comment:2 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

What version of Mac OS X, Xcode and MacPorts are you running, and on what kind of Mac?

comment:3 in reply to:  2 Changed 12 years ago by lord@…

Replying to ryandesign@macports.org:

What version of Mac OS X, Xcode and MacPorts are you running, and on what kind of Mac?

I am on MacBook Pro.

mbenzi /Users/lord> uname -a Darwin mbenzi.local 9.4.0 Darwin Kernel Version 9.4.0: Mon Jun 9 19:30:53 PDT 2008; root:xnu-1228.5.20~1/RELEASE_I386 i386 i386

mbenzi /Users/lord> gcc --version i686-apple-darwin9-gcc-4.0.1 (GCC) 4.0.1 (Apple Inc. build 5484)

mbenzi /Users/lord> port MacPorts 1.600

Let me know if there is any additional information I can provide.

Vadim

comment:4 in reply to:  2 Changed 12 years ago by cbedgar@…

Replying to ryandesign@macports.org:

What version of Mac OS X, Xcode and MacPorts are you running, and on what kind of Mac?

I am having similar problem. See output below. I am using Mac OS 10.5.4, MacPorts 1.6, on a MacBookPro 2.4GHz.

cedgar-mbp:bin cedgar$ sudo port test jpeg
--->  Building jpeg with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/
build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_jpeg/
work/jpeg-6b" && make all " returned error 2
Command output:       _parse_switches in cjpeg.o
  "_jpeg_set_defaults", referenced from:
      _main in cjpeg.o
  "_jpeg_set_colorspace", referenced from:
      _parse_switches in cjpeg.o
  "_jpeg_stdio_dest", referenced from:
      _main in cjpeg.o
  "_jpeg_add_quant_table", referenced from:
      _read_quant_tables in rdswitch.o
  "_jpeg_simple_progression", referenced from:
      _parse_switches in cjpeg.o
  "_jpeg_default_colorspace", referenced from:
      _main in cjpeg.o
  "_jpeg_finish_compress", referenced from:
      _main in cjpeg.o
  "_jpeg_std_error", referenced from:
      _main in cjpeg.o
  "_jpeg_start_compress", referenced from:
      _main in cjpeg.o
  "_jpeg_write_scanlines", referenced from:
      _main in cjpeg.o
  "_jpeg_set_quality", referenced from:
      _parse_switches in cjpeg.o
  "_jpeg_destroy_compress", referenced from:
      _main in cjpeg.o
  "_jpeg_CreateCompress", referenced from:
      _main in cjpeg.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make: *** [cjpeg] Error 1

Error: Status 1 encountered during processing.

Note: error line hard-wrapped for legibility

comment:5 Changed 12 years ago by ryandesign (Ryan Schmidt)

FYI @ cbedgar: the jpeg port does not have a test phase defined, so sudo port test jpeg won't test anything.

Could you please clean and try again, capturing all debug output, and attach that here? Do this:

sudo port clean --work jpeg
sudo port -d install jpeg 2>&1 | tee ~/Desktop/jpeg.txt

When it's done, attach jpeg.txt from your Desktop to this ticket. Then I can compare it with what I have from my system. Thanks.

Changed 12 years ago by lord@…

Attachment: jpeg.txt added

"sudo port -d install jpeg" output

comment:6 Changed 12 years ago by blb@…

Do you have any DYLD environment variables set? Use env |grep DYLD to see. Also, from jpeg.txt, this is suspicious:

ld warning: in /opt/local/lib/libjpeg.dylib, file is not of required architecture

What does

file /opt/local/lib/libjpeg.dylib

say, as well as

port provides /opt/local/lib/libjpeg.dylib

comment:7 Changed 12 years ago by lord@…

No, I do not have DYLD set.

comment:8 Changed 12 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: jpeg added

I cannot reproduce this issue here. Please make sure you have the current version of everything: Mac OS X 10.5.6 and Xcode 3.1.2 (or 10.4.11 and Xcode 2.5), and MacPorts 1.7 (use sudo port selfupdate to get that). Once you have those, clean jpeg (sudo port clean jpeg) and try installing or upgrading jpeg again.

If either of you are still experiencing this issue can you provide the information Bryan requested above?

comment:9 in reply to:  8 ; Changed 12 years ago by soconnor@…

Replying to ryandesign@…:

I cannot reproduce this issue here. Please make sure you have the current version of everything: Mac OS X 10.5.6 and Xcode 3.1.2 (or 10.4.11 and Xcode 2.5), and MacPorts 1.7 (use sudo port selfupdate to get that). Once you have those, clean jpeg (sudo port clean jpeg) and try installing or upgrading jpeg again.

If either of you are still experiencing this issue can you provide the information Bryan requested above?

I had this problem too. I solved it by doing an "sudo port uninstall jpeg" and all dependent ports. Then, I did a "sudo port install jpeg" which then worked. I believe this problem was caused by having old files from my PPC laptop that were copied over when I migrated to the Intel laptop.

comment:10 Changed 12 years ago by lord@…

Although I am original bug submitter, I could not test it now. I have changed since to another Mac. I currently do have jpeg port installed, although I am not sure how I managed to do this. I could not uninstall it because many other ports depend on it. If there is a way to test without uninstalling all these ports I will be glad to help. If there is a way to preform "dry run" port build without actually installing it?

comment:11 in reply to:  9 ; Changed 12 years ago by ryandesign (Ryan Schmidt)

Replying to soconnor@…:

I believe this problem was caused by having old files from my PPC laptop that were copied over when I migrated to the Intel laptop.

Ah, then this may be the same situation as in #16411.

comment:12 Changed 11 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: mcalhoun@… added

Cc Me!

comment:13 in reply to:  11 Changed 11 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: newclosed

Replying to ryandesign@…:

Replying to soconnor@…:

I believe this problem was caused by having old files from my PPC laptop that were copied over when I migrated to the Intel laptop.

Ah, then this may be the same situation as in #16411.

I agree that this is seems to be the same issue #16411, so r47969 should fix this as well.
Comment 9 and comment 10 seem to indicate that reinstalling solved the problem, which is consistent with #16411.

Closing as maintainer timeout of #16411.

comment:14 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.