Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#15372 closed defect (fixed)

octave-forge-2006.07.09 depends on port ginac but should be GiNaC

Reported by: blb@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: port bug typo dependency Cc: alakazam@…, jmroot (Joshua Root)
Port:

Description

math/octave-forge depends on port:ginac but should be port:GiNaC.

Change History (5)

comment:1 Changed 12 years ago by alakazam@…

The octave-forge port has actually been deprecated in favor of individual portfiles for each octave-forge package. What is the preferred way to handle deprecated port files' removals ?

comment:2 Changed 12 years ago by jmroot (Joshua Root)

Cc: alakazam@… jmr@… added

The usual strategy seems to be to change the old port to give an error message in pre-fetch indicating that it has been obsoleted (and the same info in the description.) Then after a "sufficiently long" time has passed, delete it.

comment:3 Changed 12 years ago by alakazam@…

Ticket #15419 suggests deprecating octave-forge since Changeset 36910 ensures support of the various octave-forge packages with the octave-3.0 port.

I believe that this ticket can be closed, and filed again against the specific octave-* Portfiles that might exhibit this problem. This problem should probably be filed against the octave port itself, if it is present, the individual octave-* Portfiles shouldn't have this problem, as they only depend on the octave port.

comment:4 Changed 12 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

Fixed by the resolution of #15419 in r37049.

comment:5 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.