Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#15465 closed defect (duplicate)

p5-sdl_perl missing dependencies

Reported by: mellon85@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: sethk@…
Port:

Description

p5-sdl_perl can't compile because it hasn't defined that needs libsdl_ttf, libsdl_net packages, libsdl_gfx installed

I have installed the packages at each error found

--->  Building p5-sdl_perl with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-sdl_perl/work/SDL_Perl-2.1.3" && /opt/local/bin/perl Build build " returned error 2
Command output: env MACOSX_DEPLOYMENT_TARGET=10.3 cc -L/opt/local/lib -bundle -undefined dynamic_lookup -L/usr/local/lib -o blib/arch/auto/src/SDL_perl/SDL_perl.bundle src/SDL_perl.o -L../../lib -L/opt/local/lib -lSDLmain -lSDL -Wl,-framework,Cocoa -lSDL -lSDL_ttf -lSDL_net -lSDL_image -lSDL_gfx -lSDL_mixer
ld: library not found for -lSDL_ttf
collect2: ld returned 1 exit status
error building blib/arch/auto/src/SDL_perl/SDL_perl.bundle from src/SDL_perl.o at /opt/local/lib/perl5/vendor_perl/5.8.8/ExtUtils/CBuilder/Base.pm line 212.

Error: The following dependencies failed to build: p5-sdl_perl
Error: Status 1 encountered during processing.
--->  Building p5-sdl_perl with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-sdl_perl/work/SDL_Perl-2.1.3" && /opt/local/bin/perl Build build " returned error 2
Command output: env MACOSX_DEPLOYMENT_TARGET=10.3 cc -L/opt/local/lib -bundle -undefined dynamic_lookup -L/usr/local/lib -o blib/arch/auto/src/SDL_perl/SDL_perl.bundle src/SDL_perl.o -L../../lib -L/opt/local/lib -lSDLmain -lSDL -Wl,-framework,Cocoa -lSDL -lSDL_ttf -lSDL_net -lSDL_image -lSDL_gfx -lSDL_mixer
ld: library not found for -lSDL_net
collect2: ld returned 1 exit status
error building blib/arch/auto/src/SDL_perl/SDL_perl.bundle from src/SDL_perl.o at /opt/local/lib/perl5/vendor_perl/5.8.8/ExtUtils/CBuilder/Base.pm line 212.

Error: The following dependencies failed to build: p5-sdl_perl
Error: Status 1 encountered during processing.
--->  Building p5-sdl_perl with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-sdl_perl/work/SDL_Perl-2.1.3" && /opt/local/bin/perl Build build " returned error 2
Command output: env MACOSX_DEPLOYMENT_TARGET=10.3 cc -L/opt/local/lib -bundle -undefined dynamic_lookup -L/usr/local/lib -o blib/arch/auto/src/SDL_perl/SDL_perl.bundle src/SDL_perl.o -L../../lib -L/opt/local/lib -lSDLmain -lSDL -Wl,-framework,Cocoa -lSDL -lSDL_ttf -lSDL_net -lSDL_image -lSDL_gfx -lSDL_mixer
ld: library not found for -lSDL_gfx
collect2: ld returned 1 exit status
error building blib/arch/auto/src/SDL_perl/SDL_perl.bundle from src/SDL_perl.o at /opt/local/lib/perl5/vendor_perl/5.8.8/ExtUtils/CBuilder/Base.pm line 212.

Error: The following dependencies failed to build: p5-sdl_perl
Error: Status 1 encountered during processing.

Change History (5)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Cc: sethk@… added

Cc maintainer.

comment:2 Changed 12 years ago by sethk@…

Please try the patch attached to http://trac.macports.org/ticket/13854 . It's possible that this can be marked as duplicate.

comment:3 in reply to:  2 Changed 12 years ago by mellon85@…

Replying to sethk@meowfishies.com:

Please try the patch attached to http://trac.macports.org/ticket/13854 . It's possible that this can be marked as duplicate.

This patch does solves the problem, it can be marked as dup

comment:4 Changed 12 years ago by raimue (Rainer Müller)

Resolution: duplicate
Status: newclosed

Duplicate of #13854.

comment:5 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.