Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#15553 closed defect (fixed)

py25-numeric build error: unrecognized gcc flags -no-cpp-precomp and -Wno-long-double

Reported by: dstndstn@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: jmroot (Joshua Root)
Port:

Description

I get:

# port build py25-numeric
--->  Building py25-numeric with target build
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py25-numeric/work/Numeric-24.2" && /opt/local/bin/python2.5 setup.py build " returned error 1
Command output: running build
running build_py
running build_ext
building '_numpy' extension
gcc -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -IInclude -IPackages/FFT/Include -IPackages/RNG/Include -I/opt/local/include/python2.5 -c Src/_numpymodule.c -o build/temp.macosx-10.3-ppc-2.5/Src/_numpymodule.o
gcc: unrecognized option '-no-cpp-precomp'
cc1: error: unrecognized command line option "-Wno-long-double"
error: command 'gcc' failed with exit status 1

Error: Status 1 encountered during processing.

I have:

# gcc --version
gcc (GCC) 4.0.0
Copyright (C) 2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Attachments (1)

py25-numeric_panther.diff (685 bytes) - added by jmroot (Joshua Root) 12 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Cc: jmr@… added; dstndstn@… removed

What OS version are you using? You probably need to upgrade to the latest XCode release for your system. On a Tiger machine of mine:

% gcc --version
powerpc-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5370)

Also, gcc is being invoked as just 'gcc' rather than '/usr/bin/gcc-4.0', so it looks like you're running an older version of MacPorts, and should upgrade with sudo port selfupdate.

comment:2 Changed 12 years ago by dstndstn@…

Sorry, I should have specified my OS and MacPorts versions:

# uname -a
Darwin shiny.local 7.9.0 Darwin Kernel Version 7.9.0: Wed Mar 30 20:11:17 PST 2005; root:xnu/xnu-517.12.7.obj~1/RELEASE_PPC  Power Macintosh powerpc

# port selfupdate

MacPorts base version 1.600 installed

Downloaded MacPorts base version 1.600

The MacPorts installation is not outdated and so was not updated
selfupdate done!

It's a 10.3.9 system. (I normally run Linux on this machine so I haven't bought OSX updates.)

comment:3 Changed 12 years ago by dstndstn@…

PS, I have XCode 1.5, which I believe is the latest version supported under OSX 10.3.

Changed 12 years ago by jmroot (Joshua Root)

Attachment: py25-numeric_panther.diff added

comment:4 Changed 12 years ago by jmroot (Joshua Root)

I don't have a Panther machine to test on, but here's a patch to try. It will install and use GCC 4.0.4 from MacPorts.

comment:5 Changed 12 years ago by jmroot (Joshua Root)

Further investigation reveals that -no-cpp-precomp is an obsolete option. It was used in GCC < 3.3 to select what is now the default behaviour, and does not exist in FSF's GCC 4. I'm not sure why it doesn't cause problems on 10.4 and 10.5, but I've attempted to fix this on 10.3 by explicitly using gcc-3.3 (r37676). Please try the updated port and report back.

comment:6 Changed 12 years ago by dstndstn@…

My apologies for the long delay!

I just tried the updated port and it works perfectly.

Thanks very much!!

--dustin.

comment:7 Changed 12 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

Great, marking fixed.

comment:8 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.