Opened 12 years ago

Closed 12 years ago

#15607 closed defect (duplicate)

gnumeric build stopped at py25-hashlib:

Reported by: macports@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port:

Description

I tried installing gnumeric from a fresh and updated MacPorts installation, but it stopped with:

...
--->  Building py25-hashlib with target build
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py25-hashlib/work/Python-2.5.2/Modules" && /opt/local/bin/python2.5 setup.py build " returned error 1
Command output: running build
running build_ext
building '_hashlib' extension
creating build
creating build/temp.macosx-10.3-i386-2.5
-DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I/opt/local/include -I/opt/local/include/python2.5 -c _hashopenssl.c -o build/temp.macosx-10.3-i386-2.5/_hashopenssl.o
unable to execute -DNDEBUG: No such file or directory
error: command '-DNDEBUG' failed with exit status 1

Error: The following dependencies failed to build: gnome-doc-utils iso-codes py25-hashlib libxml2 libxslt p5-xml-parser py25-gobject py25-libxml2 py25-numeric rarian getopt intltool gnome-common goffice libgnomeprintui gnome-icon-theme hicolor-icon-theme icon-naming-utils p5-getopt-long p5-pathtools p5-xml-simple p5-xml-namespacesupport p5-xml-sax gtk2 atk cairo fontconfig freetype libpixman libpng render xrender jpeg pango Xft2 xorg-xproto xorg-util-macros shared-mime-info tiff libgnomecanvas gail libart_lgpl libglade2 libgnomeprint bison libgnomecups popt libgsf gnome-vfs desktop-file-utils gconf orbit2 libidl gnome-mime-data libbonobo pcre py25-gtk py25-cairo py25-numpy fftw-3
Error: Status 1 encountered during processing.

The build could continue when I cleaned py25-hashlib:

kollaps:~ henrik$ sudo port clean py25-hashlib 
Password:
--->  Cleaning py25-hashlib

Change History (3)

comment:1 Changed 12 years ago by macports@…

I forgot to mention that this is on a Macbook Pro 2ghz with Leopard 10.5.3.

comment:2 Changed 12 years ago by macports@…

With the workarounds in #15607 (this issue), #15608, #15609 and #15612, gnumeric finally built and installed successfully.

comment:3 Changed 12 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #13930.

Note: See TracTickets for help on using tickets.