Opened 13 years ago

Closed 13 years ago

#15612 closed defect (duplicate)

gnumeric build stopped at py25-numpy

Reported by: macports@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port:

Description

gnumeric failed to build on a fresh and updated macports installation. First it stoppet at p5-hashlib (see Ticket #15607), p5-libxml2 (see Ticket #15608) and p5-getopt-long (see Ticket #15609), then (much later) it stopped at py25-numpy:

--->  Building py25-numpy with target build
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py25-numpy/work/numpy-1.1.0" && /opt/local/bin/python2.5 setup.py build " returned error 1
Command output: Running from numpy source directory.
non-existing path in 'numpy/distutils': 'site.cfg'
F2PY Version 2_5237
blas_opt_info:
  FOUND:
    extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
    define_macros = [('NO_ATLAS_INFO', 3)]
    extra_compile_args = ['-msse3', '-I/System/Library/Frameworks/vecLib.framework/Headers']

lapack_opt_info:
  FOUND:
    extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
    define_macros = [('NO_ATLAS_INFO', 3)]
    extra_compile_args = ['-msse3']

running build
running scons
customize UnixCCompiler
Could not locate executable -DNDEBUG
error: Could not find compiler executable info for scons

Error: The following dependencies failed to build: py25-gtk py25-cairo py25-numpy
Error: Status 1 encountered during processing.

The build could continue after cleaning py25-numpy:

kollaps:~ henrik$ sudo /opt/local/bin/port clean py25-numpy
--->  Cleaning py25-numpy

This is on a Macbook Pro 2ghz with Leopard 10.5.3.

Change History (2)

comment:1 Changed 13 years ago by macports@…

With the workarounds in #15607, #15608, #15609 and #15612 (this issue), gnumeric finally built and installed successfully.

comment:2 Changed 13 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #13930.

Note: See TracTickets for help on using tickets.