Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#15689 closed defect (duplicate)

sqlite3 fails to build

Reported by: donald.ball@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: sqlite3 Cc:
Port:

Description

I got this in the course of trying to install apache2 on Leopard:

--->  Fetching sqlite3
--->  Attempting to fetch sqlite-3.5.9.tar.gz from http://www.sqlite.org/
--->  Verifying checksum(s) for sqlite3
--->  Extracting sqlite3
--->  Configuring sqlite3
--->  Building sqlite3 with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_sqlite3/work/sqlite-3.5.9" && gnumake all " returned error 2
Command output: sed -e s/--VERS--/3.5.9/ ./src/sqlite.h.in | \
	sed -e s/--VERSION-NUMBER--/3005009/ >sqlite3.h
/usr/bin/gcc-4.0 -O2 -o mkkeywordhash  ./tool/mkkeywordhash.c
./mkkeywordhash >keywordhash.h
/usr/bin/gcc-4.0 -O2 -o lemon ./tool/lemon.c
cp ./tool/lempar.c .
cp ./src/parse.y .
./lemon  parse.y
mv parse.h parse.h.temp
f ./addopcodes.awk parse.h.temp >parse.h
/bin/sh: f: command not found
gnumake: [parse.c] Error 127 (ignored)
cat parse.h ./src/vdbe.c |  -f ./mkopcodeh.awk >opcodes.h
/bin/sh: -f: command not found
cat: stdout: Broken pipe
gnumake: *** [opcodes.h] Error 127

Error: The following dependencies failed to build: apr-util sqlite3 pcre
Error: Status 1 encountered during processing.

Subsequent attempts to install sqlite3 give me:

donald-balls-macbook-pro:~ dball$ sudo port install sqlite3
--->  Building sqlite3 with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_sqlite3/work/sqlite-3.5.9" && gnumake all " returned error 2
Command output: sqlite3.c:75960: error: 'TK_GE' undeclared (first use in this function)
sqlite3.c:75963: error: 'TK_RSHIFT' undeclared (first use in this function)
sqlite3.c:75966: error: 'TK_GT' undeclared (first use in this function)
sqlite3.c:75972: error: 'TK_ILLEGAL' undeclared (first use in this function)
sqlite3.c:75981: error: 'TK_BITOR' undeclared (first use in this function)
sqlite3.c:75984: error: 'TK_CONCAT' undeclared (first use in this function)
sqlite3.c:75989: error: 'TK_COMMA' undeclared (first use in this function)
sqlite3.c:75993: error: 'TK_BITAND' undeclared (first use in this function)
sqlite3.c:75997: error: 'TK_BITNOT' undeclared (first use in this function)
sqlite3.c:76014: error: 'TK_STRING' undeclared (first use in this function)
sqlite3.c:76026: error: 'TK_DOT' undeclared (first use in this function)
sqlite3.c:76034: error: 'TK_INTEGER' undeclared (first use in this function)
sqlite3.c:76040: error: 'TK_FLOAT' undeclared (first use in this function)
sqlite3.c:76060: error: 'TK_ID' undeclared (first use in this function)
sqlite3.c:76060: warning: assignment makes integer from pointer without a cast
sqlite3.c:76064: error: 'TK_VARIABLE' undeclared (first use in this function)
sqlite3.c:76073: error: 'TK_REGISTER' undeclared (first use in this function)
sqlite3.c:76113: error: 'TK_BLOB' undeclared (first use in this function)
sqlite3.c: In function 'sqlite3RunParser':
sqlite3.c:76184: error: 'TK_SPACE' undeclared (first use in this function)
sqlite3.c:76184: warning: case label value exceeds maximum value for type
sqlite3.c:76185: error: 'TK_COMMENT' undeclared (first use in this function)
sqlite3.c:76185: warning: case label value exceeds maximum value for type
sqlite3.c:76193: error: 'TK_ILLEGAL' undeclared (first use in this function)
sqlite3.c:76193: warning: case label value exceeds maximum value for type
sqlite3.c:76202: error: 'TK_SEMI' undeclared (first use in this function)
sqlite3.c:76202: warning: case label value exceeds maximum value for type
sqlite3.c:76218: warning: comparison between pointer and integer
sqlite3.c:76219: warning: passing argument 2 of 'sqlite3Parser' makes integer from pointer without a cast
gnumake: *** [sqlite3.lo] Error 1

Error: Status 1 encountered during processing.

Any suggestions?

Change History (2)

comment:1 Changed 12 years ago by raimue (Rainer Müller)

Milestone: Port Bugs
Resolution: duplicate
Status: newclosed
Version: 1.6.0

Duplicate of #13953.

You need to clean between subsequent attempts.

$ sudo port clean sqlite3

This is a known problem with Tcl on Leopard.

comment:2 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.