Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#15693 closed defect (worksforme)

problem upgrading libbonobo

Reported by: webmaster@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.5.0
Keywords: libbonobo Cc: jmroot (Joshua Root)
Port:

Description (last modified by jmpp@…)

it is from much time that I have this problem:

sudo port upgrade outdated

--->  Activating libbonobo 2.20.4_0
Error: Activating libbonobo 2.20.4_0 failed: Image error: Another version of this port (libbonobo @2.20.1_2) is already active.
--->  Activating gnome-vfs 2.20.1_1
Error: Activating gnome-vfs 2.20.1_1 failed: Image error: Another version of this port (gnome-vfs @2.20.0_1) is already active.
--->  Activating gtk-doc 1.10_2
Error: Activating gtk-doc 1.10_2 failed: Image error: /opt/local/var/scrollkeeper/am/scrollkeeper_cl.xml already exists and does not belong to a registered port.  Unable to activate port gtk-doc.
--->  Building libgnome with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_libgnome/work/libgnome-2.22.0" && make all " returned error 2
Command output:  /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I.. -I.. -D_REENTRANT -DORBIT2=1 -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/gnome-vfs-2.0 -I/opt/local/lib/gnome-vfs-2.0/include -I/opt/local/include/gconf/2 -I/opt/local/include/orbit-2.0 -I/opt/local/include/libbonobo-2.0 -I/opt/local/include/bonobo-activation-2.0 -DG_LOG_DOMAIN=\"libgnome\" -DVERSION=\"2.22.0\" -I/opt/local/include -O2 -MT bonobo-config-bag.lo -MD -MP -MF .deps/bonobo-config-bag.Tpo -c bonobo-config-bag.c  -fno-common -DPIC -o .libs/bonobo-config-bag.o
bonobo-config-bag.c: In function 'impl_Bonobo_PropertyBag_setValue':
bonobo-config-bag.c:212: error: parse error before 'do'
bonobo-config-bag.c:212: error: too few arguments to function 'gconf_client_set_string'
bonobo-config-bag.c:212: error: parse error before '_g_boolean_var_'
bonobo-config-bag.c:212: error: '_g_boolean_var_' undeclared (first use in this function)
bonobo-config-bag.c:212: error: (Each undeclared identifier is reported only once
bonobo-config-bag.c:212: error: for each function it appears in.)
bonobo-config-bag.c:212: error: parse error before ')' token
bonobo-config-bag.c: At top level:
bonobo-config-bag.c:216: warning: data definition has no type or storage class
bonobo-config-bag.c:216: error: parse error before '}' token
bonobo-config-bag.c:220: warning: data definition has no type or storage class
bonobo-config-bag.c:220: error: parse error before '}' token
bonobo-config-bag.c:224: warning: data definition has no type or storage class
bonobo-config-bag.c:224: error: parse error before '}' token
bonobo-config-bag.c:231: error: parse error before '(' token
bonobo-config-bag.c:235: warning: parameter names (without types) in function declaration
bonobo-config-bag.c:235: error: conflicting types for 'g_free'
/opt/local/include/glib-2.0/glib/gmem.h:51: error: previous declaration of 'g_free' was here
bonobo-config-bag.c:235: warning: data definition has no type or storage class
bonobo-config-bag.c:237: error: parse error before 'if'
bonobo-config-bag.c:239: warning: parameter names (without types) in function declaration
bonobo-config-bag.c:239: error: conflicting types for 'g_error_free'
/opt/local/include/glib-2.0/glib/gerror.h:46: error: previous declaration of 'g_error_free' was here
bonobo-config-bag.c:239: warning: data definition has no type or storage class
bonobo-config-bag.c:240: error: parse error before '}' token
make[2]: *** [bonobo-config-bag.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Unable to upgrade port: 1
--->  Building libbonoboui with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_libbonoboui/work/libbonoboui-2.22.0" && make all " returned error 2
Command output: make  all-recursive
Making all in bonobo
/bin/sh ../libtool --tag=CC   --mode=compile /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I.. -I.. -I.. -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare  -DXTHREADS -DORBIT2=1 -D_REENTRANT -I/opt/local/include/libgnomecanvas-2.0 -I/opt/local/include/pango-1.0 -I/opt/local/include/gail-1.0 -I/opt/local/include/libart-2.0 -I/opt/local/include/gtk-2.0 -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/freetype2 -I/opt/local/include/atk-1.0 -I/opt/local/lib/gtk-2.0/include -I/opt/local/include/cairo -I/opt/local/include/libpng12 -I/usr/X11R6/include -I/opt/local/include/pixman-1 -I/opt/local/include/libbonobo-2.0 -I/opt/local/include/orbit-2.0 -I/opt/local/include/bonobo-activation-2.0 -I/opt/local/include/libgnome-2.0 -I/opt/local/include/gconf/2 -I/opt/local/include/gnome-vfs-2.0 -I/opt/local/lib/gnome-vfs-2.0/include -I/opt/local/include/libxml2 -I/opt/local/include/gnome-vfs-module-2.0   -DPREFIX=\""/opt/local"\" -DPLUGIN_DIR=\"""\" -DBONOBO_UI_INTERNAL -DBONOBO_UIDIR=\""/opt/local/share/gnome-2.0/ui/"\" -DBONOBO_LIBDIR=\""/opt/local/lib"\" -DBONOBO_DATADIR=\""/opt/local/share"\" -DBONOBO_PIXMAPDIR=\""/opt/local/share/pixmaps"\" -DBONOBO_BINDIR=\""/opt/local/bin"\" -DBONOBO_LOCALSTATEDIR=\""/opt/local/var"\" -DBONOBO_LOCALEDIR="\"/opt/local/share/locale\"" -DBONOBO_EXPLICIT_TRANSLATION_DOMAIN="GETTEXT_PACKAGE" -DG_LOG_DOMAIN=\"Bonobo\" -DVERSION=\"2.22.0\"  -UBONOBO_DISABLE_DEPRECATED -UBONOBO_UI_DISABLE_DEPRECATED  -I/opt/local/include -L/opt/local/lib  -O2 -no-cpp-precomp -flat_namespace -undefined suppress -MT bonobo-ui-toolbar-control-item.lo -MD -MP -MF .deps/bonobo-ui-toolbar-control-item.Tpo -c -o bonobo-ui-toolbar-control-item.lo bonobo-ui-toolbar-control-item.c
 /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I.. -I.. -I.. -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare -DXTHREADS -DORBIT2=1 -D_REENTRANT -I/opt/local/include/libgnomecanvas-2.0 -I/opt/local/include/pango-1.0 -I/opt/local/include/gail-1.0 -I/opt/local/include/libart-2.0 -I/opt/local/include/gtk-2.0 -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/freetype2 -I/opt/local/include/atk-1.0 -I/opt/local/lib/gtk-2.0/include -I/opt/local/include/cairo -I/opt/local/include/libpng12 -I/usr/X11R6/include -I/opt/local/include/pixman-1 -I/opt/local/include/libbonobo-2.0 -I/opt/local/include/orbit-2.0 -I/opt/local/include/bonobo-activation-2.0 -I/opt/local/include/libgnome-2.0 -I/opt/local/include/gconf/2 -I/opt/local/include/gnome-vfs-2.0 -I/opt/local/lib/gnome-vfs-2.0/include -I/opt/local/include/libxml2 -I/opt/local/include/gnome-vfs-module-2.0 -DPREFIX=\"/opt/local\" -DPLUGIN_DIR=\"\" -DBONOBO_UI_INTERNAL -DBONOBO_UIDIR=\"/opt/local/share/gnome-2.0/ui/\" -DBONOBO_LIBDIR=\"/opt/local/lib\" -DBONOBO_DATADIR=\"/opt/local/share\" -DBONOBO_PIXMAPDIR=\"/opt/local/share/pixmaps\" -DBONOBO_BINDIR=\"/opt/local/bin\" -DBONOBO_LOCALSTATEDIR=\"/opt/local/var\" -DBONOBO_LOCALEDIR=\"/opt/local/share/locale\" -DBONOBO_EXPLICIT_TRANSLATION_DOMAIN=GETTEXT_PACKAGE -DG_LOG_DOMAIN=\"Bonobo\" -DVERSION=\"2.22.0\" -UBONOBO_DISABLE_DEPRECATED -UBONOBO_UI_DISABLE_DEPRECATED -I/opt/local/include -L/opt/local/lib -O2 -no-cpp-precomp -flat_namespace -undefined suppress -MT bonobo-ui-toolbar-control-item.lo -MD -MP -MF .deps/bonobo-ui-toolbar-control-item.Tpo -c bonobo-ui-toolbar-control-item.c  -fno-common -DPIC -o .libs/bonobo-ui-toolbar-control-item.o
bonobo-ui-toolbar-control-item.c: In function 'set_control_property_bag_gint':
bonobo-ui-toolbar-control-item.c:61: error: parse error before 'do'
bonobo-ui-toolbar-control-item.c:61: warning: left-hand operand of comma expression has no effect
bonobo-ui-toolbar-control-item.c:61: warning: left-hand operand of comma expression has no effect
bonobo-ui-toolbar-control-item.c:61: error: parse error before ')' token
bonobo-ui-toolbar-control-item.c:61: error: '_g_boolean_var_' undeclared (first use in this function)
bonobo-ui-toolbar-control-item.c:61: error: (Each undeclared identifier is reported only once
bonobo-ui-toolbar-control-item.c:61: error: for each function it appears in.)
bonobo-ui-toolbar-control-item.c: At top level:
bonobo-ui-toolbar-control-item.c:61: error: parse error before ')' token
bonobo-ui-toolbar-control-item.c:61: warning: type defaults to 'int' in declaration of 'set_control_property_bag_value'
bonobo-ui-toolbar-control-item.c:61: warning: parameter names (without types) in function declaration
bonobo-ui-toolbar-control-item.c:61: error: conflicting types for 'set_control_property_bag_value'
bonobo-ui-toolbar-control-item.c:27: error: previous definition of 'set_control_property_bag_value' was here
bonobo-ui-toolbar-control-item.c:61: warning: data definition has no type or storage class
bonobo-ui-toolbar-control-item.c:61: warning: type defaults to 'int' in declaration of 'bonobo_arg_release'
bonobo-ui-toolbar-control-item.c:61: warning: parameter names (without types) in function declaration
bonobo-ui-toolbar-control-item.c:61: error: conflicting types for 'bonobo_arg_release'
/opt/local/include/libbonobo-2.0/bonobo/bonobo-arg.h:91: error: previous declaration of 'bonobo_arg_release' was here
bonobo-ui-toolbar-control-item.c:61: warning: data definition has no type or storage class
bonobo-ui-toolbar-control-item.c:61: error: parse error before '}' token
make[2]: *** [bonobo-ui-toolbar-control-item.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Unable to upgrade port: 1
--->  Activating p5-getopt-long 2.37_0
Error: Activating p5-getopt-long 2.37_0 failed: Image error: /opt/local/lib/perl5/5.8.8/Getopt/Long.pm is being used by the active perl5.8 port.  Please deactivate this port first, or use the -f flag to force the activation.
--->  Configuring evolution-data-server
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_evolution-data-server/work/evolution-data-server-2.22.1" && ./configure --prefix=/opt/local --enable-static --enable-nss --enable-smime --enable-gnome-keyring --enable-ipv6 --enable-nntp --enable-gtk-doc --with-libiconv=/opt/local --with-nspr-includes=/opt/local/include/nspr --with-nss-includes=/opt/local/include/nss --with-krb5=/usr " returned error 1
Command output: checking semaphore.h presence... yes
checking for semaphore.h... yes
checking sys/wait.h usability... yes
checking sys/wait.h presence... yes
checking for sys/wait.h... yes
checking for fsync... yes
checking for strptime... yes
checking for strtok_r... yes
checking alloca.h usability... yes
checking alloca.h presence... yes
checking for alloca.h... yes
checking for GNOME_PLATFORM... configure: error: Package requirements (gtk+-2.0 >= 2.10.0
         ORBit-2.0 >= 2.9.8
         gnome-vfs-2.0 >= 2.4.0
         libbonobo-2.0 >= 2.20.3
         gconf-2.0 >= 2.0.0
         libglade-2.0 >= 2.0.0
         libgnome-2.0 >= 2.0.0
         libxml-2.0 >= 2.0.0
         libsoup-2.4 >= 2.3.0) were not met:

Requested 'libbonobo-2.0 >= 2.20.3' but version of libbonobo is 2.20.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GNOME_PLATFORM_CFLAGS
and GNOME_PLATFORM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Error: Unable to upgrade port: 1
--->  Activating gnome-vfs 2.20.1_1
Error: Activating gnome-vfs 2.20.1_1 failed: Image error: Another version of this port (gnome-vfs @2.20.0_1) is already active.
--->  Activating libbonobo 2.20.4_0
Error: Activating libbonobo 2.20.4_0 failed: Image error: Another version of this port (libbonobo @2.20.1_2) is already active.
--->  Activating gnome-vfs 2.20.1_1
Error: Activating gnome-vfs 2.20.1_1 failed: Image error: Another version of this port (gnome-vfs @2.20.0_1) is already active.
--->  Activating libbonobo 2.20.4_0
Error: Activating libbonobo 2.20.4_0 failed: Image error: Another version of this port (libbonobo @2.20.1_2) is already active.
--->  Building libgnome with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_libgnome/work/libgnome-2.22.0" && make all " returned error 2
Command output:  /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I.. -I.. -D_REENTRANT -DORBIT2=1 -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/gnome-vfs-2.0 -I/opt/local/lib/gnome-vfs-2.0/include -I/opt/local/include/gconf/2 -I/opt/local/include/orbit-2.0 -I/opt/local/include/libbonobo-2.0 -I/opt/local/include/bonobo-activation-2.0 -DG_LOG_DOMAIN=\"libgnome\" -DVERSION=\"2.22.0\" -I/opt/local/include -O2 -MT bonobo-config-bag.lo -MD -MP -MF .deps/bonobo-config-bag.Tpo -c bonobo-config-bag.c  -fno-common -DPIC -o .libs/bonobo-config-bag.o
bonobo-config-bag.c: In function 'impl_Bonobo_PropertyBag_setValue':
bonobo-config-bag.c:212: error: parse error before 'do'
bonobo-config-bag.c:212: error: too few arguments to function 'gconf_client_set_string'
bonobo-config-bag.c:212: error: parse error before '_g_boolean_var_'
bonobo-config-bag.c:212: error: '_g_boolean_var_' undeclared (first use in this function)
bonobo-config-bag.c:212: error: (Each undeclared identifier is reported only once
bonobo-config-bag.c:212: error: for each function it appears in.)
bonobo-config-bag.c:212: error: parse error before ')' token
bonobo-config-bag.c: At top level:
bonobo-config-bag.c:216: warning: data definition has no type or storage class
bonobo-config-bag.c:216: error: parse error before '}' token
bonobo-config-bag.c:220: warning: data definition has no type or storage class
bonobo-config-bag.c:220: error: parse error before '}' token
bonobo-config-bag.c:224: warning: data definition has no type or storage class
bonobo-config-bag.c:224: error: parse error before '}' token
bonobo-config-bag.c:231: error: parse error before '(' token
bonobo-config-bag.c:235: warning: parameter names (without types) in function declaration
bonobo-config-bag.c:235: error: conflicting types for 'g_free'
/opt/local/include/glib-2.0/glib/gmem.h:51: error: previous declaration of 'g_free' was here
bonobo-config-bag.c:235: warning: data definition has no type or storage class
bonobo-config-bag.c:237: error: parse error before 'if'
bonobo-config-bag.c:239: warning: parameter names (without types) in function declaration
bonobo-config-bag.c:239: error: conflicting types for 'g_error_free'
/opt/local/include/glib-2.0/glib/gerror.h:46: error: previous declaration of 'g_error_free' was here
bonobo-config-bag.c:239: warning: data definition has no type or storage class
bonobo-config-bag.c:240: error: parse error before '}' token
make[2]: *** [bonobo-config-bag.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Unable to upgrade port: 1
--->  Building libbonoboui with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_libbonoboui/work/libbonoboui-2.22.0" && make all " returned error 2
Command output: make  all-recursive
Making all in bonobo
/bin/sh ../libtool --tag=CC   --mode=compile /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I.. -I.. -I.. -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare  -DXTHREADS -DORBIT2=1 -D_REENTRANT -I/opt/local/include/libgnomecanvas-2.0 -I/opt/local/include/pango-1.0 -I/opt/local/include/gail-1.0 -I/opt/local/include/libart-2.0 -I/opt/local/include/gtk-2.0 -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/freetype2 -I/opt/local/include/atk-1.0 -I/opt/local/lib/gtk-2.0/include -I/opt/local/include/cairo -I/opt/local/include/libpng12 -I/usr/X11R6/include -I/opt/local/include/pixman-1 -I/opt/local/include/libbonobo-2.0 -I/opt/local/include/orbit-2.0 -I/opt/local/include/bonobo-activation-2.0 -I/opt/local/include/libgnome-2.0 -I/opt/local/include/gconf/2 -I/opt/local/include/gnome-vfs-2.0 -I/opt/local/lib/gnome-vfs-2.0/include -I/opt/local/include/libxml2 -I/opt/local/include/gnome-vfs-module-2.0   -DPREFIX=\""/opt/local"\" -DPLUGIN_DIR=\"""\" -DBONOBO_UI_INTERNAL -DBONOBO_UIDIR=\""/opt/local/share/gnome-2.0/ui/"\" -DBONOBO_LIBDIR=\""/opt/local/lib"\" -DBONOBO_DATADIR=\""/opt/local/share"\" -DBONOBO_PIXMAPDIR=\""/opt/local/share/pixmaps"\" -DBONOBO_BINDIR=\""/opt/local/bin"\" -DBONOBO_LOCALSTATEDIR=\""/opt/local/var"\" -DBONOBO_LOCALEDIR="\"/opt/local/share/locale\"" -DBONOBO_EXPLICIT_TRANSLATION_DOMAIN="GETTEXT_PACKAGE" -DG_LOG_DOMAIN=\"Bonobo\" -DVERSION=\"2.22.0\"  -UBONOBO_DISABLE_DEPRECATED -UBONOBO_UI_DISABLE_DEPRECATED  -I/opt/local/include -L/opt/local/lib  -O2 -no-cpp-precomp -flat_namespace -undefined suppress -MT bonobo-ui-toolbar-control-item.lo -MD -MP -MF .deps/bonobo-ui-toolbar-control-item.Tpo -c -o bonobo-ui-toolbar-control-item.lo bonobo-ui-toolbar-control-item.c
 /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I.. -I.. -I.. -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare -DXTHREADS -DORBIT2=1 -D_REENTRANT -I/opt/local/include/libgnomecanvas-2.0 -I/opt/local/include/pango-1.0 -I/opt/local/include/gail-1.0 -I/opt/local/include/libart-2.0 -I/opt/local/include/gtk-2.0 -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/freetype2 -I/opt/local/include/atk-1.0 -I/opt/local/lib/gtk-2.0/include -I/opt/local/include/cairo -I/opt/local/include/libpng12 -I/usr/X11R6/include -I/opt/local/include/pixman-1 -I/opt/local/include/libbonobo-2.0 -I/opt/local/include/orbit-2.0 -I/opt/local/include/bonobo-activation-2.0 -I/opt/local/include/libgnome-2.0 -I/opt/local/include/gconf/2 -I/opt/local/include/gnome-vfs-2.0 -I/opt/local/lib/gnome-vfs-2.0/include -I/opt/local/include/libxml2 -I/opt/local/include/gnome-vfs-module-2.0 -DPREFIX=\"/opt/local\" -DPLUGIN_DIR=\"\" -DBONOBO_UI_INTERNAL -DBONOBO_UIDIR=\"/opt/local/share/gnome-2.0/ui/\" -DBONOBO_LIBDIR=\"/opt/local/lib\" -DBONOBO_DATADIR=\"/opt/local/share\" -DBONOBO_PIXMAPDIR=\"/opt/local/share/pixmaps\" -DBONOBO_BINDIR=\"/opt/local/bin\" -DBONOBO_LOCALSTATEDIR=\"/opt/local/var\" -DBONOBO_LOCALEDIR=\"/opt/local/share/locale\" -DBONOBO_EXPLICIT_TRANSLATION_DOMAIN=GETTEXT_PACKAGE -DG_LOG_DOMAIN=\"Bonobo\" -DVERSION=\"2.22.0\" -UBONOBO_DISABLE_DEPRECATED -UBONOBO_UI_DISABLE_DEPRECATED -I/opt/local/include -L/opt/local/lib -O2 -no-cpp-precomp -flat_namespace -undefined suppress -MT bonobo-ui-toolbar-control-item.lo -MD -MP -MF .deps/bonobo-ui-toolbar-control-item.Tpo -c bonobo-ui-toolbar-control-item.c  -fno-common -DPIC -o .libs/bonobo-ui-toolbar-control-item.o
bonobo-ui-toolbar-control-item.c: In function 'set_control_property_bag_gint':
bonobo-ui-toolbar-control-item.c:61: error: parse error before 'do'
bonobo-ui-toolbar-control-item.c:61: warning: left-hand operand of comma expression has no effect
bonobo-ui-toolbar-control-item.c:61: warning: left-hand operand of comma expression has no effect
bonobo-ui-toolbar-control-item.c:61: error: parse error before ')' token
bonobo-ui-toolbar-control-item.c:61: error: '_g_boolean_var_' undeclared (first use in this function)
bonobo-ui-toolbar-control-item.c:61: error: (Each undeclared identifier is reported only once
bonobo-ui-toolbar-control-item.c:61: error: for each function it appears in.)
bonobo-ui-toolbar-control-item.c: At top level:
bonobo-ui-toolbar-control-item.c:61: error: parse error before ')' token
bonobo-ui-toolbar-control-item.c:61: warning: type defaults to 'int' in declaration of 'set_control_property_bag_value'
bonobo-ui-toolbar-control-item.c:61: warning: parameter names (without types) in function declaration
bonobo-ui-toolbar-control-item.c:61: error: conflicting types for 'set_control_property_bag_value'
bonobo-ui-toolbar-control-item.c:27: error: previous definition of 'set_control_property_bag_value' was here
bonobo-ui-toolbar-control-item.c:61: warning: data definition has no type or storage class
bonobo-ui-toolbar-control-item.c:61: warning: type defaults to 'int' in declaration of 'bonobo_arg_release'
bonobo-ui-toolbar-control-item.c:61: warning: parameter names (without types) in function declaration
bonobo-ui-toolbar-control-item.c:61: error: conflicting types for 'bonobo_arg_release'
/opt/local/include/libbonobo-2.0/bonobo/bonobo-arg.h:91: error: previous declaration of 'bonobo_arg_release' was here
bonobo-ui-toolbar-control-item.c:61: warning: data definition has no type or storage class
bonobo-ui-toolbar-control-item.c:61: error: parse error before '}' token
make[2]: *** [bonobo-ui-toolbar-control-item.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Unable to upgrade port: 1
--->  Activating libbonobo 2.20.4_0
Error: Activating libbonobo 2.20.4_0 failed: Image error: Another version of this port (libbonobo @2.20.1_2) is already active.
--->  Activating gnome-vfs 2.20.1_1
Error: Activating gnome-vfs 2.20.1_1 failed: Image error: Another version of this port (gnome-vfs @2.20.0_1) is already active.
--->  Building libgnome with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_libgnome/work/libgnome-2.22.0" && make all " returned error 2
Command output:  /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I.. -I.. -D_REENTRANT -DORBIT2=1 -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/gnome-vfs-2.0 -I/opt/local/lib/gnome-vfs-2.0/include -I/opt/local/include/gconf/2 -I/opt/local/include/orbit-2.0 -I/opt/local/include/libbonobo-2.0 -I/opt/local/include/bonobo-activation-2.0 -DG_LOG_DOMAIN=\"libgnome\" -DVERSION=\"2.22.0\" -I/opt/local/include -O2 -MT bonobo-config-bag.lo -MD -MP -MF .deps/bonobo-config-bag.Tpo -c bonobo-config-bag.c  -fno-common -DPIC -o .libs/bonobo-config-bag.o
bonobo-config-bag.c: In function 'impl_Bonobo_PropertyBag_setValue':
bonobo-config-bag.c:212: error: parse error before 'do'
bonobo-config-bag.c:212: error: too few arguments to function 'gconf_client_set_string'
bonobo-config-bag.c:212: error: parse error before '_g_boolean_var_'
bonobo-config-bag.c:212: error: '_g_boolean_var_' undeclared (first use in this function)
bonobo-config-bag.c:212: error: (Each undeclared identifier is reported only once
bonobo-config-bag.c:212: error: for each function it appears in.)
bonobo-config-bag.c:212: error: parse error before ')' token
bonobo-config-bag.c: At top level:
bonobo-config-bag.c:216: warning: data definition has no type or storage class
bonobo-config-bag.c:216: error: parse error before '}' token
bonobo-config-bag.c:220: warning: data definition has no type or storage class
bonobo-config-bag.c:220: error: parse error before '}' token
bonobo-config-bag.c:224: warning: data definition has no type or storage class
bonobo-config-bag.c:224: error: parse error before '}' token
bonobo-config-bag.c:231: error: parse error before '(' token
bonobo-config-bag.c:235: warning: parameter names (without types) in function declaration
bonobo-config-bag.c:235: error: conflicting types for 'g_free'
/opt/local/include/glib-2.0/glib/gmem.h:51: error: previous declaration of 'g_free' was here
bonobo-config-bag.c:235: warning: data definition has no type or storage class
bonobo-config-bag.c:237: error: parse error before 'if'
bonobo-config-bag.c:239: warning: parameter names (without types) in function declaration
bonobo-config-bag.c:239: error: conflicting types for 'g_error_free'
/opt/local/include/glib-2.0/glib/gerror.h:46: error: previous declaration of 'g_error_free' was here
bonobo-config-bag.c:239: warning: data definition has no type or storage class
bonobo-config-bag.c:240: error: parse error before '}' token
make[2]: *** [bonobo-config-bag.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Unable to upgrade port: 1

Change History (5)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Cc: jmr@… added
Milestone: Port UpdatesPort Bugs
Priority: HighNormal
Summary: upgrade libbonoboproblem upgrading libbonobo

Try running sudo port -f uninstall libbonobo @2.20.1_2 before you upgrade.

comment:2 in reply to:  1 Changed 12 years ago by webmaster@…

Replying to jmr@macports.org:

Try running sudo port -f uninstall libbonobo @2.20.1_2 before you upgrade.

this problem is resolved, but

sudo port upgrade outdated ---> Fetching scrollkeeper Error: Target org.macports.fetch returned:

scrollkeeper is superseded by port rarian; use that port instead

Error: Unable to upgrade port: 1

thanks

comment:3 Changed 12 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: newclosed

As it says, scrollkeeper has been superseded by rarian. Uninstall scrollkeeper and install rarian.

comment:4 Changed 12 years ago by jmpp@…

Description: modified (diff)

comment:5 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.