Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#15717 closed defect (duplicate)

texlive_base-2007r1 Build failure

Reported by: kyle.husmann@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: texlive Cc:
Port:

Description

Hi,

I just compiled texlive, and found an error in one of the Makefiles. It was giving me this error:

/bin/sh ../libtool --mode=link /usr/bin/gcc-4.0 -o xdvi-xaw.bin
-L/opt/local/lib   browser.o dvi-draw.o dvi-init.o dvisel.o
encodings.o events.o filehist.o font-open.o gf.o hypertex.o
image-magick.o mime.o my-snprintf.o my-vsnprintf.o pagehist.o pk.o
print-internal.o psdps.o psgs.o psheader.o psnews.o read-mapfile.o
search-internal.o special.o string-utils.o tfmload.o util.o vf.o
xdvi.o xserver-info.o x_util.o ./gui/libgui.a ../../libs/t1lib/libt1.a
../../libs/t1lib/../type1/libtype1.a -L/usr/lib/ruby 1  -L/usr/X11/lib
 -lXaw -lXmu -lXt -lSM -lICE -lXp -lXext -lXpm -lX11 -liconv
../kpathsea/libkpathsea.la -lm
/usr/bin/gcc-4.0 -o xdvi-xaw.bin browser.o dvi-draw.o dvi-init.o
dvisel.o encodings.o events.o filehist.o font-open.o gf.o hypertex.o
image-magick.o mime.o my-snprintf.o my-vsnprintf.o pagehist.o pk.o
print-internal.o psdps.o psgs.o psheader.o psnews.o read-mapfile.o
search-internal.o special.o string-utils.o tfmload.o util.o vf.o
xdvi.o xserver-info.o x_util.o 1  -L/opt/local/lib ./gui/libgui.a
../../libs/t1lib/libt1.a ../../libs/t1lib/../type1/libtype1.a
-L/usr/lib/ruby -L/usr/X11/lib -lXaw -lXmu -lXt -lSM -lICE -lXp -lXext
-lXpm -lX11 -lXau -lXdmcp -liconv ../kpathsea/.libs/libkpathsea.a -lm
i686-apple-darwin9-gcc-4.0.1: 1: No such file or directory
make[2]: *** [xdvi-xaw.bin] Error 1
make[1]: *** [all] Error 1
make: *** [all] Error 1

I fixed it by editing texlive_base-2007/texk/xdvik/Makefile

I changed the line that read:

x_ldflags=-L/usr/lib/ruby 1 -L/usr/X11/lib

to:

x_ldflags=-L/usr/lib/ruby -L/usr/X11/lib

When I asked on the texlive mailing list, they said to look at the line in Makefile.in that reads:

x_ldflags=@X_LIBS@ @x_linker_options@ @iconv_libpath@

And it looks like the `1' got inserted as a result of a configure test.

Change History (3)

comment:2 Changed 12 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Right, this is a duplicate of #13396.

comment:3 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.