Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#15719 closed defect (invalid)

GHC 6.8.3 needs new cabal, cabal-install

Reported by: luke@… Owned by: gwright@…
Priority: Low Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port:

Description

From IRC:

dons: basically, minimal haskell support for a distro *must* be: ghc, core libs, extra libs, cabal 1.4.x , cabal install dons: anything less than that is substandard, and not accredited

Currently port install ghc installs cabal 1.2.4.0, and no cabal-install.

We do want to be accredited, don't we :)

Change History (3)

comment:1 Changed 11 years ago by jmroot (Joshua Root)

Milestone: Port Bugs
Owner: changed from macports-tickets@… to gwright@…

Assigning to maintainer.

comment:2 Changed 11 years ago by gwright@…

Resolution: invalid
Status: newclosed

This is not a bug in ghc. ghc is distributed with a stable version of cabal that it is tested with. Off the cuff remarks on IRC notwithstanding, there is no other "standard" or "accredited" version of ghc.

If you want the cutting edge cabal, that could be provided as a separate port.

comment:3 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.