Opened 12 years ago

Closed 12 years ago

#15732 closed defect (duplicate)

Trouble building python, sort of

Reported by: Dave@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port:

Description

Port stopped because of a build problem, and then just running port again seemed to make it build OK. This happened twice, as you can see below.

--->  Fetching python25
--->  Attempting to fetch Python-2.5.2.tar.bz2 from http://www.python.org//ftp/python/2.5.2/
--->  Verifying checksum(s) for python25
--->  Extracting python25
--->  Applying patches to python25
--->  Configuring python25
--->  Building python25 with target all
--->  Staging python25 into destroot
--->  Installing python25 2.5.2_2+darwin_9
--->  Activating python25 2.5.2_2+darwin_9
--->  Cleaning python25
--->  Fetching py25-bz2
--->  Verifying checksum(s) for py25-bz2
--->  Extracting py25-bz2
--->  Configuring py25-bz2
--->  Building py25-bz2 with target build
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py25-bz2/work/Python-2.5.2/Modules" && /opt/local/bin/python2.5 setup.py build " returned error 1
Command output: running build
running build_ext
building 'bz2' extension
creating build
creating build/temp.macosx-10.3-i386-2.5
-DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I/opt/local/include/ -I/opt/local/include/python2.5 -c bz2module.c -o build/temp.macosx-10.3-i386-2.5/bz2module.o
unable to execute -DNDEBUG: No such file or directory
error: command '-DNDEBUG' failed with exit status 1

Error: The following dependencies failed to build: py25-bz2 py25-hashlib openssl zlib py25-zlib
Error: Status 1 encountered during processing.
Sun 11:13:20 DYMac1.local yost /Users/yost/java/netbeans/src
0 546 Z% df
Filesystem                             1,024-blocks     Used Available Capacity  Mounted on
/dev/disk0s2                                   83,886,080 68,722,564  14,907,516    83%    /
/dev/disk0s3                                   83,886,080 72,167,592  11,718,488    87%    /Volumes/Other
/dev/disk0s4                                   10,485,760 10,417,720    68,040   100%    /Volumes/v1
/dev/disk0s5                                    6,291,456  6,216,124    75,332    99%    /Volumes/v2
/dev/disk0s6                                   46,075,044 43,882,136 2,192,908    96%    /Volumes/x
/dev/disk0s7                                   12,582,892 11,072,644 1,510,248    88%    /Volumes/Alt
map -hosts                                              0        0         0   100%    /net
/dev/disk1s2                                   10,380,900  6,008,784 4,372,116    58%    /Volumes/stuff
/dev/disk2s2                                    6,186,596  4,274,552 1,912,044    70%    /Volumes/n
afp_3ZY2yI00,089T0,000oM0,000VU-1.2d000,003  62,778,240 57,052,292 5,725,948    91%    /Volumes/Laura
Sun 12:20:18 DYMac1.local yost /Users/yost/java/netbeans/src
0 547 Z% sudo port install mercurial
Password:
--->  Building py25-bz2 with target build
--->  Staging py25-bz2 into destroot
--->  Installing py25-bz2 2.5.2_0
--->  Activating py25-bz2 2.5.2_0
--->  Cleaning py25-bz2
--->  Fetching zlib
...
--->  Cleaning openssl
--->  Fetching py25-hashlib
--->  Verifying checksum(s) for py25-hashlib
--->  Extracting py25-hashlib
--->  Configuring py25-hashlib
--->  Building py25-hashlib with target build
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py25-hashlib/work/Python-2.5.2/Modules" && /opt/local/bin/python2.5 setup.py build " returned error 1
Command output: running build
running build_ext
building '_hashlib' extension
creating build
creating build/temp.macosx-10.3-i386-2.5
-DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I/opt/local/include -I/opt/local/include/python2.5 -c _hashopenssl.c -o build/temp.macosx-10.3-i386-2.5/_hashopenssl.o
unable to execute -DNDEBUG: No such file or directory
error: command '-DNDEBUG' failed with exit status 1

Error: The following dependencies failed to build: py25-hashlib py25-zlib
Error: Status 1 encountered during processing.
Sun 12:24:46 DYMac1.local yost /Users/yost/java/netbeans/src
0 548 Z% sudo port install mercurial
--->  Building py25-hashlib with target build
--->  Staging py25-hashlib into destroot
--->  Installing py25-hashlib 2.5.2_0
--->  Activating py25-hashlib 2.5.2_0
--->  Cleaning py25-hashlib
--->  Fetching py25-zlib
--->  Verifying checksum(s) for py25-zlib
--->  Extracting py25-zlib
--->  Configuring py25-zlib
--->  Building py25-zlib with target build
--->  Staging py25-zlib into destroot
--->  Installing py25-zlib 2.5.2_0
--->  Activating py25-zlib 2.5.2_0
--->  Cleaning py25-zlib
--->  Fetching mercurial


Change History (1)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #13930.

Note: See TracTickets for help on using tickets.