Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#15757 closed defect (invalid)

port distfiles shows name and URLs of new distfile but checksums of old distfile

Reported by: ryandesign (Ryan Schmidt) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: base Version: 1.7.0
Keywords: Cc: wsiegrist@…
Port:

Description

The ncid port is at version 0.70. "port distfiles ncid" says this:

$ port distfiles ncid
--->  Distfiles for ncid
[ncid-0.70.tar.gz]
 md5: e179fbac6ab04ed3015fdf4e1c2a33f6
 sha1: 287ebd8181f94be6a252edb10bf8b3593ac50d60
 rmd160: 3da3269e9c8dd1da1c9ddf3b1e7be180230979a9
  http://downloads.sourceforge.net/ncid/ncid-0.70.tar.gz
[snip other download locations]

I edited the portfile and updated the version to 0.71. Now "port distfiles ncid" says this:

$ port distfiles ncid
Portfile changed since last build; discarding previous state.
--->  Distfiles for ncid
[ncid-0.71.tar.gz]
 md5: e179fbac6ab04ed3015fdf4e1c2a33f6
 sha1: 287ebd8181f94be6a252edb10bf8b3593ac50d60
 rmd160: 3da3269e9c8dd1da1c9ddf3b1e7be180230979a9
  http://downloads.sourceforge.net/ncid/ncid-0.71.tar.gz
[snip other download locations]

I see two problems:

  1. It did not attempt to fetch ncid-0.71.tar.gz
  2. Even if I "port fetch ncid" to get the new distfile, it is still showing the checksums of ncid-0.70.tar.gz; it should show the checksums of ncid-0.71.tar.gz

Or do I misunderstand how "port distfiles" is meant to work?

Change History (9)

comment:1 Changed 12 years ago by wsiegrist@…

distfiles was originally meant to help the mirroring process and to be a debugging tool. It does not do any actual fetching or calculating of checksums, it just shows you what the Portfile says. I'm assuming that you did not change the checksums when you changed the distfile, which is why the checksums were still for the old distfile.

comment:2 Changed 12 years ago by ryandesign (Ryan Schmidt)

Right, I did not yet change the Portfile's checksums. I was trying to use port distfiles to help me learn what the new checksums should be so that I could update the Portfile.

comment:3 Changed 12 years ago by wsiegrist@…

Owner: changed from macports-tickets@… to ryandesign@…

I always just use "port -d fetch" to make it tell me the correct checksums. But no one relies on this command as far as I know, mirroring is done with the mirror command entirely, so feel free to change/improve the distfiles command.

I'm assigning to you to repurpose or close the ticket.

comment:4 Changed 12 years ago by wsiegrist@…

Cc: wsiegrist@… removed

Cc Me!

comment:5 Changed 12 years ago by wsiegrist@…

Cc: wsiegrist@… added

Cc Me!

comment:6 in reply to:  2 Changed 12 years ago by blb@…

Replying to ryandesign@macports.org:

Right, I did not yet change the Portfile's checksums. I was trying to use port distfiles to help me learn what the new checksums should be so that I could update the Portfile.

FYI, I always update the Portfile then run 'port -d checksum' to fetch and tell me the new one.

comment:7 Changed 12 years ago by tobypeterson

Milestone: MacPorts base bugsMacPorts Future

Milestone MacPorts base bugs deleted

comment:8 Changed 11 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: newclosed

Working as intended.

comment:9 Changed 11 years ago by jmroot (Joshua Root)

Milestone: MacPorts Future
Note: See TracTickets for help on using tickets.