Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#15889 closed defect (fixed)

MacFUSE 1.7 fails to build

Reported by: rodrigo.haenggi@… Owned by: kballard (Lily Ballard)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: MacFUSE 1.7 Cc: niels@…, raimue (Rainer Müller), jmroot (Joshua Root), blb@…, trevor@…, neal.dudley@…, mail@…, j.bugzilla2@…, jochen@…, mf2k (Frank Schima), skymoo (Adam Mercer), js-macports@…
Port: macfuse

Description

MacFUSE fails to build on my system with following error message:

MacFUSE:
	PhaseScriptExecution /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_fuse_macfuse/work/macfuse-core/sdk-objc/build/MacFUSE.build/Release/MacFUSE.build/Script-FF8DE2320D4EFE7C0007BFF6.sh
(1 failure)

Whole log attached to ticket.

System: MacBookPro Core2 Duo, Leopard 10.5.4, Darwin Kernel Version 9.4.0 i386 release

Attachments (1)

MacFUSE.log (88.4 KB) - added by rodrigo.haenggi@… 13 years ago.
MacFUSE Log

Download all attachments as: .zip

Change History (23)

Changed 13 years ago by rodrigo.haenggi@…

Attachment: MacFUSE.log added

MacFUSE Log

comment:1 Changed 13 years ago by raimue (Rainer Müller)

Owner: changed from macports-tickets@… to eridius@…

comment:2 Changed 13 years ago by jmroot (Joshua Root)

Milestone: Port Bugs
Priority: HighNormal

So gen_bridge_metadata is failing as in #15284, but in a different way.

comment:3 in reply to:  2 Changed 13 years ago by ses@…

Replying to jmr@macports.org:

So gen_bridge_metadata is failing as in #15284, but in a different way.

Underlying bug is in /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rexml/document.rb

There's a typo of trans instead of transitive

* /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rexml/document.rb 2008-07-08 10:33:39.000000000 -0400 --- document.rb 2008-07-08 10:22:28.000000000 -0400 * * 184,190

output = Output.new( output, xml_decl.encoding )

end formatter = if indent > -1

! if trans

REXML::Formatters::Transitive.new( indent, ie_hack )

else

REXML::Formatters::Pretty.new( indent, ie_hack )

--- 184,190 ----

output = Output.new( output, xml_decl.encoding )

end formatter = if indent > -1

! if transitive

REXML::Formatters::Transitive.new( indent, ie_hack )

else

REXML::Formatters::Pretty.new( indent, ie_hack )

comment:4 Changed 13 years ago by niels@…

I can confirm this bug report as well as the workaround by ses on an up-to-date Leopard 10.5.4 installation with standard ruby libraries. So this should be closed as it is an Apple bug?

comment:5 Changed 13 years ago by niels@…

Cc: niels@… added

Cc Me!

comment:6 Changed 13 years ago by raimue (Rainer Müller)

Cc: raimue@… added

Maybe we should create our own port for BridgeSupport to avoid these problems with the system's provided version.

comment:7 Changed 13 years ago by raimue (Rainer Müller)

I filed rdar://problem/6071648 for the problem in rexml.

comment:8 Changed 13 years ago by jmroot (Joshua Root)

Cc: jmr@… added

comment:9 Changed 13 years ago by blb@…

Cc: blb@… added

Note that the trans -> transitive seems to be the opposite of a bug report in REXML that claims transitive is wrong...

comment:10 in reply to:  9 ; Changed 13 years ago by niels@…

Replying to blb@macports.org:

The latest changeset linked from the mentioned REXML bug report indicates that it should indeed be "transitive" though.

comment:11 Changed 13 years ago by trevor@…

Cc: trevor@… added

Cc Me!

comment:12 in reply to:  10 Changed 13 years ago by trevor@…

Replying to niels@herimedia.com:

Replying to blb@macports.org:

The latest changeset linked from the mentioned REXML bug report indicates that it should indeed be "transitive" though.

Right, it looks like it was originally transitive, broke, got changed to trans in a fix, broke again, then got changed back to transitive in another fix.

Apple must have grabbed their copy during the second period it was broken.

comment:13 Changed 12 years ago by blb@…

Cc: neal.dudley@… added

Cc reporter of dup #16070.

comment:14 Changed 12 years ago by blb@…

Cc: mail@… added

Cc reporter for dup #16078.

comment:15 Changed 12 years ago by j.bugzilla2@…

Cc: j.bugzilla2@… added

Cc Me!

comment:16 Changed 12 years ago by blb@…

Cc: jochen@… added

Cc reporter of dup #16095.

comment:17 Changed 12 years ago by mf2k (Frank Schima)

Cc: macsforever2000@… added

Cc Me!

comment:18 Changed 12 years ago by skymoo (Adam Mercer)

Cc: ram@… added

Cc Me!

comment:19 Changed 12 years ago by js-macports@…

Cc: js-macports@… added

Cc Me!

comment:20 Changed 12 years ago by mf2k (Frank Schima)

Port: macfuse added

Has dup of #16460.

comment:21 Changed 12 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

10.5.5 appears to have fixed this.

comment:22 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.