Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#15922 closed defect (fixed)

desktop-file-utils build failure

Reported by: karoliina.t.salminen@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port: desktop-file-utils

Description

Gimp2 install (or any other gtk-app) in Leopard fails. I installed Macports to my leopard from macports page and followed the instructions for selfupdate etc. However, when I try to install gimp2, the install always fails:

install gimp2 results the followings problem:

--->  Building desktop-file-utils with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_desktop-file-utils/work/desktop-file-utils-0.15" && make all " returned error 2
Command output: /usr/bin/gcc-4.0 -O2 -no-cpp-precomp -flat_namespace -undefined suppress -Wall -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wcast-align -Wsign-compare -o desktop-file-validate keyfileutils.o validate.o validator.o  -L/opt/local/lib /opt/local/lib/libglib-2.0.dylib /opt/local/lib/libintl.dylib -lc /opt/local/lib/libiconv.dylib
if /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I.. -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include   -DDATADIR="\"/opt/local/share\"" -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE  -I/opt/local/include -L/opt/local/lib  -O2 -no-cpp-precomp -flat_namespace -undefined suppress -Wall -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wcast-align -Wsign-compare -MT install.o -MD -MP -MF ".deps/install.Tpo" \
	  -c -o install.o `test -f 'install.c' || echo './'`install.c; \
	then mv -f ".deps/install.Tpo" ".deps/install.Po"; \
	else rm -f ".deps/install.Tpo"; exit 1; \
	fi
/bin/sh ../libtool --mode=link /usr/bin/gcc-4.0  -O2 -no-cpp-precomp -flat_namespace -undefined suppress -Wall -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wcast-align -Wsign-compare  -L/opt/local/lib -o desktop-file-install  keyfileutils.o validate.o install.o -L/opt/local/lib -lglib-2.0 -lintl -liconv   
/usr/bin/gcc-4.0 -O2 -no-cpp-precomp -flat_namespace -undefined suppress -Wall -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wcast-align -Wsign-compare -o desktop-file-install keyfileutils.o validate.o install.o  -L/opt/local/lib /opt/local/lib/libglib-2.0.dylib /opt/local/lib/libintl.dylib -lc /opt/local/lib/libiconv.dylib
if /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I.. -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include   -DDATADIR="\"/opt/local/share\"" -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE  -I/opt/local/include -L/opt/local/lib  -O2 -no-cpp-precomp -flat_namespace -undefined suppress -Wall -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wcast-align -Wsign-compare -MT update-desktop-database.o -MD -MP -MF ".deps/update-desktop-database.Tpo" \
	  -c -o update-desktop-database.o `test -f 'update-desktop-database.c' || echo './'`update-desktop-database.c; \
	then mv -f ".deps/update-desktop-database.Tpo" ".deps/update-desktop-database.Po"; \
	else rm -f ".deps/update-desktop-database.Tpo"; exit 1; \
	fi
/bin/sh ../libtool --mode=link /usr/bin/gcc-4.0  -O2 -no-cpp-precomp -flat_namespace -undefined suppress -Wall -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wcast-align -Wsign-compare  -L/opt/local/lib -o update-desktop-database  update-desktop-database.o -L/opt/local/lib -lglib-2.0 -lintl -liconv   
/usr/bin/gcc-4.0 -O2 -no-cpp-precomp -flat_namespace -undefined suppress -Wall -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wcast-align -Wsign-compare -o update-desktop-database update-desktop-database.o  -L/opt/local/lib /opt/local/lib/libglib-2.0.dylib /opt/local/lib/libintl.dylib -lc /opt/local/lib/libiconv.dylib
Making all in misc
WARNING: Warnings can be ignored. :-)
if test emacs != no; then \
	  set x; \
	  list='desktop-entry-mode.el'; for p in $list; do \
            if test -f "$p"; then d=; else d="./"; fi; \
	    set x "$@" "$d$p"; shift; \
	  done; \
	  shift; \
	  EMACS=emacs /bin/sh ../elisp-comp "$@" || exit 1; \
	else : ; fi
mv: rename *.elc to ../*.elc: No such file or directory
make[2]: *** [elc-stamp] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: The following dependencies failed to build: libgnomeui libbonoboui gnome-vfs desktop-file-utils gnome-mime-data openssl libbonobo libglade2 libgnome esound audiofile libgnomecanvas gail libgtkhtml libmng autoconf help2man p5-locale-gettext m4 automake lcms libtool librsvg libcroco libgsf libwmf poppler poppler-data py25-gtk py25-cairo py25-numpy fftw-3 py25-hashlib python25 py25-gobject libxslt
Error: Status 1 encountered during processing.

Change History (7)

comment:1 Changed 13 years ago by karoliina.t.salminen@…

Cc: karoliina.t.salminen@… added

Cc Me!

comment:2 Changed 13 years ago by jmroot (Joshua Root)

Cc: karoliina.t.salminen@… removed
Milestone: Port Bugs
Summary: graphics/gimp2 2.4.5 build failuredesktop-file-utils build failure

comment:3 Changed 13 years ago by raimue (Rainer Müller)

Can't reproduce, build works fine for me on Mac OS X 10.5.4 Leopard.

comment:4 Changed 13 years ago by macosforge.lbn@…

I started with a system upgraded from 10.4.11 to 10.5.4 (then updated to 10.5.5). Prior to upgrade, I completely uninstall MacPorts. After the upgrade, I reinstalled MacPorts and then issued 'sudo port -dk install gnome-desktop +quartz +no_x11' and hit this error.

It would appear to be a missing dependency of some sort... Emacs??

comment:5 in reply to:  4 Changed 13 years ago by macosforge.lbn@…

Replying to macosforge.lbn@…:

I started with a system upgraded from 10.4.11 to 10.5.4 (then updated to 10.5.5). Prior to upgrade, I completely uninstall MacPorts. After the upgrade, I reinstalled MacPorts and then issued 'sudo port -dk install gnome-desktop +quartz +no_x11' and hit this error.

It would appear to be a missing dependency of some sort... Emacs??

Issuing this command fixed the error 'sudo port -dk install emacs +quartz +no_x11'. It appears somewhere emacs is an undeclared (but required) dependency for at least building (running too??).

comment:6 Changed 13 years ago by blb@…

Port: desktop-file-utils added
Resolution: fixed
Status: newclosed

This should be fixed with r40951, borrowing from how FreeBSD handled it.

comment:7 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.