Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#15964 closed defect (worksforme)

file 4.2.5 fails to fetch

Reported by: mf2k (Frank Schima) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: simon@…
Port:

Description

When i run the following:

sudo port -d upgrade file

I see the following error:

--->  Attempting to fetch file-4.25.tar.gz from ftp://ftp.astron.com/pub/file/
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 58222  100 58222    0     0  39980      0  0:00:01  0:00:01 --:--:--  145k
DEBUG: Fetching failed:: Transferred a partial file

But if I manually download the file, it works fine.

I'm not sure where the problem lies, the Portfile seems correct on this.

Change History (5)

comment:1 Changed 12 years ago by simon@…

Cc: simon@… added

I just tested it and it works fine for me. I'm running macports trunk; maybe there was a fix committed. But maybe it was only a temporary problem.

comment:2 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

Works for me too.

comment:3 Changed 12 years ago by mf2k (Frank Schima)

I'm running 1.6 at work. Because I'm using a custom tcl install, I apparently cannot install the trunk version of macports until I install the threads version of tcl. I still cannot install file. It's the strange partial file issue that is the problem. I have run clean on the port and tried again to no avail.

comment:4 Changed 12 years ago by mf2k (Frank Schima)

For the record. When I installed the trunk version of MacPorts, I was able to fetch and install file.

comment:5 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.