Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#15976 closed defect (worksforme)

py-matplotlib 0.98.2 stalls during build

Reported by: cvanweelden@… Owned by: skymoo (Adam Mercer)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: py-matplotlib Cc:
Port:

Description

py-matplotlib fails to build with MacPorts 1.600 under Mac OS X 10.5.4 and Xcode 3.0 on an intel MacBook.

The install seems to go well and the build is started and returns no errors, but it doesn't finish (at least not within 8hrs). During build 0% cpu resource is used and the build seems to just stall.

DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py-matplotlib
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py-matplotlib
DEBUG: Requested variant darwin is not provided by port py-matplotlib.
DEBUG: Requested variant i386 is not provided by port py-matplotlib.
DEBUG: Requested variant macosx is not provided by port py-matplotlib.
DEBUG: Executing variant tkinter provides tkinter
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/lang/python24
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/lang/python24
DEBUG: Requested variant darwin is not provided by port python24.
DEBUG: Requested variant i386 is not provided by port python24.
DEBUG: Requested variant macosx is not provided by port python24.
DEBUG: Executing variant darwin_9 provides darwin_9
DEBUG: Searching for dependency: python24
DEBUG: Found Dependency: receipt exists for python24
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/print/freetype
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/print/freetype
DEBUG: Requested variant darwin is not provided by port freetype.
DEBUG: Requested variant i386 is not provided by port freetype.
DEBUG: Requested variant macosx is not provided by port freetype.
DEBUG: Searching for dependency: freetype
DEBUG: Found Dependency: receipt exists for freetype
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/graphics/libpng
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/graphics/libpng
DEBUG: Requested variant darwin is not provided by port libpng.
DEBUG: Requested variant i386 is not provided by port libpng.
DEBUG: Requested variant macosx is not provided by port libpng.
DEBUG: Searching for dependency: libpng
DEBUG: Found Dependency: receipt exists for libpng
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py-dateutil
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py-dateutil
DEBUG: Requested variant darwin is not provided by port py-dateutil.
DEBUG: Requested variant i386 is not provided by port py-dateutil.
DEBUG: Requested variant macosx is not provided by port py-dateutil.
DEBUG: Searching for dependency: py-dateutil
DEBUG: Found Dependency: receipt exists for py-dateutil
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py-tz
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py-tz
DEBUG: Requested variant darwin is not provided by port py-tz.
DEBUG: Requested variant i386 is not provided by port py-tz.
DEBUG: Requested variant macosx is not provided by port py-tz.
DEBUG: Searching for dependency: py-tz
DEBUG: Found Dependency: receipt exists for py-tz
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py-numpy
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py-numpy
DEBUG: Requested variant darwin is not provided by port py-numpy.
DEBUG: Requested variant i386 is not provided by port py-numpy.
DEBUG: Requested variant macosx is not provided by port py-numpy.
DEBUG: Searching for dependency: py-numpy
DEBUG: Found Dependency: receipt exists for py-numpy
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py-tkinter
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py-tkinter
DEBUG: Requested variant darwin is not provided by port py-tkinter.
DEBUG: Requested variant i386 is not provided by port py-tkinter.
DEBUG: Requested variant macosx is not provided by port py-tkinter.
DEBUG: Searching for dependency: py-tkinter
DEBUG: Found Dependency: receipt exists for py-tkinter
DEBUG: Executing org.macports.main (py-matplotlib)
--->  Fetching py-matplotlib
DEBUG: Executing org.macports.fetch (py-matplotlib)
--->  Verifying checksum(s) for py-matplotlib
DEBUG: Executing org.macports.checksum (py-matplotlib)
--->  Checksumming matplotlib-0.98.2.tar.gz
DEBUG: Correct (md5) checksum for matplotlib-0.98.2.tar.gz
DEBUG: Correct (sha1) checksum for matplotlib-0.98.2.tar.gz
DEBUG: Correct (rmd160) checksum for matplotlib-0.98.2.tar.gz
--->  Extracting py-matplotlib
DEBUG: Executing org.macports.extract (py-matplotlib)
--->  Extracting matplotlib-0.98.2.tar.gz
DEBUG: setting option extract.args to /opt/local/var/macports/distfiles/python/matplotlib-0.98.2.tar.gz
DEBUG: Environment: 
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-matplotlib/work" && gzip -dc /opt/local/var/macports/distfiles/python/matplotlib-0.98.2.tar.gz | /usr/bin/gnutar --no-same-owner -xf -'
DEBUG: Executing proc-post-org.macports.extract-extract-0
DEBUG: Executing org.macports.patch (py-matplotlib)
--->  Applying patches to py-matplotlib
--->  Applying /opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py-matplotlib/files/patch-setupext.py.diff
DEBUG: Environment: 
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-matplotlib/work/matplotlib-0.98.2" && patch -p0'
patching file setupext.py
Hunk #2 succeeded at 325 (offset -2 lines).
Hunk #3 succeeded at 993 (offset 11 lines).
Hunk #4 succeeded at 1014 (offset 11 lines).
DEBUG: Executing proc-post-org.macports.patch-patch-0
--->  Configuring py-matplotlib
DEBUG: Executing org.macports.configure (py-matplotlib)
DEBUG: Using compiler 'Mac OS X gcc 4.0'
--->  Building py-matplotlib with target build
DEBUG: Executing org.macports.build (py-matplotlib)
DEBUG: Environment: CFLAGS='-Os' MPLIB_BASE='/opt/local'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-matplotlib/work/matplotlib-0.98.2" && /opt/local/bin/python2.4 setup.py build'

Change History (10)

comment:1 Changed 12 years ago by skymoo (Adam Mercer)

Owner: changed from macports-tickets@… to ram@…
Status: newassigned

Is that the complete output of "sudo port -d install py-matplotlib"?

comment:2 Changed 12 years ago by skymoo (Adam Mercer)

Also I'd recommend using py25-matplotlib instead as I've had some strange problems with python24 ports on Leopard.

comment:3 Changed 12 years ago by cvanweelden@…

Yes, that's the complete output. Then it has spawned a python process, but it doesn't seem to do anything at all.

comment:4 Changed 12 years ago by cvanweelden@…

Interestingly enough, py25-matplotlib seems to exhibit the same behaviour, although I've not let it run for as long yet. It just seems stalled, with about the same debug info as above. Very strange. Is this even reproducible?

comment:5 Changed 12 years ago by skymoo (Adam Mercer)

Its not reproducible for me, and this is the first report of this problem I've had.

comment:6 Changed 12 years ago by cvanweelden@…

Ah, it has something to do with the version of x11 that leopard comes with. Updating Xquartz to the latest version on http://xquartz.macosforge.org/ resolves the problem. So it's probably not a bug with the port at all :)

comment:7 Changed 12 years ago by skymoo (Adam Mercer)

Resolution: worksforme
Status: assignedclosed

Great glad its working for you now, although it is strange that updating Xquartz makes the problem go away

comment:8 Changed 12 years ago by cvanweelden@…

Well, while building py25-matplotlib it starts x11 (not sure why) and before the update a lot of other applications also had the problem that they couldn't start x11. So my guess is that it was just waiting for x11 to start and that caused it to stall.

comment:9 Changed 12 years ago by skymoo (Adam Mercer)

It needs to start X so that it can determine the location and version of Tcl/Tk as the MacPorts Tcl/Tk is not a framework build.

comment:10 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.