Opened 12 years ago

Closed 12 years ago

#15977 closed defect (duplicate)

py25-hashlib 2.5.2_0 - does not build once

Reported by: pub1@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port:

Description

Dear Porters

While installing a dependency of gimp, I discovered the following problem: When py25-hashlib is built for the first time, it fails with an error message

unable to execute -DNDEBUG: No such file or directory

When the port install is run for the second time, it works... It seems that others experience the same problem too http://mac-guy-ver.blogspot.com/2008/05/mac-ports-troubleshooting-error-command.html

Thanks a lot for your work!

# first attempt

bash-3.2# port install gimp-app
--->  Fetching python25
--->  Verifying checksum(s) for python25
--->  Extracting python25
--->  Applying patches to python25
--->  Configuring python25
--->  Building python25 with target all libpython2.5.dylib
--->  Staging python25 into destroot
--->  Installing python25 2.5.2_5+darwin_9
--->  Activating python25 2.5.2_5+darwin_9

To fully complete your installation and make python 2.5 the default, please run

	sudo port install python_select  
	sudo python_select python25

--->  Cleaning python25
--->  Building py25-hashlib with target build
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py25-hashlib/work/Python-2.5.2/Modules" && /opt/local/bin/python2.5 setup.py build " returned error 1
Command output: running build
running build_ext
building '_hashlib' extension
-DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I/opt/local/include -I/opt/local/Library/Frameworks/Python.framework/Versions/2.5/include/python2.5 -c _hashopenssl.c -o build/temp.macosx-10.3-i386-2.5/_hashopenssl.o
unable to execute -DNDEBUG: No such file or directory
error: command '-DNDEBUG' failed with exit status 1

Error: The following dependencies failed to build: gimp2 py25-gtk py25-cairo py25-numpy py25-hashlib py25-gobject libxslt
Error: Status 1 encountered during processing.


# second attempt

bash-3.2# port install gimp-app
--->  Building py25-hashlib with target build
--->  Staging py25-hashlib into destroot
--->  Installing py25-hashlib 2.5.2_0
--->  Activating py25-hashlib 2.5.2_0
--->  Cleaning py25-hashlib
--->  Fetching py25-numpy
--->  Attempting to fetch numpy-1.1.0.tar.gz from http://downloads.sourceforge.net/numpy
--->  Verifying checksum(s) for py25-numpy

# snip

Change History (1)

comment:1 Changed 12 years ago by skymoo (Adam Mercer)

Resolution: duplicate
Status: newclosed

duplicate of #13930

Note: See TracTickets for help on using tickets.