Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#15980 closed defect (duplicate)

apache2 @2.2.9_1 extra/* configuration files are overwritten when upgrading

Reported by: yann+macports@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: apache2 Cc:
Port:

Description

After upgrading from apache2 @2.2.4_1 to @2.2.9_1, I realized in horror that my httpd-vhosts.conf file had been erased and replaced by the default one.

Note that the main httpd.conf was preserved. But ALL files in /opt/local/apache2/conf/extra/ were replaced without warning. At the minimum, I would suggest making a backup of the user's conf files before replacing them. Or deliver the default files as httpd-xxxx.conf.sample, like what is done for the httpd.conf file.

I was out of the office, and therefore far from my backup, so I had to rebuild my complicated vhosts. Very painful...

Note: During the upgrade, I had to make a "port clean apache2" to have a successful compilation. Maybe it is related to the problem? Note: MacPort 1.600, Mac OS X 10.5.4

Change History (2)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #8605.

comment:2 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.