Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#16001 closed defect (duplicate)

frozenbubble2 doesn't build on OS-X 10.5.4

Reported by: brunogirin@… Owned by: pmq@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port:

Description

Tried to install frozenbubble2 from a fresh MacPorts install on Leopard on a PowerMac G5. All dependent libraries build and install fine, the problem arises when building the frozenbubble2 package itself:

--->  Fetching frozenbubble2
--->  Attempting to fetch frozen-bubble-2.1.0.tar.bz2 from http://www.frozen-bubble.org/data
--->  Verifying checksum(s) for frozenbubble2
--->  Extracting frozenbubble2
--->  Applying patches to frozenbubble2
--->  Configuring frozenbubble2
--->  Building frozenbubble2 with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_games_frozenbubble2/work/frozen-bubble-2.1.0" && make all PREFIX=/opt/local " returned error 2
Command output: msgfmt pl.po -o pl.mo
msgfmt pt.po -o pt.mo
msgfmt pt_BR.po -o pt_BR.mo
msgfmt ro.po -o ro.mo
msgfmt ru.po -o ru.mo
msgfmt sk.po -o sk.mo
msgfmt sl.po -o sl.mo
msgfmt sv.po -o sv.mo
I. `pkg-config glib-2.0 --cflags` -DVERSION=\"2.1.0\" -M fb-server.c log.c tools.c game.c net.c > .depend
/bin/sh: I.: command not found
make[1]: [.depend] Error 127 (ignored)
I. `pkg-config glib-2.0 --cflags` -DVERSION=\"2.1.0\"  -c -o fb-server.o fb-server.c
/bin/sh: I.: command not found
make[1]: [fb-server.o] Error 127 (ignored)
I. `pkg-config glib-2.0 --cflags` -DVERSION=\"2.1.0\"  -c -o log.o log.c
/bin/sh: I.: command not found
make[1]: [log.o] Error 127 (ignored)
I. `pkg-config glib-2.0 --cflags` -DVERSION=\"2.1.0\"  -c -o tools.o tools.c
/bin/sh: I.: command not found
make[1]: [tools.o] Error 127 (ignored)
I. `pkg-config glib-2.0 --cflags` -DVERSION=\"2.1.0\"  -c -o game.o game.c
/bin/sh: I.: command not found
make[1]: [game.o] Error 127 (ignored)
I. `pkg-config glib-2.0 --cflags` -DVERSION=\"2.1.0\"  -c -o net.o net.c
/bin/sh: I.: command not found
make[1]: [net.o] Error 127 (ignored)
fb-server.o log.o tools.o game.o net.o  `pkg-config glib-2.0 --libs` -o fb-server
/bin/sh: fb-server.o: command not found
make[1]: *** [fb-server] Error 127
make: *** [dirs] Error 2

Error: Status 1 encountered during processing.

Change History (8)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Milestone: Port Bugs
Owner: changed from macports-tickets@… to pmq@…

Assigning to maintainer.

comment:2 Changed 12 years ago by pmq@…

Could you try cleaning and rebuilding?

comment:3 Changed 12 years ago by brunogirin@…

It's all working now! Thanks!

comment:4 Changed 12 years ago by pmq@…

Resolution: invalid
Status: newclosed

comment:5 Changed 12 years ago by garfieldrules@…

Resolution: invalid
Status: closedreopened

I wouldn't say that this bug is invalid. When building FrozenBubble 2 on Leopard I had the same problem. As instructed to Bruno, I had to clean the build before it would work.

comment:6 Changed 12 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: reopenedclosed

OK then, duplicate of #13930. (See LeopardProblems.)

comment:7 in reply to:  5 Changed 12 years ago by pmq@…

Replying to garfieldrules@sbcglobal.net:

I wouldn't say that this bug is invalid. When building FrozenBubble 2 on Leopard I had the same problem. As instructed to Bruno, I had to clean the build before it would work.

I understand that you have a patch for that Leopard issue?

comment:8 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.