Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#16016 closed defect (invalid)

Concern ddd programm

Reported by: alexandre.grivel@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: ryandesign (Ryan Schmidt), febeling@…
Port: ddd

Description (last modified by jmroot (Joshua Root))

I try to compile ddd programm on my MacBook under 10.5.4, fresh install.

ddd programm in first he freez on ----> Configuring ddd, I think this because, I need kill process for this time.

I launch ddd whit sudo after many time he say :

Internal error (Bus error).

Oops!  You have found a bug in DDD.

If you can reproduce this bug, please send a bug report
to <ddd@gnu.org>, giving a subject like

    DDD 3.3.11 (i686-apple-darwin9.4.0) gets `Bus error' signal

To enable us to fix the bug, you should include the following information:
* What you were doing to get this message.  Report all the facts.
* The contents of the `~/.ddd/log' file as generated by this session.
Please read also the section "Reporting Bugs" in the DDD manual.

We thank you for your support.

But i test on other MacBook with 10.6 BETA the programm compile without problem.

I attach log file

Best regard for the crew

Change History (8)

comment:1 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

If you meant to attach a logfile here, you don't appear to have done so.

I too get a crash when trying to run ddd from the normal Terminal in Mac OS X 10.5.4 on a MacBook Pro with Xcode 3.1.

But it works fine if I launch it from an X11 terminal. So that appears to be what you need to do. Open /Applications/Utilities/X11.app and open ddd from within that terminal window, not the terminal window you get by opening /Applications/Utilities/Terminal.app.

comment:2 Changed 13 years ago by ryandesign (Ryan Schmidt)

Keywords: ticketformatting added
Resolution: invalid
Status: newclosed

comment:3 Changed 12 years ago by jmroot (Joshua Root)

Description: modified (diff)
Keywords: ticketformatting removed

comment:4 Changed 12 years ago by febeling@…

I get this same error. Are you sure this is invalid?

comment:5 Changed 12 years ago by febeling@…

Cc: febeling@… added

Cc Me!

comment:6 Changed 12 years ago by febeling@…

I also meant to say that I did launch from X11 terminal window, but still get the bus error.

comment:7 in reply to:  4 Changed 12 years ago by ryandesign (Ryan Schmidt)

Port: ddd added

Replying to febeling@…:

I get this same error. Are you sure this is invalid?

No I'm not sure, but the message says:

If you can reproduce this bug, please send a bug report to <ddd@…>,

so that is what I recommend you do, especially since the ddd port has no maintainer who would otherwise possibly be able to do this for you.

comment:8 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.