Opened 13 years ago

Closed 8 years ago

#16036 closed defect (worksforme)

php5: Memory error when using SoapClient

Reported by: contact@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: contact@…, jyrkiwahlstedt
Port: php5

Description

Hello,

I have been using the Entropy PHP package on my aluminum iMac running Leopard 10.5.4, but I wanted to try the MacPorts install to see if I could get ZendDebugger to work. I installed PHP as 'php5 @5.2.6_1+apache2+ipc+macosx+mysql5+pcntl+pear+pspell+readline+sockets+t1lib+tidy' and was indeed able to get ZendDebugger to work, however I've found that all points in my application that use SoapClient will error out with the message "PHP Fatal error: Possible integer overflow in memory allocation (3819152326 * 4 + 0)".

My memory limit is set to 256M in PHP.ini, up from 128M default.. tried raising it even to 512M but this has no effect. But again, never seen this happen in either my Entropy dev environment or on our QA and production servers.

I've googled for 'PHP SOAP "integer overflow"' and found no clues..

So I guess I will be going back to the Entropy package with no ZendDebugger for now..

Here's the output of port installed, maybe something in here will key some knowledgeable eyes to my problem:

The following ports are currently installed:

  apache2 @2.2.9_1+darwin_9 (active)
  apr @1.2.12_1+darwin_9
  apr @1.3.2_0+darwin_9 (active)
  apr-util @1.2.12_0
  apr-util @1.3.2_0 (active)
  aspell @0.60.6_1+macosx (active)
  autoconf @2.62_0 (active)
  automake @1.10.1_0 (active)
  bzip2 @1.0.5_0
  bzip2 @1.0.5_1 (active)
  curl @7.18.1_1
  curl @7.18.2_0 (active)
  cyrus-sasl2 @2.1.21_0+kerberos (active)
  db44 @4.4.20_1 (active)
  db46 @4.6.21_1 (active)
  expat @2.0.1_0 (active)
  fontconfig @2.5.0_0+macosx
  fontconfig @2.6.0_0+macosx (active)
  freetype @2.3.5_1
  freetype @2.3.7_1 (active)
  gawk @3.1.6_0 (active)
  gd2 @2.0.35_0
  gd2 @2.0.35_1 (active)
  gettext @0.17_3 (active)
  gmake @3.81_0 (active)
  gperf @3.0.3_0 (active)
  help2man @1.36.4_1 (active)
  jpeg @6b_2 (active)
  libiconv @1.12_0 (active)
  libmcrypt @2.5.8_0 (active)
  libpng @1.2.24_0
  libpng @1.2.29_0 (active)
  libtool @1.5.24_2
  libtool @1.5.26_0 (active)
  libxml @1.8.17_0 (active)
  libxml2 @2.6.31_0
  libxml2 @2.6.32_1 (active)
  libxslt @1.1.22_0
  libxslt @1.1.23_0 (active)
  m4 @1.4.11_0 (active)
  mhash @0.9.9_0 (active)
  mysql5 @5.0.51a_0+server (active)
  ncurses @5.6_0 (active)
  ncursesw @5.6_1 (active)
  neon @0.26.4_1 (active)
  openssl @0.9.8g_0
  openssl @0.9.8h_0 (active)
  p5-locale-gettext @1.05_0 (active)
  pcre @7.6_0
  pcre @7.7_0 (active)
  perl5.8 @5.8.8_3+darwin_9 (active)
  php5 @5.2.6_1+apache2+ipc+macosx+mysql5+pcntl+pear+pspell+readline+sockets+t1lib+tidy (active)
  pkgconfig @0.23_0 (active)
  readline @5.2.007_0+darwin_9
  readline @5.2.012_1 (active)
  serf @0.2.0_0 (active)
  sqlite3 @3.5.8_0 (active)
  subversion @1.5.0_1 (active)
  t1lib @5.1.1_0 (active)
  texinfo @4.11_0 (active)
  tidy @20051026_0 (active)
  tiff @3.8.2_1+macosx
  tiff @3.8.2_2+darwin_9+macosx (active)
  unrar @3.7.8_0 (active)
  zlib @1.2.3_1 (active)

Thanks all. it's always somethin' isn't it?

Change History (8)

comment:1 Changed 13 years ago by contact@…

Cc: contact@… added

Cc Me!

comment:2 Changed 13 years ago by blb@…

Cc: jwa@… added
Owner: changed from macports-tickets@… to ryandesign@…

Assign/Cc to maintainers.

comment:3 Changed 13 years ago by ryandesign (Ryan Schmidt)

Summary: Memory error when using SoapClient with PHP 5.2.6php5: Memory error when using SoapClient

If "3819152326 * 4 + 0" is a number of bytes of memory that it is trying to allocate, then that's 14.2GB of memory. That's a lot.

I don't have any ideas for how to deal with this problem. You might have to file a bug with the PHP developers or SoapClient (if it is separate from PHP).

Can you provide sample code that causes the problem? I don't know SoapClient.

comment:4 Changed 13 years ago by contact@…

I dug through the bug reports at PHP.net for anything like this and found nothing, so I submitted this one: http://bugs.php.net/45577.

But this strikes me as a pretty big bug for there not to be buzz about it on Google, or a bug ticket on PHP.net.. Hence why I posted this bug here.

I was able to determine that it was using "https" that seemed to be killing the SoapClient invokation. Trying a public http SOAP server worked fine.

Switching back to my Entropy.ch build of PHP 5.2.5 restored functionality..

comment:5 Changed 13 years ago by ryandesign (Ryan Schmidt)

I can't reproduce the problem using php5 @5.2.6_1+apache2+ipc+macosx+mysql5+pcntl+pear+pspell+readline+sockets+t1lib+tidy on either Mac OS X 10.4.11 with Xcode 2.5 or Mac OS X 10.5.4 with Xcode 3.0 (both on Intel). My php.ini is absent, meaning php is using its built-in defaults. Do you still see the problem if you remove your php.ini? Are you on Intel or PowerPC?

comment:6 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:7 Changed 11 years ago by jmroot (Joshua Root)

Keywords: php php5 soap removed
Port: php5 added

comment:8 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

I'm going to close this, since it was reported years ago against php 5.2 which is by now several versions out of date; since I was never able to reproduce it; and since the problem described sounds like it is (or was) a bug in PHP, and not a bug in the way MacPorts installs PHP.

Note: See TracTickets for help on using tickets.