Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#16086 closed defect (fixed)

silc-client: gcc-4.0: -E, -S, -save-temps and -M options are not allowed with multiple -arch flags

Reported by: jharres@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: ryandesign (Ryan Schmidt)
Port:

Description

---> Building silc-client with target all Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_irc_silc-client/work/silc-client-1.1.4" && make all " returned error 2 Command output: mv -f .deps/fe-silc-messages.Tpo .deps/fe-silc-messages.Plo /bin/sh ../../../libtool --tag=CC --mode=compile /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I../../.. -I/opt/local/include/glib-1.2 -I/opt/local/lib/glib/include -DSYSCONFDIR=\""/opt/local/etc"\" -I../../.. -I../../../src -I../../../src/core -I../../../src/fe-common/core -I../../../src/silc -I../../../src/silc/core -I/includes -I/lib/silccore -I/lib/silccrypt -I/lib/silcmath -I/lib/silcske -I/lib/silcsim -I/lib/silcutil -I/lib/silcapputil -I/lib/silcvcard -I/lib/silcskr -I/lib/s ...

all -MT perl-core.lo -MD -MP -MF .deps/perl-core.Tpo -c perl-core.c -fno-common -DPIC -o .libs/perl-core.o gcc-4.0: -E, -S, -save-temps and -M options are not allowed with multiple -arch flags make[6]: * [perl-core.lo] Error 1 make[5]: * [all-recursive] Error 1 make[4]: * [all-recursive] Error 1 make[3]: * [all] Error 2 make[2]: * [all-recursive] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

Error: Status 1 encountered during processing.

Attachments (2)

silc-install.err (7.1 KB) - added by jharres@… 13 years ago.
full log of error
silc-client.txt (899.8 KB) - added by jharres@… 13 years ago.

Download all attachments as: .zip

Change History (10)

Changed 13 years ago by jharres@…

Attachment: silc-install.err added

full log of error

comment:1 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Milestone: Port Bugs

Please remember WikiFormatting when pasting output.

Are you trying to build silc-client with the +universal variant? Are your ports up to date? What version of Mac OS X and Xcode are you using? This sounds like a duplicate of #14314 which was fixed by disabling silc-client's universal variant so you should not be experiencing this issue anymore.

comment:2 in reply to:  1 Changed 13 years ago by jharres@…

Replying to ryandesign@macports.org:

Please remember WikiFormatting when pasting output.

Are you trying to build silc-client with the +universal variant? Are your ports up to date? What version of Mac OS X and Xcode are you using? This sounds like a duplicate of #14314 which was fixed by disabling silc-client's universal variant so you should not be experiencing this issue anymore.

First off, I'm new on the Mac, so sorry for anything I may not be answering right ;)

I just installed the macports stuff for the first time that night. I saw the older bug, but since it's fixed, and I'm running the latest, I figured I shouldn't run into it. I'm not sure what "+universal" means, so there's nothing odd I've done to re-enable such.

This is OSX 10.5.4 and I downloaded the latest Xcode 3.1 that night as well, which was the first XCode install here.

Is there a way to disable this on the build directly here?

comment:3 Changed 13 years ago by ryandesign (Ryan Schmidt)

Welcome to Macintosh! :) Let's see if we can figure out why this isn't working.

+universal is a variant you can select on many ports which builds the port for both PowerPC and Intel (instead of for only PowerPC or Intel depending on which kind of Mac you have, which is the default). Most users don't need the +universal variant because they only use MacPorts on either a PowerPC or Intel Mac (as opposed to on both a PowerPC and an Intel Mac). More information on MacPorts universal support is in the FAQ.

You can learn about a port's variants by typing "port variants foo" (e.g. "port variants silc-client" should show "silc-client has no variants" but other ports may have variants you might be interested in). More info on variants is in the Guide.

Please try updating your ports with "sudo port -d sync" and if that succeeds then try "sudo port clean --work silc-client" followed by "sudo port -d install silc-client 2>&1 | tee ~/Desktop/silc-client.txt" If it fails, please attach the file silc-client.txt from your Desktop to this ticket which will hopefully contain more information to help us solve this.

comment:4 Changed 13 years ago by ryandesign (Ryan Schmidt)

Summary: silc-client install probsilc-client: gcc-4.0: -E, -S, -save-temps and -M options are not allowed with multiple -arch flags

Changed 13 years ago by jharres@…

Attachment: silc-client.txt added

comment:5 Changed 13 years ago by jharres@…

I added the requested information as the suggestions didn't change the results.

comment:6 Changed 13 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Fixed in r38933. The problem appears to have been that on Leopard, the perl provided by Mac OS X is universal, and so the silc-client compilation process somehow inherits the "-arch i386 -arch ppc" flags from there. This problem was not present on earlier versions of Mac OS X. The problem also doesn't exist on any platform when using the MacPorts perl, so that's how I fixed it (always require MacPorts perl). Thanks for reporting the problem and for bearing with me through to the solution. If you wait 30 minutes, then "sudo port sync" and "sudo port clean --work silc-client" you should then be able to install silc-client.

comment:7 Changed 13 years ago by ryandesign (Ryan Schmidt)

Requiring MacPorts perl is also better because then it uses the library path ${prefix}/lib/perl5/5.8.8/darwin-2level which is reasonable because that contains other perl stuff installed by other ports. Whereas when using Mac OS X's perl, it uses the library path ${prefix}/System/Library/Perl/5.8.8/darwin-thread-multi-2level which is rather preposterous. :)

comment:8 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.