Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#16160 closed defect (fixed)

sbcl_1.0.18_0 build fails

Reported by: ludwig@… Owned by: gwright@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: sbcl Cc: waqar@…
Port:

Description

Hi,

my attempt to upgrade the sbcl port to 1.0.18_0 on an Intel MacBook Pro, OS X 10.4.11, failed with some linker error:

dyld: lazy symbol binding failed: Symbol not found: _kill$UNIX2003

I will attach the full output of 'port -v upgrade sbcl' to this ticket.

If I simply try the same command again, without cleaning the port in between, I only get:

--->  Building sbcl with target all
make.sh: make.sh: No such file or directory
Error: Target org.macports.build returned: shell command "unset LD_PREBIND && unset LD_PREBIND_ALLOW_OVERLAP && sh make.sh "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_sbcl/work/sbcl-1.0.12-x86-darwin/src/runtime/sbcl --core /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_sbcl/work/sbcl-1.0.12-x86-darwin/output/sbcl.core --disable-debugger --sysinit /dev/null --userinit /dev/null" " returned error 127
Command output: make.sh: make.sh: No such file or directory

Regards

Christoph

Attachments (3)

sbcl_1.0.18_0_build-msgs.txt (5.5 KB) - added by ludwig@… 13 years ago.
Output of 'sudo port -v upgrade sbcl
Portfile (2.9 KB) - added by mail_ben_schmidt@… 13 years ago.
Suggested fix
Portfile.diff (1.0 KB) - added by mail_ben_schmidt@… 13 years ago.
Diff with the current Portfile

Download all attachments as: .zip

Change History (15)

Changed 13 years ago by ludwig@…

Output of 'sudo port -v upgrade sbcl

comment:1 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: waqar@… added; ludwig@… removed
Milestone: Port Bugs
Owner: changed from macports-tickets@… to gwright@…

Notifying port maintainers.

comment:2 Changed 13 years ago by ryandesign (Ryan Schmidt)

I can confirm both issues, also on 10.4.11 on Intel, with Xcode 2.5. sbcl 1.0.17_0 had no trouble installing.

comment:3 Changed 13 years ago by jwhowse4

I can also confirm both issues with 10.4.11 on Intel using Xcode 2.5. I also had no trouble with sbcl 1.0.17.

comment:4 Changed 13 years ago by blb@…

Looks like the src/runtime/sbcl binary in sbcl-1.0.12-x86-darwin-binary.tar.bz2 has been built on/for 10.5. 10.4 has some $UNIX2003-prefixed symbols, but looking at libSystem seems to show none for kill().

comment:5 in reply to:  4 ; Changed 13 years ago by jwhowse4

Replying to blb@macports.org:

Looks like the src/runtime/sbcl binary in sbcl-1.0.12-x86-darwin-binary.tar.bz2 has been built on/for 10.5. 10.4 has some $UNIX2003-prefixed symbols, but looking at libSystem seems to show none for kill().

I took the liberty of doing some hacking, and I found that with 10.4.11 running on Intel sbcl 1.0.19 (which is the latest) builds successfully with the bootversion set to 1.0.10.

comment:6 in reply to:  5 ; Changed 13 years ago by ludwig@…

The issue still persists with port sbcl@1.0.20_0.

Replying to jwhowse4@…:

I took the liberty of doing some hacking, and I found that with 10.4.11 running on Intel sbcl 1.0.19 (which is the latest) builds successfully with the bootversion set to 1.0.10.

Do you have a path for the port file that you could share? Or can you give more details what exactly you had to do? Thanks.

comment:7 in reply to:  6 Changed 13 years ago by ludwig@…

Replying to ludwig@…:

Do you have a path for the port file that you could share? Or can you give more details what exactly you had to do? Thanks.

Sorry, a typo - "path" should read "patch", of course.

comment:8 Changed 13 years ago by mail_ben_schmidt@…

I've attached the Portfile I used. I just changed the set bootversion line at the top to 1.0.10 and the md5 in the platform i386 section. What actually should be done is a new section added that changes the bootversion and sets the md5 if it detects Mac OS 10.4, like the ppc section does. But I don't know how to do that in a Portfile (I am fairly new to Macports).

comment:9 Changed 13 years ago by mail_ben_schmidt@…

OK. I've taken a little time to learn. I think I've made a Portfile that will work now. I'll attach it, and a diff and email the maintainers.

Changed 13 years ago by mail_ben_schmidt@…

Attachment: Portfile added

Suggested fix

Changed 13 years ago by mail_ben_schmidt@…

Attachment: Portfile.diff added

Diff with the current Portfile

comment:10 Changed 13 years ago by mail_ben_schmidt@…

One of the maintainers (gwright) has fixed this (slightly differently) in the Macports system. I tested it and it works for me. This ticket can probably be closed now.

comment:11 Changed 13 years ago by gwright@…

Resolution: fixed
Status: newclosed

Closing, since it looks like r39907 has fixed this.

comment:12 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.