Opened 12 years ago

Closed 10 years ago

#16238 closed submission (wontfix)

Port for MapServer

Reported by: mbarchfe@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: lack-of-interest Cc: ryandesign (Ryan Schmidt), mf2k (Frank Schima)
Port: mapserver grass gdal-grass

Description

Attached you find a Portfile for MapServer. I would suggest to categorize it and its dependencies as gis.

Attachments (9)

Portfile (1.1 KB) - added by mbarchfe@… 12 years ago.
Portfile for MapServer
Portfile.2 (1.2 KB) - added by mbarchfe@… 12 years ago.
tidied up version (except for category)
gis.tar.gz (2.3 KB) - added by mbarchfe@… 12 years ago.
Port for mapserver, grass and gdal grass plugin
patch-configure.diff (685 bytes) - added by mf2k (Frank Schima) 12 years ago.
patch-Makefile.diff (860 bytes) - added by mf2k (Frank Schima) 12 years ago.
Portfile.grass (3.2 KB) - added by mf2k (Frank Schima) 12 years ago.
grass.tar.bz2 (2.6 KB) - added by blb@… 12 years ago.
grass port
Portfile.2.grass (3.7 KB) - added by mf2k (Frank Schima) 12 years ago.
My latest version of the grass portfile based on blb's changes. Fixed variants. Fixed dependencies.
Portfile.gdal-grass (900 bytes) - added by mf2k (Frank Schima) 12 years ago.
I'm not able to get gdal-grass to install. Here's my modified version of the portfile. Any ideas would be appreciated!

Download all attachments as: .zip

Change History (25)

Changed 12 years ago by mbarchfe@…

Attachment: Portfile added

Portfile for MapServer

comment:1 Changed 12 years ago by blb@…

Milestone: Port Submissions

comment:2 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Thanks for the contribution!

port lint has the following suggestions about your Portfile:

$ port lint
--->  Verifying Portfile for mapserver
Warning: Line 2 should be a newline (after RCS tag)
Warning: Line 3 should be a newline (after PortSystem)
Warning: Line 21 has trailing whitespace before newline
Warning: Line 33 has trailing whitespace before newline
Warning: Line 35 has trailing whitespace before newline
Warning: Line 36 has trailing whitespace before newline
Warning: Line 37 has trailing whitespace before newline
Warning: Line 38 has trailing whitespace before newline
Warning: Line 40 has trailing whitespace before newline
Warning: Line 41 has trailing whitespace before newline
Warning: Line 42 has trailing whitespace before newline
Warning: Line 43 has trailing whitespace before newline
Error: Unknown category: gis
Warning: Variant gdalogr does not have a description
Warning: Variant proj does not have a description
Warning: Variant wms does not have a description

The whitespace notices aren't so important and will probably be removed from port lint anyway, but the others are relevant. Variants should have descriptions explaining their use, and we don't have a category "gis". Perhaps the port would fit into one of the existing categories.

Further comments from me:

  • You don't wish to be the maintainer of this port?
  • It looks like the variant "wms" doesn't do anything so it should be removed.
  • In the destroot phase you should use xinstall instead of system "install".
  • With regard to your comment on setting the cgi_path, this project is called MacPorts. It hasn't been called DarwinPorts in 16 months. :-)
  • extract.suffix .tar.gz is unnecessary; that's the default.

Changed 12 years ago by mbarchfe@…

Attachment: Portfile.2 added

tidied up version (except for category)

comment:3 in reply to:  2 Changed 12 years ago by mbarchfe@…

port lint has the following suggestions about your Portfile:

sorry, should have run that beforehand. Attached is a cleaned file.

The whitespace notices aren't so important and will probably be removed from port lint anyway, but the others are relevant. Variants should have descriptions explaining their use, and we don't have a category "gis". Perhaps the port would fit into one of the existing categories.

Where can I find out about valid categories? According to http://www.macports.org/ports.php ther is a gis category.

Further comments from me:

  • You don't wish to be the maintainer of this port?

Actually I hoped I could throw this over the fence and get away with it ;-). But if being the maintainer means I can directly submit changes to the Portfile that would be fine with me.

  • It looks like the variant "wms" doesn't do anything so it should be removed.

It adds a necessary dependency for wms. I wanted this category just to make it explicit.

  • In the destroot phase you should use xinstall instead of system "install".

Fixed.

  • With regard to your comment on setting the cgi_path, this project is called MacPorts. It hasn't been called DarwinPorts in 16 months. :-)

Sorry, I am new to Mac and this does not mean much to me.

  • extract.suffix .tar.gz is unnecessary; that's the default.

Removed.

Changed 12 years ago by mbarchfe@…

Attachment: gis.tar.gz added

Port for mapserver, grass and gdal grass plugin

comment:4 Changed 12 years ago by mbarchfe@…

The new attachment gis.tar.gz contains some improvements for mapserver plus ports for grass and the grass plugin for gdal. With these ports it is possible to develop with grass and directly access grass data from mapserver.

The mapserver port has got a patch for Makefile.in to support DESTROOT.

comment:5 Changed 12 years ago by mbarchfe@…

Sorry, I meant DESTDIR instead of DESTROOT.

comment:6 Changed 12 years ago by ryandesign (Ryan Schmidt)

Replying to mbarchfe@googlemail.com:

we don't have a category "gis". Perhaps the port would fit into one of the existing categories.

Where can I find out about valid categories? According to http://www.macports.org/ports.php ther is a gis category.

Oh, I see, indeed ports.php does show a gis category. I was going by "port lint" which said the category didn't exist. lint currently goes off a list that's in portlint.tcl, while I believe ports.php gathers all categories of all ports and displays them. Looks like only the spatialite port currently claims to be in category gis. Would the science category be appropriate? That's where ports like gdal, geos and proj are currently filed. Or if it would help people to find the software if the ports were in a category gis, we could officially add that category. Ports can be in multiple categories; e.g. you could file them in science and gis.

  • You don't wish to be the maintainer of this port?

Actually I hoped I could throw this over the fence and get away with it ;-). But if being the maintainer means I can directly submit changes to the Portfile that would be fine with me.

You don't need to be maintainer if you don't want to. :-) The problem is that ports with no mainatiner seem to bitrot as nobody feels responsible for them, and already 46% of our ports have no maintainer. By being a port's maintainer, you're saying that you will keep it updated and be a point of contact for users having questions about the MacPorts-specific aspects of the software. You would still need to file tickets to effect those updates, unless you want to request commit access to the repository.

  • It looks like the variant "wms" doesn't do anything so it should be removed.

It adds a necessary dependency for wms. I wanted this category just to make it explicit.

But the wms variant doesn't do anything. It only contains the comment "--with-wms is enabled by default". The description of the variant reads "Enable Web Map Service" but that's not what the variant does. Regardless of whether I install mapserver +proj or mapserver +proj +wms I get exactly the same software which has wms enabled. So the wms variant should go away. If there is value in allowing wms to be disabled, then you could add a variant no_wms which appends the configure argument --without-wms. Is there a reason why anyone would want to disable wms?

comment:7 in reply to:  6 Changed 12 years ago by mbarchfe@…

we don't have a category "gis". Perhaps the port would fit into one of the existing categories.

Where can I find out about valid categories? According to http://www.macports.org/ports.php ther is a gis category.

Oh, I see, indeed ports.php does show a gis category. I was going by "port lint" which said the category didn't exist. lint currently goes off a list that's in portlint.tcl, while I believe ports.php gathers all categories of all ports and displays them. Looks like only the spatialite port currently claims to be in category gis. Would the science category be appropriate? That's where ports like gdal, geos and proj are currently filed. Or if it would help people to find the software if the ports were in a category gis, we could officially add that category. Ports can be in multiple categories; e.g. you could file them in science and gis.

I think it would make sense to add the gis category. gdal/geos/proj/grass/mapserver/gdal-grass should probably be tagged for the science and gis category.

  • You don't wish to be the maintainer of this port?

Actually I hoped I could throw this over the fence and get away with it ;-). But if being the maintainer means I can directly submit changes to the Portfile that would be fine with me.

You don't need to be maintainer if you don't want to. :-) The problem is that ports with no mainatiner seem to bitrot as nobody feels responsible for them, and already 46% of our ports have no maintainer. By being a port's maintainer, you're saying that you will keep it updated and be a point of contact for users having questions about the MacPorts-specific aspects of the software. You would still need to file tickets to effect those updates, unless you want to request commit access to the repository.

Then I would suggest that you enter my email address as maintainer and add the ports to the repository. I will then request access to the repository.

  • It looks like the variant "wms" doesn't do anything so it should be removed.

It adds a necessary dependency for wms. I wanted this category just to make it explicit.

But the wms variant doesn't do anything. It only contains the comment "--with-wms is enabled by default". The description of the variant reads "Enable Web Map Service" but that's not what the variant does. Regardless of whether I install mapserver +proj or mapserver +proj +wms I get exactly the same software which has wms enabled. So the wms variant should go away. If there is value in allowing wms to be disabled, then you could add a variant no_wms which appends the configure argument --without-wms. Is there a reason why anyone would want to disable wms?

No, but wms depends on proj and if somebody wanted to enable wms (s)he would have to add the proj variant. --with-wms is given per default but will only be considered if there is proj support as well. Since I did not regard this as intuitive I have added the wms variant. As an alternative the proj variant could be renamed to wmsproj or so.

comment:8 Changed 12 years ago by mf2k (Frank Schima)

Port: mapserver grass gdal-grass added

mapserver port added in r41898 and modified in r41899. Hopefully I satisfied all parties. :)

comment:9 Changed 12 years ago by mf2k (Frank Schima)

Cc: macsforever2000@… added

Cc Me!

comment:10 Changed 12 years ago by mf2k (Frank Schima)

I could use a suggestion about the grass port. Currently it violates the mtree and it seems something better should be done for that. Attaching my mods to the portfile.

Changed 12 years ago by mf2k (Frank Schima)

Attachment: patch-configure.diff added

Changed 12 years ago by mf2k (Frank Schima)

Attachment: patch-Makefile.diff added

Changed 12 years ago by mf2k (Frank Schima)

Attachment: Portfile.grass added

comment:11 Changed 12 years ago by blb@…

Attaching a tarball with my attempt for grass. It builds the unix-style grass, not the Mac app, as the Mac app it built here properly installs into the destroot but is missing the Info.plist file that Mac OS X expects and therefore doesn't run. Also enabled parallel builds as it built fine several times with it enabled.

Changed 12 years ago by blb@…

Attachment: grass.tar.bz2 added

grass port

Changed 12 years ago by mf2k (Frank Schima)

Attachment: Portfile.2.grass added

My latest version of the grass portfile based on blb's changes. Fixed variants. Fixed dependencies.

comment:12 Changed 12 years ago by mf2k (Frank Schima)

grass added r42393.

Changed 12 years ago by mf2k (Frank Schima)

Attachment: Portfile.gdal-grass added

I'm not able to get gdal-grass to install. Here's my modified version of the portfile. Any ideas would be appreciated!

comment:13 Changed 11 years ago by jmroot (Joshua Root)

Type: enhancementsubmission

comment:14 Changed 11 years ago by (none)

Milestone: Port Submissions

Milestone Port Submissions deleted

comment:15 Changed 11 years ago by raimue (Rainer Müller)

Keywords: lack-of-interest added

comment:16 Changed 10 years ago by raimue (Rainer Müller)

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.