Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#16335 closed defect (duplicate)

frotz: declares dependency on ncurses port but uses system ncurses

Reported by: ryandesign (Ryan Schmidt) Owned by: pack-darwinports@…
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: Cc:
Port:

Description

frotz should use the MacPorts ncurses library, not the system's.

$ otool -L /opt/local/bin/frotz
/opt/local/bin/frotz:
	/usr/lib/libncurses.5.4.dylib (compatibility version 5.4.0, current version 5.4.0)
	/usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 111.1.1)

Change History (3)

comment:1 Changed 12 years ago by milosh@…

There is a patch for this issue with #12152 (patch which wasn't applied fully in r30512...)

comment:2 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Indeed, this is a duplicate of #12152.

comment:3 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.