Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#16381 closed defect (worksforme)

incorrect directory for local openmotif port package

Reported by: john_conklin@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: openmotif Cc: raimue (Rainer Müller), ryandesign (Ryan Schmidt)
Port:

Description

installing openmotif (or a package that relies on it), gives the following error: " ---> Verifying checksum(s) for openmotif Error: Target org.macports.checksum returned: Could not open file: /opt/local/var/macports/distfiles/openmotif/2.3.0-final/openmotif-2.3.0.tar.gz Error: The following dependencies failed to build: openmotif Error: Status 1 encountered during processing. "

I went to '/opt/local/var/macports/distfiles/openmotif/' only the 'openmotif-2.3.0.tar.gz' file was there so I created a '2.3.0-final' directory and moved the .gz file into the new directory so it matched the path in the errored pathname. After that the build worked fine.

Change History (4)

comment:1 Changed 12 years ago by raimue (Rainer Müller)

Cc: raimue@… added
Keywords: openmotif added
Milestone: Port Bugs

I can't reproduce here.

$ sudo port clean --dist openmotif
$ find /opt/local/var/macports/distfiles/openmotif
find: /opt/local/var/macports/distfiles/openmotif: No such file or directory
$ sudo port -f fetch openmotif
--->  Fetching openmotif
--->  Attempting to fetch openmotif-2.3.0.tar.gz from http://distfiles.macports.org/openmotif/2.3.0-final
$ find /opt/local/var/macports/distfiles/openmotif
/opt/local/var/macports/distfiles/openmotif
/opt/local/var/macports/distfiles/openmotif/2.3.0-final
/opt/local/var/macports/distfiles/openmotif/2.3.0-final/openmotif-2.3.0.tar.gz

Is it possible that you did a 'port fetch openmotif' before the dist_subdir was added in r28155?

comment:2 Changed 12 years ago by john_conklin@…

Not explicitly but perhaps equivalently. The chains of events is that I was attempting to install the ddd package ("sudo port install ddd") and the installation stopped at said error. I performed selfupdate and tried installing openmotif again but had the same error until the stated fix. I originally installed macports before the r28155 release with openmotif installed (for xephem).

comment:3 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: worksforme
Status: newclosed

I can't reproduce the issue here either; it works fine. Since you got it working, no need to probe further. But something probably needed to have been cleaned.

sudo port clean --work openmotif

or

sudo port clean --all openmotif

would probably have done it.

comment:4 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.