Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#16531 closed defect (duplicate)

mysql5 secure installation

Reported by: darren.weber.lists@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: mysql install secure root password Cc: jyrkiwahlstedt
Port: mysql5, mysql5-devel

Description

I think we need a symbolic link for mysql in /opt/local/bin/mysql so that basic config scripts will work. I guess this can screw up installation of multiple versions, but that can be handled by having some meta scripts to set the preferred alternative or current working version. In this ticket, I just want to highlight that the secure installation fails because it cannot find the mysql command (maybe there is an easy solution for this):

[ dweber@elegans ~ ]$ sudo /opt/local/lib/mysql5/bin/mysql_secure_installation




NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MySQL
      SERVERS IN PRODUCTION USE!  PLEASE READ EACH STEP CAREFULLY!


In order to log into MySQL to secure it, we'll need the current
password for the root user.  If you've just installed MySQL, and
you haven't set the root password yet, the password will be blank,
so you should just press enter here.

Enter current password for root (enter for none): 
/opt/local/lib/mysql5/bin/mysql_secure_installation: line 42: mysql: command not found
OK, successfully used password, moving on...

Setting the root password ensures that nobody can log into the MySQL
root user without the proper authorisation.

Set root password? [Y/n] 
New password: 
Re-enter new password: 
/opt/local/lib/mysql5/bin/mysql_secure_installation: line 42: mysql: command not found
Password update failed!
[ dweber@elegans ~ ]$ 

Change History (4)

comment:1 Changed 12 years ago by darren.weber.lists@…

Just a quick follow-up note:

[ dweber@elegans ~ ]$ which mysql
[ dweber@elegans ~ ]$ which mysql5
/opt/local/bin/mysql5
[ dweber@elegans ~ ]$ 

comment:2 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: jwa@… added; ryandesign@… removed
Owner: changed from macports-tickets@… to ryandesign@…
Port: mysql5-devel added; +server removed
Status: newassigned

comment:3 in reply to:  description Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Replying to darren.weber.lists@…:

I think we need a symbolic link for mysql in /opt/local/bin/mysql so that basic config scripts will work. I guess this can screw up installation of multiple versions,

Installation of multiple versions is already screwed, though I would rather unscrew it than screw it more. :-)

but that can be handled by having some meta scripts to set the preferred alternative or current working version.

You mean like select? We could create a mysql_select port using select. However if the goal is to be able to type just "mysql" at the command line and have it launch mysql, then the way to do that currently is to add /opt/local/lib/mysql5/bin to your $PATH.

In this ticket, I just want to highlight that the secure installation fails because it cannot find the mysql command (maybe there is an easy solution for this):

Duplicate of #14600. We should patch mysql_secure_installation.

comment:4 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.