Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#16554 closed defect (fixed)

Gnucash 2.2.5_1 does not build due to typos in gnc-module.c and gnc-exp-parser.c

Reported by: pgijnxn02@… Owned by: mf2k (Frank Schima)
Priority: Normal Milestone:
Component: ports Version: 1.7.0
Keywords: build, typo Cc: jmroot (Joshua Root)
Port: gnucash

Description

An extra < at the top of the files prevents gnucash from building.

error: <guile16/gh.h: No such file or directory

Removing the extra < resulted in success. Unfortunately I didn't think to capture a diff for you.

Attachments (2)

gnucash-Portfile.diff (820 bytes) - added by illogical1@… 12 years ago.
diff against gnucash portfile with proposed fix
Portfile (4.6 KB) - added by illogical1@… 12 years ago.
Actual portfile so user can test if Portfile works

Download all attachments as: .zip

Change History (10)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Cc: jmr@… added

I can't reproduce this. If there's a problem, it would be in the reinplace on line 66 of the Portfile. You don't have any local modifications? Can you tweak the reinplace expression to get it to work?

comment:2 Changed 12 years ago by pgijnxn02@…

My Portfile line 66: reinplace "s|\\<guile\\/|\<guile16\\/|g" ${src_file}

I see that there are two
before <guile and only one \ before <guile16. Would that do it?

I don't have local modifications. What other information would be useful?

comment:3 in reply to:  2 Changed 12 years ago by pgijnxn02@…

This remains true in 2.2.7_1. gnc-module.c and gnc-exp-parser.c won't build until I modify the <guile16/gh.h line in each. After that, they're fine.

Changed 12 years ago by illogical1@…

Attachment: gnucash-Portfile.diff added

diff against gnucash portfile with proposed fix

Changed 12 years ago by illogical1@…

Attachment: Portfile added

Actual portfile so user can test if Portfile works

comment:4 Changed 12 years ago by pgijnxn02@…

Great, thanks!

Unfortunately I can't test this at the moment because it's not building for other reasons: the dependency gnome-desktop needs xrandr 1.2, which I don't seem to have, so it doesn't build.

...unless you know of a way to update my version of xrandr? I have Tiger 10.4.11 on PPC. But we're getting a bit off-topic now, aren't we? :)

comment:5 Changed 12 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to macsforever2000@…
Status: newassigned

comment:6 Changed 12 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: assignedclosed

Committed revision r40485. Strangely it always worked for me without the patch, but adding this patch does not hurt anything for me. Thanks!

comment:7 Changed 12 years ago by pgijnxn02@…

Works for me now :)

comment:8 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.