Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#16718 closed defect (fixed)

objc_encoding.m does not compile

Reported by: milosh@… Owned by: tobypeterson
Priority: Normal Milestone: MacPorts 1.7.0
Component: base Version: 1.7.0
Keywords: Cc:
Port:

Description (last modified by blb@…)

compiling macports trunk fails with

objc_encoding.m:45:20: warning: ctypes.h: No such file or directory
objc_encoding.m: In function ‘objc_to_tclobj’:
objc_encoding.m:59: error: ‘intptr_t’ undeclared (first use in this function)
objc_encoding.m:59: error: (Each undeclared identifier is reported only once
objc_encoding.m:59: error: for each function it appears in.)
objc_encoding.m:59: error: expected ‘)’ before ‘val’
make: *** [objc_encoding.o] Error 1

Regression caused by r40058. Note: uname -a Linux 2.6.26-1-686 #1 SMP ... i686 GNU/Linux

Change History (8)

comment:1 Changed 11 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to toby@…

comment:2 Changed 11 years ago by blb@…

Description: modified (diff)

Isn't intptr_t C99-only?

comment:3 Changed 11 years ago by tobypeterson

Linux?

comment:4 Changed 11 years ago by tobypeterson

Is it defined in a header on your system, perhaps stdint.h ? Seems like it'd be harmless enough to start including it. I only tested on 10.5/10.6

comment:5 Changed 11 years ago by milosh@…

Yep, adding a

#include <stdint.h>

makes intptr_t known.

comment:6 Changed 11 years ago by tobypeterson

Resolution: fixed
Status: newclosed

Added #include <stdint.h> to objc_encoding.m and Pextlib.c in r40476

comment:7 Changed 11 years ago by tobypeterson

Milestone: MacPorts base bugsMacPorts Future

Milestone MacPorts base bugs deleted

comment:8 Changed 10 years ago by jmroot (Joshua Root)

Milestone: MacPorts FutureMacPorts 1.7.0
Note: See TracTickets for help on using tickets.