Opened 13 years ago

Closed 11 years ago

Last modified 11 years ago

#16720 closed defect (worksforme)

gnome-desktop 2.24.0 build failure

Reported by: vinc17@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: kschombu@…, pgijnxn02@…, lists@…, aetherknight@…, fhwi93ne@…, dbonde+bugs+macosforge.org@…, jwhowse4, lev_@…, tmdias@…, gale@…, MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: gnome-desktop

Description

I get the following error when I want to upgrade gnome-desktop:

 /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I.. -DGNOMELOCALEDIR=\"/opt/local/share/locale\" -DGNOME_DESKTOP_SYSCONFDIR=\"/opt/local/etc\" -DGNOME_DESKTOP_PIXMAPDIR=\"/opt/local/share/pixmaps\" -DGNOME_DESKTOP_ICONDIR=\"/opt/local/share/icons\" -DGNOME_CORE_INTERNAL -DDATADIR=\"/opt/local/share/gnome-desktop\" -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare -I/usr/X11R6/include -DXTHREADS -DORBIT2=1 -D_REENTRANT -I/opt/local/include/libxml2 -I/opt/local/include/gtk-2.0 -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/lib/gtk-2.0/include -I/opt/local/include/atk-1.0 -I/opt/local/include/cairo -I/opt/local/include/pango-1.0 -I/opt/local/include/pixman-1 -I/opt/local/include/freetype2 -I/opt/local/include/libpng12 -I/usr/X11R6/include -I/opt/local/include/libgnomeui-2.0 -I/opt/local/include/libart-2.0 -I/opt/local/include/gconf/2 -I/opt/local/include/gnome-keyring-1 -I/opt/local/include/libgnome-2.0 -I/opt/local/include/libbonoboui-2.0 -I/opt/local/include/libgnomecanvas-2.0 -I/opt/local/include/gnome-vfs-2.0 -I/opt/local/lib/gnome-vfs-2.0/include -I/opt/local/include/orbit-2.0 -I/opt/local/include/dbus-1.0 -I/opt/local/lib/dbus-1.0/include -I/opt/local/include/libbonobo-2.0 -I/opt/local/include/bonobo-activation-2.0 -I/opt/local/include/gail-1.0 -I/opt/local/include/startup-notification-1.0 -I/opt/local/include -O2 -MT gnome-rr.lo -MD -MP -MF .deps/gnome-rr.Tpo -c gnome-rr.c  -fno-common -DPIC -o .libs/gnome-rr.o
gnome-rr.c:46: error: parse error before 'XRRScreenResources'
gnome-rr.c:46: warning: no semicolon at end of struct or union
gnome-rr.c:53: error: parse error before '}' token
gnome-rr.c:73: error: parse error before 'RROutput'
gnome-rr.c:73: warning: no semicolon at end of struct or union
gnome-rr.c:85: error: parse error before '}' token
[...]

Attachments (1)

Portfile.2.23.3 (1.5 KB) - added by pgijnxn02@… 13 years ago.
gnome-desktop 2.23.3 Portfile

Download all attachments as: .zip

Change History (33)

comment:1 Changed 13 years ago by vinc17@…

This was under Mac OS X 10.4.11. I've looked as the preprocessed output, and the problem is that XRRScreenResources is never defined. This seems to be the same problem as http://live.gnome.org/JhbuildIssues/gnome-desktop. It is said that libXrandr >= 1.2 is needed.

comment:2 in reply to:  1 Changed 13 years ago by kschombu@…

I am experiencing the same problem and I have libXrandr 2.1.0 installed. When I try to compile gnome-rr.c using the command in the original post I get exact same errors.

However, when installing gnome-desktop via the port command I get a different set of errors:

> sudo port instal gnome-desktop

--->  Fetching gnome-desktop
--->  Verifying checksum(s) for gnome-desktop
--->  Extracting gnome-desktop
--->  Configuring gnome-desktop
--->  Building gnome-desktop with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-desktop/work/gnome-desktop-2.24.0" && make all " returned error 2
Command output: gnome-rr.c:1111: error: dereferencing pointer to incomplete type
gnome-rr.c: At top level:
gnome-rr.c:1117: error: syntax error before 'RRMode'
gnome-rr.c:1118: warning: 'mode_new' was used with no prototype before its definition
gnome-rr.c: In function 'mode_new':
gnome-rr.c:1119: error: invalid application of 'sizeof' to incomplete type 'GnomeRRMode' 
gnome-rr.c:1121: error: dereferencing pointer to incomplete type
gnome-rr.c:1121: error: 'id' undeclared (first use in this function)
gnome-rr.c:1122: error: dereferencing pointer to incomplete type
gnome-rr.c:1122: error: 'info' undeclared (first use in this function)
gnome-rr.c: In function 'gnome_rr_mode_get_id':
gnome-rr.c:1131: error: dereferencing pointer to incomplete type
gnome-rr.c: In function 'gnome_rr_mode_get_width':
gnome-rr.c:1138: error: dereferencing pointer to incomplete type
gnome-rr.c: In function 'gnome_rr_mode_get_freq':
gnome-rr.c:1145: error: dereferencing pointer to incomplete type
gnome-rr.c: In function 'gnome_rr_mode_get_height':
gnome-rr.c:1152: error: dereferencing pointer to incomplete type
gnome-rr.c: At top level:
gnome-rr.c:1156: error: syntax error before 'XRRModeInfo'
gnome-rr.c:1157: warning: 'mode_initialize' was used with no prototype before its definition
gnome-rr.c: In function 'mode_initialize':
gnome-rr.c:1158: error: 'mode' undeclared (first use in this function)
gnome-rr.c:1159: error: 'info' undeclared (first use in this function)
gnome-rr.c: In function 'mode_free':
gnome-rr.c:1170: error: dereferencing pointer to incomplete type
make[3]: *** [gnome-rr.lo] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Status 1 encountered during processing.

comment:3 Changed 13 years ago by kschombu@…

(duplicate comment removed by admin)

comment:4 Changed 13 years ago by kschombu@…

Cc: kschombu@… added

Cc Me!

comment:5 Changed 13 years ago by pgijnxn02@…

Cc: pgijnxn02@… added

Cc Me!

comment:6 Changed 13 years ago by pgijnxn02@…

Here's the upstream gnome bug.

I will attempt to install a newer X Server to solve this.

comment:7 Changed 13 years ago by pgijnxn02@…

Alas, it appears there's no way to upgrade the X Server in Tiger. Is that correct?

Changed 13 years ago by pgijnxn02@…

Attachment: Portfile.2.23.3 added

gnome-desktop 2.23.3 Portfile

comment:8 Changed 13 years ago by pgijnxn02@…

Since eel requires at least gnome-desktop 2.23.3, here's a Portfile to use as a workaround. The only changes I've made from the 2.22.3 Portfile are the version number and the checksum.

comment:9 in reply to:  description Changed 13 years ago by lists@…

I'm experiencing the same thing on Leopard 10.5.5.

I've replaced the portfile with the attached one, and get:

Unable to execute port: extra characters after close-quote

The error with the official Portfile:

--->  Building gnome-desktop
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-desktop/work/gnome-desktop-2.24.0" && make all " returned error 2
Command output: gnome-rr.c:1111: error: dereferencing pointer to incomplete type
gnome-rr.c: At top level:
gnome-rr.c:1117: error: syntax error before 'RRMode'
gnome-rr.c:1118: warning: 'mode_new' was used with no prototype before its definition
gnome-rr.c: In function 'mode_new':
gnome-rr.c:1119: error: invalid application of 'sizeof' to incomplete type 'GnomeRRMode' 
gnome-rr.c:1121: error: dereferencing pointer to incomplete type
gnome-rr.c:1121: error: 'id' undeclared (first use in this function)
gnome-rr.c:1122: error: dereferencing pointer to incomplete type
gnome-rr.c:1122: error: 'info' undeclared (first use in this function)
gnome-rr.c: In function 'gnome_rr_mode_get_id':
gnome-rr.c:1131: error: dereferencing pointer to incomplete type
gnome-rr.c: In function 'gnome_rr_mode_get_width':
gnome-rr.c:1138: error: dereferencing pointer to incomplete type
gnome-rr.c: In function 'gnome_rr_mode_get_freq':
gnome-rr.c:1145: error: dereferencing pointer to incomplete type
gnome-rr.c: In function 'gnome_rr_mode_get_height':
gnome-rr.c:1152: error: dereferencing pointer to incomplete type
gnome-rr.c: At top level:
gnome-rr.c:1156: error: syntax error before 'XRRModeInfo'
gnome-rr.c:1157: warning: 'mode_initialize' was used with no prototype before its definition
gnome-rr.c: In function 'mode_initialize':
gnome-rr.c:1158: error: 'mode' undeclared (first use in this function)
gnome-rr.c:1159: error: 'info' undeclared (first use in this function)
gnome-rr.c: In function 'mode_free':
gnome-rr.c:1170: error: dereferencing pointer to incomplete type
make[3]: *** [gnome-rr.lo] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Status 1 encountered during processing.

comment:10 Changed 13 years ago by lists@…

Cc: lists@… added

Cc Me!

comment:11 Changed 13 years ago by mp@…

Installing version 2.3.1 of XQuartz on my MBP running OSX 10.5.5 has fixed the problem for me, but I guess this isn't really helpful for Tiger users...

comment:12 Changed 13 years ago by aetherknight@…

Cc: aetherknight@… added

Cc Me!

comment:13 Changed 13 years ago by fhwi93ne@…

Cc: fhwi93ne@… added

Cc Me!

comment:14 Changed 13 years ago by dbonde+bugs+macosforge.org@…

Cc: dbonde+bugs+macosforge.org@… added

Cc Me!

comment:15 Changed 13 years ago by jwhowse4

Cc: jwhowse4@… added

Cc Me!

comment:16 Changed 13 years ago by blb@…

Cc: lev_@… added

Cc reporter of dup #16987.

comment:17 Changed 13 years ago by pgijnxn02@…

This bug is still present in 2.24.1 ... which I would expect since the upstream bug is still unresolved.

comment:18 in reply to:  17 Changed 13 years ago by macports@…

Bug still present for me. Attached ports file fixed issue for me.

comment:19 Changed 13 years ago by bluegod@…

I had the same issue, solved with the attached port file (but that means downgrade gnome!)

comment:20 Changed 13 years ago by jmroot (Joshua Root)

Does installing xorg-randrproto help at all?

comment:21 Changed 13 years ago by pgijnxn02@…

Installing xorg-randrproto did not solve it for me.

Current result:

Command output: gnome-rr.c: In function 'mode_new':
gnome-rr.c:1123: error: invalid application of 'sizeof' to incomplete type 'GnomeRRMode'
gnome-rr.c:1125: error: dereferencing pointer to incomplete type
gnome-rr.c:1125: error: 'id' undeclared (first use in this function)
gnome-rr.c:1126: error: dereferencing pointer to incomplete type
gnome-rr.c:1126: error: 'info' undeclared (first use in this function)
gnome-rr.c: In function 'gnome_rr_mode_get_id':
gnome-rr.c:1135: error: dereferencing pointer to incomplete type
gnome-rr.c: In function 'gnome_rr_mode_get_width':
gnome-rr.c:1142: error: dereferencing pointer to incomplete type
gnome-rr.c: In function 'gnome_rr_mode_get_freq':
gnome-rr.c:1149: error: dereferencing pointer to incomplete type
gnome-rr.c: In function 'gnome_rr_mode_get_height':
gnome-rr.c:1156: error: dereferencing pointer to incomplete type
gnome-rr.c: At top level:
gnome-rr.c:1160: error: parse error before 'XRRModeInfo'
gnome-rr.c:1161: warning: 'mode_initialize' was used with no prototype before its definition
gnome-rr.c: In function 'mode_initialize':
gnome-rr.c:1162: error: 'mode' undeclared (first use in this function)
gnome-rr.c:1163: error: 'info' undeclared (first use in this function)
gnome-rr.c: In function 'mode_free':
gnome-rr.c:1174: error: dereferencing pointer to incomplete type

comment:22 Changed 13 years ago by pgijnxn02@…

I had this problem, and gnome-desktop 2.24.2_0 now builds for me.

comment:23 in reply to:  22 Changed 13 years ago by vinc17@…

Replying to pgijnxn02@…:

I had this problem, and gnome-desktop 2.24.2_0 now builds for me.

Here it still fails.

comment:24 Changed 13 years ago by tmdias@…

Cc: tmdias@… added

Cc Me!

comment:25 Changed 13 years ago by gale@…

Several months have passed. It is looking doubtful that upstream will backport to support older X servers.

Since we have little control over our X servers, I think unfortunately there is no choice but to downgrade gnome-desktop until every version of OSX that we support has an X server with XRandR 1.2. Or until upstream fixes this, if they ever do.

Perhaps there is some other solution, using variants or something. It sounds tricky to me though.

This has been blocking other ports for a long time. We need to take some action now to clear up the logjam.

comment:26 Changed 13 years ago by gale@…

Cc: gale@… added

Cc Me!

comment:27 Changed 13 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: mcalhoun@… added

Cc Me!

comment:28 in reply to:  25 Changed 13 years ago by vinc17@…

Replying to gale@…:

Since we have little control over our X servers, I think unfortunately there is no choice but to downgrade gnome-desktop until every version of OSX that we support has an X server with XRandR 1.2. Or until upstream fixes this, if they ever do.

IMHO, it's more a problem with an X library than with an X server: the X server can be on a remote machine (which is not necessarily a Mac OS X machine), and I don't see how a remote machine can affect the build of a MacPorts port. Now, if we do not control the X server, perhaps we can control the libraries, e.g. how about all those xorg* ports?

comment:29 Changed 13 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:30 Changed 11 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to devans@…

comment:31 Changed 11 years ago by dbevans (David B. Evans)

Resolution: worksforme
Status: newclosed

Can't reproduce problem with current port version 2.30.2. Assuming ticket is outdated.

comment:32 Changed 11 years ago by vinc17@…

Yes, it was outdated.

Note: See TracTickets for help on using tickets.