Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#16738 closed update (fixed)

transmission-x11 1.34 : new release

Reported by: neric27@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: raimue (Rainer Müller)
Port: transmission-x11

Description

transmission 1.34 is available. Attached an updated Portfile.

transmission used to be split between 2 ports :

  • transmission : build the aqua version
  • transmission-x11: build the command-line and gtk version

Why not merge them and use variants instead ?

NOTE : The aqua front-end (port transmission) doesn't build on OS X Tiger (requires XCode 3), so I can't test it, but I can provide a tentative Portfile.

Attachments (1)

transmission-x11.diff (1.6 KB) - added by neric27@… 12 years ago.
unified diff, no aqua variant

Download all attachments as: .zip

Change History (9)

comment:1 Changed 12 years ago by neric27@…

Maybe I should make the gtk variant default...

comment:2 Changed 12 years ago by raimue (Rainer Müller)

Cc: raimue@… added

Patch does not apply:

~/src/macports/trunk/dports/net/transmission-x11 $ patch Portfile < transmission-x11.diff 
patching file Portfile
patch: **** unexpected end of file in patch at line 37

Could you please generate it as a unified diff using diff -u?

comment:3 Changed 12 years ago by neric27@…

Hope this time it works !

Changed 12 years ago by neric27@…

Attachment: transmission-x11.diff added

unified diff, no aqua variant

comment:4 Changed 12 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: newclosed

I'm closing this ticket. The port appears to have been updated by revision r40957.

comment:5 Changed 12 years ago by jmroot (Joshua Root)

Type: enhancementupdate

comment:6 Changed 12 years ago by (none)

Milestone: Port Updates

Milestone Port Updates deleted

comment:7 in reply to:  description Changed 11 years ago by ryandesign (Ryan Schmidt)

Replying to neric27@…:

NOTE : The aqua front-end (port transmission) doesn't build on OS X Tiger (requires XCode 3), so I can't test it, but I can provide a tentative Portfile.

r40947 made the port require Leopard exactly; I changed it in r54522 to allow Leopard or later (though I did not test it).

comment:8 Changed 11 years ago by neric27@…

That's just fine, thank you !

Note: See TracTickets for help on using tickets.