Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#16760 closed defect (fixed)

Pidgin 2.5.1 fails to compile

Reported by: tafinho@… Owned by: simon@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: pidgin compile Cc: darmish@…
Port: Pidgin

Description (last modified by simon@…)

Pidgin 2.5.1 fails to compile on a brand new port instalation.

log:

--->  Building pidgin with target all
/bin/sh ./config.status --recheck
running CONFIG_SHELL=/bin/sh /bin/sh ./configure  --prefix=/opt/local --disable-avahi --disable-consoleui --disable-gstreamer --disable-gtkspell --disable-meanwhile --disable-nm --disable-perl --disable-screensaver --disable-sm --disable-startup-notification --enable-nss --mandir=/opt/local/share/man --with-nspr-includes=/opt/local/include/nspr --with-nspr-libs=/opt/local/lib --with-nss-includes=/opt/local/include/nss --with-nss-libs=/opt/local/lib CC=/usr/bin/gcc-4.0 CFLAGS=-O2 LDFLAGS=-L/opt/local/lib -bind_at_load CPPFLAGS=-I/opt/local/include -no-cpp-precomp CPP=/usr/bin/cpp-4.0 CXX=/usr/bin/g++-4.0 CXXFLAGS=-O2 FFLAGS=-O2  --no-create --no-recursion
checking build system type... i386-apple-darwin9.5.0
checking host system type... i386-apple-darwin9.5.0
checking target system type... i386-apple-darwin9.5.0
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... ./install-sh -c -d
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... yes
checking for sed... /usr/bin/sed
checking for gcc... /usr/bin/gcc-4.0
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether /usr/bin/gcc-4.0 accepts -g... yes
checking for /usr/bin/gcc-4.0 option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of /usr/bin/gcc-4.0... gcc3
checking whether /usr/bin/gcc-4.0 and cc understand -c and -o together... yes
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for ld used by /usr/bin/gcc-4.0... /usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld
checking if the linker (/usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld) is GNU ld... no
checking for /usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -p
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking how to run the C preprocessor... /usr/bin/cpp-4.0
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking whether we are using the GNU C++ compiler... yes
checking whether /usr/bin/g++-4.0 accepts -g... yes
checking dependency style of /usr/bin/g++-4.0... gcc3
checking how to run the C++ preprocessor... /usr/bin/g++-4.0 -E
checking for g77... no
checking for xlf... no
checking for f77... no
checking for frt... no
checking for pgf77... no
checking for cf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for xlf90... no
checking for f90... no
checking for pgf90... no
checking for pghpf... no
checking for epcf90... no
checking for gfortran... no
checking for g95... no
checking for xlf95... no
checking for f95... no
checking for fort... no
checking for ifort... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for ftn... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether  accepts -g... no
checking the maximum length of command line arguments... 196608
checking command to parse /usr/bin/nm -p output from /usr/bin/gcc-4.0 object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if /usr/bin/gcc-4.0 supports -fno-rtti -fno-exceptions... no
checking for /usr/bin/gcc-4.0 option to produce PIC... -fno-common
checking if /usr/bin/gcc-4.0 PIC flag -fno-common works... yes
checking if /usr/bin/gcc-4.0 static flag -static works... no
checking if /usr/bin/gcc-4.0 supports -c -o file.o... yes
checking whether the /usr/bin/gcc-4.0 linker (/usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin9.5.0 dyld
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by /usr/bin/g++-4.0... /usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld
checking if the linker (/usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld) is GNU ld... no
checking whether the /usr/bin/g++-4.0 linker (/usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld) supports shared libraries... yes
checking for /usr/bin/g++-4.0 option to produce PIC... -fno-common
checking if /usr/bin/g++-4.0 PIC flag -fno-common works... yes
checking if /usr/bin/g++-4.0 static flag -static works... no
checking if /usr/bin/g++-4.0 supports -c -o file.o... yes
checking whether the /usr/bin/g++-4.0 linker (/usr/libexec/gcc/i686-apple-darwin9/4.0.1/ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin9.5.0 dyld
checking how to hardcode library paths into programs... immediate
appending configuration tag "F77" to libtool
checking for a BSD-compatible install... /usr/bin/install -c
./configure: line 19796: AC_PROG_INTLTOOL: command not found
./configure: line 19797: PKG_PROG_PKG_CONFIG: command not found
checking for working alloca.h... yes
checking for alloca... yes
checking for res_query in -lresolv... yes
checking CoreFoundation/CoreFoundation.h usability... yes
checking CoreFoundation/CoreFoundation.h presence... yes
checking for CoreFoundation/CoreFoundation.h... yes
checking IOKit/IOKitLib.h usability... yes
checking IOKit/IOKitLib.h presence... yes
checking for IOKit/IOKitLib.h... yes
./configure: line 20521: AM_GLIB_GNU_GETTEXT: command not found
configure: error:

The msgfmt command is required to build libpurple.  If it is installed
on your system, ensure that it is in your path.  If it is not, install
GNU gettext to continue.

If you have msgfmt installed, but for some reason this error message
is still displayed, you have encountered what appears to be a bug in
third-party configure macros.  Try setting the MSGFMT environment
variable to the absolute path to your msgfmt binary and trying
configure again, like this:

MSGFMT=/path/to/msgfmt ./configure ...

make: *** [config.status] Error 1
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_pidgin/work/pidgin-2.5.1" && make all " returned error 2
Command output: checking how to hardcode library paths into programs... immediate
appending configuration tag "F77" to libtool
checking for a BSD-compatible install... /usr/bin/install -c
./configure: line 19796: AC_PROG_INTLTOOL: command not found
./configure: line 19797: PKG_PROG_PKG_CONFIG: command not found
checking for working alloca.h... yes
checking for alloca... yes
checking for res_query in -lresolv... yes
checking CoreFoundation/CoreFoundation.h usability... yes
checking CoreFoundation/CoreFoundation.h presence... yes
checking for CoreFoundation/CoreFoundation.h... yes
checking IOKit/IOKitLib.h usability... yes
checking IOKit/IOKitLib.h presence... yes
checking for IOKit/IOKitLib.h... yes
./configure: line 20521: AM_GLIB_GNU_GETTEXT: command not found
configure: error:

The msgfmt command is required to build libpurple.  If it is installed
on your system, ensure that it is in your path.  If it is not, install
GNU gettext to continue.

If you have msgfmt installed, but for some reason this error message
is still displayed, you have encountered what appears to be a bug in
third-party configure macros.  Try setting the MSGFMT environment
variable to the absolute path to your msgfmt binary and trying
configure again, like this:

MSGFMT=/path/to/msgfmt ./configure ...

make: *** [config.status] Error 1

Warning: the following items did not execute (for pidgin): org.macports.activate org.macports.build org.macports.destroot org.macports.install

Change History (7)

comment:1 Changed 12 years ago by simon@…

Description: modified (diff)
Owner: changed from macports-tickets@… to simon@…

I don't understand this, msgfmt is installed by the gettext port which is installed by gtk2.
Please check if gettext is active (port installed gettext) and if msgfmt is available (which msgfmt).

Thanks,

Simon

comment:2 Changed 12 years ago by tafinho@…

I'm betting on a PATH problem, but here goes:

sudo port installed gettext The following ports are currently installed:

gettext @0.17_3 (active)

which msgfmt /opt/local/bin/msgfmt

comment:3 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: darmish@… added

comment:4 Changed 12 years ago by blb@…

A couple of questions:

  • does it succeed if you clean then try again (sudo port clean --work pidgin && sudo port install pidgin)?
  • what version of Xcode is installed?

comment:5 in reply to:  4 Changed 12 years ago by darmish@…

Replying to blb@…:

A couple of questions:

  • does it succeed if you clean then try again (sudo port clean --work pidgin && sudo port install pidgin)?
  • what version of Xcode is installed?

Yes it did install after running (sudo port clean --work pidgin && sudo port install pidgin), but now when I try to run it I get....

(pidgin:74350): Gdk-CRITICAL : gdk_display_get_name: assertion `GDK_IS_DISPLAY (display)' failed Pidgin 2.5.2

(pidgin:74350): WARNING : cannot open display: unset

comment:6 Changed 12 years ago by simon@…

Resolution: fixed
Status: newclosed

As the compile bug was fixed, I'm closing this as duplicate of #16995, please see there for more information.

Thanks,

Simon

comment:7 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.