Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#16935 closed defect (duplicate)

gmp 4.2.3 port does not have universal binary support

Reported by: illogic-al@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: gmp universal Cc: ryandesign (Ryan Schmidt)
Port: gmp

Description

gmp has the line 'universal_variant no' in its portfile. If removed gmp can actually compile a universal binary.

Change History (4)

comment:1 Changed 12 years ago by illogic-al@…

Resolution: fixed
Status: newclosed

fixed in r41020

comment:2 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Port: gmp added
Resolution: fixed
Status: closedreopened

Are you certain the universal variant now works? When I tried it last, it compiled but did not produce a usable gmp. Please see #15578.

comment:3 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: reopenedclosed

The universal variant does not work with gmp 4.2.3.

On PowerPC 10.4.11, configure does not complete:

checking if .align assembly directive is logarithmic... yes
checking whether compiler output is PIC by default... yes
checking if the assembler needs r on registers... configure: error: neither "mtctr 6" nor "mtctr r6" works

On Intel 10.4.11, configure and build succeed, but test fails as in #15578:

make  check-TESTS
PASS: t-asmtype
PASS: t-aors_1
PASS: t-divrem_1
PASS: t-fat
mpn_get_d wrong on 2^n
   bit      0
   exp      0
   want_bit 0
   sign     0
   n        =0x1
   nsize    1
   want     =[00 00 00 00 00 00 F0 3F] 1
   got      =[FE 07 00 00 00 00 00 00] 1.0108583113911904294e-320
FAIL: t-get_d
PASS: t-instrument
PASS: t-iord_u
PASS: t-mp_bases
PASS: t-perfsqr
PASS: t-scan
==================================
1 of 10 tests failed
Please report to gmp-bugs@swox.com
==================================
make[4]: *** [check-TESTS] Error 1
make[3]: *** [check-am] Error 2
make[2]: *** [check-recursive] Error 1
make[1]: *** [check-recursive] Error 1
make: *** [check] Error 2

Turned universal variant off again in r41062. Duplicate of #15578.

comment:4 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.