Opened 12 years ago

Closed 10 years ago

#17102 closed enhancement (fixed)

libgda's postgresql8 variant should depend on postgresql83

Reported by: nox@… Owned by: landonf (Landon Fuller)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: jyrkiwahlstedt, dbevans (David B. Evans), ryandesign (Ryan Schmidt)
Port: libgda libgda3 libgda4

Description

libgda's postgresql8 variant currently depend on postgresql80, I think it should depend on the latest stable version of PostgreSQL: postgresql83.

Attachments (1)

libgda-1.2.4_4.diff (646 bytes) - added by nox@… 12 years ago.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by nox@…

Attachment: libgda-1.2.4_4.diff added

comment:1 Changed 12 years ago by (none)

Milestone: Port Enhancements

Milestone Port Enhancements deleted

comment:2 Changed 11 years ago by blb@…

Port: postgresql83 removed

Or 8.4 now; or like some ports, make separate postgresql83 and postgresql84 variants...

comment:3 Changed 11 years ago by dbevans (David B. Evans)

Cc: jwa@… devans@… added
Port: libgda3 libgda4 added

The most current port of libgda is port libgda4 (stable version 4.0.3) which does in fact have the variant +with_postgresql83. Will look at adding an 8.4 version.

port libgda is very old (version 1.2.4) and should be removed as soon as its dependents are either updated or deleted themselves. So it makes no sense to spend much time adding new variants to this one, just moving its dependents to version 3 or 4 if possible.

port libgda3 (version 3.0.4) currently exists to support applications that work with version 3 but have not yet moved to version 4. It too should eventually be removed when the need has passed. It also has a +with_postgresql83 variant.

This all being the case, I think the premise of this ticket is moot.

maintainers libgda landonf

libgda3 jwa libgda4 jwa devans

comment:4 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: fixed
Status: newclosed

libgda currently uses postgresql 8.2 but declares a dependency on 8.0 so that certainly needs to be fixed. Updated the port to use 8.4 in r80031.

Note: See TracTickets for help on using tickets.